locked
Repeated 401 errors for every resource request RRS feed

Answers

  • User-1454326058 posted

    Hi jkjhse,

    Base on your reply, I think there are something error in the firefox developer tool or it has the different action.

    After clear the browser’s cache, the resources should be load from the server instead from the cache. The 200 status means this resource is loaded from the server.

    I suggest that you should post it to the firefox forum for response.

    Best Regards,

    Starain Chen

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Tuesday, August 19, 2014 3:58 AM

All replies

  • User-1454326058 posted

    Hi jkjhse,

    How do you get that issue? Could you reproduce that issue in a new project?

    If the issue occur when deploy the application to the IIS, please take a look at this link:

    # Using IIS Authentication with ASP.NET Impersonation

    http://msdn.microsoft.com/en-us/library/vstudio/134ec8tc(v=vs.100).aspx

    Please try to add the enough premission to everyone and try again.

    Thanks

    Best Regards

    Monday, August 11, 2014 5:56 AM
  • User895691971 posted

    This is not normal atleast for me. Getting 401 (Unauthorized; Unauthenticated) error is not a normal thing, seems like the server itself is trying to reject the connection. 

    Tuesday, August 12, 2014 4:20 AM
  • User325035487 posted

    I am using windows authentication, with enrypted access database. The connection string in the web.config is also encrypted by RSA container.

    Others have this issue too. Couldnt solve using what they suggest as I am no expert. See here : http://stackoverflow.com/questions/1222506/avoiding-401-response-for-each-request-using-ntlm

    I will update once I get to try out Starain's suggestion.

    Tuesday, August 12, 2014 6:01 AM
  • User-1454326058 posted

    Hi jkjhse,

    Try to add EveryOne and grant Read permission for these pictures (Security tab).

    Thanks

    Best Regards

    Tuesday, August 12, 2014 9:41 PM
  • User325035487 posted

    Its not permission issue. Still get 401 after i did what you suggested.

    I was able to try your previous suggestion today as I finally got my network admin to decrypt the web.config. But the moment I turned identity impersonate to true I started getting Server Error. So I turned it off. I am not getting this error in local environment (localhost) only when deployed to IIS

    Friday, August 15, 2014 4:14 AM
  • User-1454326058 posted

    Hi jkjhse,

    Did these images show if you clear the browser’s cache?

    Please use the Developer tool of IE to check the status of these request.

    On the other hand, please try to deploy it to the other IIS and check the result.

    Best Regards,

    Starain Chen

    Monday, August 18, 2014 4:36 AM
  • User325035487 posted

    These show whenever i clear the cache, or whenever i hit reload from the address bar using firefox.

    Please use the Developer tool of IE to check the status of these request.

    When I tried from Internet Explorer 11 developer tools I am not getting 401s, only 200s (opted to refresh from server always). I will check with another full IIS. IIS express in my development shows same error in firefox only. (I tried in Chrome v36 also now with no 401s with disabled cache.)

    I am assuming this has something to do with firefox developer tools?

    Monday, August 18, 2014 11:53 AM
  • User-1454326058 posted

    Hi jkjhse,

    Base on your reply, I think there are something error in the firefox developer tool or it has the different action.

    After clear the browser’s cache, the resources should be load from the server instead from the cache. The 200 status means this resource is loaded from the server.

    I suggest that you should post it to the firefox forum for response.

    Best Regards,

    Starain Chen

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Tuesday, August 19, 2014 3:58 AM