none
how install Microsoft .Net Framework Version 4.6.00081 ? RRS feed

  • Question

  • Hello,

     1 -I have portatil with WIN 7 ultimate 64bits  and i has installed VS2013 that point to Frameworks 4.6.00079  

    All EXE programs in managed code don´t run . (console, WinForm, WPF, no program run)

    2 - I have a Desktop PC with various disks with different windows.

    2-1-WIN 7 ultimate 64bits with visual studio 2013 that point to Frameworks 4.6.00081

    In this windows all EXE programs in managed code run without problems

    2-2-WIN 10 Profissional 64 bit with visual studio 2015 that point to frameworks 4.6.00079

    All EXE programs managed code don´t run

    SO, exist here a BIG, BIG BUG!!!! i need try substitute 00079 by 00081 for conclution (or not)

    Question: How i can install the version 4.6.0081 of frameworks?

    Thank

    PauloGoncalves

    

    

    Sunday, November 29, 2015 9:02 PM

All replies

  • It would be very unusual for differences between two minor subversions of a .NET Framework caused programs targeting that major version (4.6 in your case) to stop working.

    I suspect that your problem is with framework corruption, not a subversion difference.

    You said: "All EXE programs in managed code don´t run . (console, WinForm, WPF, no program run)".

    Do you see any error message(s)? If so, please quote them.

    Can you upload on of the failing .exe files to your OneDrive and post the link here so we can see what is going on?

    Monday, November 30, 2015 5:37 AM
  • Thanks for try help me,

    In all cases inside Visual Studio 2013 and 2015 in realise mode all programs runs correct. In debug mode i can make pauses and make breakpoints etc.

    After compile in realise mode i try run EXE file outside of visual studio and don't run.

    (I compile in framework 4.0, 4.0 Client, 4.5 and 4.5.1)

    No message are sent. Explore windows stay with "wait cursor" for long time and some times block the explorer window. 

    In Win7, task manager show all program that i try executed and i can't kill them.

    In Win10, Task Manager don't show programs but i now they are started because i can't recompile again (the file is in use)

    i will be going crazy?!?!?!?

    I work with Visual Studio .Net since first realise and i never have any problems 

    Help me resolve or understand

    PauloGoncalves

    Note; i make a copy of EXE program that no runs to my Job and there run withou problems!!! (WIN7 ultimate x86 with visual studio 2012)


    Monday, November 30, 2015 7:14 PM
  • Hi PauloGoncalves,

    Glad to hear you have had your issue resolved, And thanks for sharing us your result here.

    If you think pvdg42's reply is helpful, please mark his reply or your reply as the answer, it will benefit to other community members who have the same issue. It will be easier for them to search the solution.

    Have a nice day:)

    Best Regards,

    Wen


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.

    Click HERE to participate the survey.

    Tuesday, December 1, 2015 9:19 AM
    Moderator
  • hello,

    I'm very angry, a month later I discovered the problem !!!! It is the anti-virus "avast"  that blocking all executable .NET :(
    for other reasons i stopped "avast" an hour and in this time i run one my utility .net ........and Run ok (HUMM?!?!?!?)

    Then i tested in all my machines and i confirm, it is the avast.
    Are unbelievable the symptoms with avast connected:
     1 - the .NET executable does not run (and blocks the explorer)
     2 - i cannot not delete the executable (meaning that is running in background)
     3 - in Task Manager appears 3 executables (instances)
     4 - o cannot kill any instance. 

    Thanks

    PauloGoncalves

    Wednesday, December 23, 2015 6:22 PM