none
imx35_wince6_build_error RRS feed

  • Question

  • Hi all,
    I am building wince 6.0 using imx35 bsp.

    while doing sysgen after some time I am getting one build error.Please help me to solve the error.My log is below.

    GDIEX_MODULES= imaging
    IMAGING_COMPONENTS= img_ico img_tiff img_libtiff img_png img_libpng  img_pngencoder img_pngdecoder img_gif img_liblzw  img_gifencoder img_gifdecoder img_jpeg img_jpegfull img_jpegmem  img_jpegencoder img_jpegdecoder img_bmp  img_bmpencoder img_bmpdecoder
    IE_MODULES= iepeers iesample iectl msls31 mshtml mshta shdoclc shdocvw inetcpl msxml3 urlmon wininet jsproxy shlwapi uuid ieceext mlang
    SCRIPT_MODULES= jscript vbscript
    SERVERS_MODULES= asp httpd timesvc
    SHELLSDK_MODULES= aygshell
    AYGSHELL_COMPONENTS= aygshcore aygshhpc aygqvga
    SHELL_MODULES= explorer shcore ceshell qvgap
    CESHELL_COMPONENTS= ceshapi ceshui taskbarlist
    SHCORE_COMPONENTS= shcore path
    WCESHELLFE_MODULES= control ctlpnl cplmain AdvBacklight connpnl intlp stguip stdwavefiles bthpnl
    WCEAPPSFE_MODULES= pword pwd_res pwwiff office riched20
    DIRECTX_MODULES= strmbase quartz msrle32 icm msdmo wmvdmoe directdraw ddsamples
    QUARTZ_COMPONENTS=quartz0 quartz1 quartz2 quartz3 quartz4
    QUARTZ0_COMPONENTS=amutil fgctl filgraph
    QUARTZ1_COMPONENTS= waveout avimsr avidec mp3filter mpgsplit dmowrap image
    QUARTZ2_COMPONENTS=asyncrdr qtzbase  imgsink    smarttee
    QUARTZ3_COMPONENTS= asfwriter asfmuxcore wavein vidcap filcap
    QUARTZ4_COMPONENTS= buffilter colour
    DATASYNC_MODULES= cefobj repllog rapisrv eventrst rra_stm systemcpl udp2tcp wceload unload
    NETCFV35_MODULES= dotnetv35
    CEBUILD: Running sysgen -p dcom preproc
    Starting sysgen phase for project ( dcom )
    \WINCE600\build.err

    BLDDEMO: There were errors building nok

    nok - 1 error(s), 0 warning(s)
    ========== Build: 0 succeeded or up-to-date, 1 failed, 0 skipped ==========

    Thanks in advance.

    Monday, April 15, 2013 5:57 AM

Answers

All replies

  • Hi Rohith,

    Please try Clean Sysgen.

    Have you tried it?

    With Regards

    nadini

    Monday, April 15, 2013 6:29 AM
  • Hi nadini,

    I already tried clean sysgen

    Monday, April 15, 2013 7:09 AM
  • Hi Rohith,

    As the build is failing is sysgen Phase.Means its not entering into building of BSP.

    Its difficult to find out the reason.Try to build some other BSP(Ex:iMX27) with the same Visual Studio (Platform Builder).See weather it will get build or not.

    If with that also problem exists then try Build and Sysgen(Note:We should not use this build option(Build and Sysgen or Rebuild and clean Sysgen) more frequently as it may corrupt your  WinCE installation.

    Dear All,

    Correct me If my understanding is wrong.

    With Regards

    nadini

    Monday, April 15, 2013 8:47 AM
  • Hi Nadini,

    (Note:We should not use this build option(Build and Sysgen or Rebuild and clean Sysgen) more frequently as it may corrupt your  WinCE installation.

    Many people told me about this problem...

    But why you suggested him to try Build and Sysgen??

    Is there any specific reason? Because if simply he try that, he may need to re-install the entire WINCE...

    Thanks.

    With regards,

    Keshava G N


    Keshava G N ( keshavagn@iwavesystems.com ), Member - Technical, iWave Systems ( http://iwavesystems.com )


    • Edited by Keshava GN Monday, April 15, 2013 9:06 AM
    Monday, April 15, 2013 9:05 AM
  • Hi nadini,

    my platform builder is working fine.I tried imx35 with another one bsp.That's building fine.

    So what will be the problem.How I can debug it.

    Monday, April 15, 2013 9:08 AM
  • Hi Rohith,

    Ok.

    So I guess We need to try with "Build and Sysgen"

    I feel you need to take decision to go for it or not.Because as I told some times it will corrupt the WinCE installation.

    Just check with the Sysgen variables are properly selected.

    With Regards

    nadini



    • Edited by nadini Monday, April 15, 2013 10:31 AM
    Monday, April 15, 2013 10:29 AM
  • Hi Nadini,

    Let me why I need to do "Build and Sysgen"?

    Its first time I am building this new bsp.

    Monday, April 15, 2013 10:48 AM
  • Hi,

    You should check build.err (under WINCE600) to find the cause of the problem.

    Hope wince is properly installed. If on other machines the build is fine you might not have installed components properly.

    There should be no need to do build and sysgen. 

    Try pasting the build error from above mentioned file.

    Regards,

    Balaji. 


    Monday, April 15, 2013 11:01 AM
  • Hi Balaji,

    below is my build.err contents.

    E:\WINCE600\build.log(1) : error SYSGEN0000: error(s) in sysgen phase

    build.log file contains

    Copying fallite.*
    Copying fmdwrapperpdd.*
    Starting sysgen phase for project ( dcom ) 
    Found localized resources for Languages ( 0404 0407 0409 040C 0410 0411 0412 0413 0416 0419 041D 0804 0C0A) 

    Microsoft (R) Program Maintenance Utility Version CE-6.00.1893.0
    Copyright (C) Microsoft Corporation.  All rights reserved.

    Windows CE Version (Release) (Built on Jun 30 2006 16:52:46)
    makefile.def: Invoked with predefined settings:
    TARGETNAME: dummy
    TARGETTYPE: dummy
    RELEASETYPE: 
    TARGETLIBS: 
    SOURCELIBS: 
    makefile.def: Including E:\WINCE600\public\common\oak\misc\Sources.default
    makefile.def: BUILDROOT is E:\WINCE600\public\dcom\cesysgen
    makefile.def: Including E:\WINCE600\PUBLIC\DCOM\CESYSGEN\sources
    makefile.def: Including E:\WINCE600\public\common\oak\misc\Sources.CE
    Directory: E:\WINCE600\PUBLIC\DCOM\CESYSGEN
    TARGETNAME: dummy
    RELEASETYPE is not defined.  Using DEFAULT.
    makefile.def: Including E:\WINCE600\public\common\oak\misc\sources.ReleaseType_DEFAULT
    makefile(24) : fatal error U1036: syntax error : too many names to left of '='
    Stop.

    Monday, April 15, 2013 12:20 PM
  • Hi,

    Check the environment variables in your machine for suspected entries. Sometimes presence of certain env variables for other programs can cause these(especially QNX).

    Hopefully you haven't changed any makefiles in public directory.

    Otherwise a reinstall would be wise.

    Regards,

    Balaji.


    • Edited by balajitrv1 Monday, April 15, 2013 1:47 PM
    Monday, April 15, 2013 1:46 PM
  • it looks like some of the contents in make file is changed. It is not required to change any of the make files in CE build system.

    - Chandra

    Tuesday, April 16, 2013 6:23 AM
  • I solved it by changing the makefile.

    In make file missing of @ in some places .I added that and rebuilt.

    Now that error solved.some other error came.

    build.log contains 

    E:\WINCE600\OSDesigns\nok\nok\Wince600\nok_ARMV4I\cesysgen\sdk\lib\ARMV4I\retail\coredll.lib E:\WINCE600\public\dcom\oak\lib\ARMV4I\retail\dllhost.lib E:\WINCE600\public\dcom\oak\lib\ARMV4I\retail\common.lib E:\WINCE600\public\dcom\sdk\lib\ARMV4I\retail\uuid.lib E:\WINCE600\OSDesigns\nok\nok\Wince600\nok_ARMV4I\cesysgen\sdk\lib\ARMV4I\retail\ole32.lib E:\WINCE600\OSDesigns\nok\nok\Wince600\nok_ARMV4I\cesysgen\sdk\lib\ARMV4I\retail\coredll.lib E:\WINCE600\public\common\oak\lib\ARMV4I\retail\corelib0.lib E:\WINCE600\OSDesigns\nok\nok\Wince600\nok_ARMV4I\cesysgen\oak\lib\ARMV4I\retail\corelib1.lib 

    E:\WINCE600\OSDesigns\nok\nok\Wince600\nok_ARMV4I\cesysgen\oak\lib\ARMV4I\retail\dcomssd.exp 

    dcomssd.exp : error LNK2001: unresolved external symbol DCM_Deinit

    dcomssd.exp : error LNK2001: unresolved external symbol DCM_IOControl

    dcomssd.exp : error LNK2001: unresolved external symbol DCM_Init

    E:\WINCE600\OSDesigns\nok\nok\Wince600\nok_ARMV4I\cesysgen\oak\target\ARMV4I\retail\dcomssd.dll : fatal error LNK1120: 3 unresolved externals



    NMAKE : fatal error U1077: 'SysgenMake' : return code '0x2'

    Stop.

    Please help me to solve this.

    thanks in advance

    Tuesday, April 16, 2013 3:50 PM
  • Restore the makefile you changed to the original and remove all the TAB characters from the DCOM makefile.

    The problem is explained in detail here: http://guruce.com/blogpost/cloning-calibrui-in-windows-ce-60

    This error is caused by TAB characters in the makefile in \WINCE600\PUBLIC\DCOM\CESYSGEN. Remember that you should NEVER EVER change anything in the PUBLIC or PRIVATE folders? Well, this is an exception. There's simply no way around this bug without changing the TAB characters to spaces, so:

    1. Open \WINCE600\PUBLIC\DCOM\CESYSGEN\makefile. in Visual Studio 2008
    2. Press CTRL-R, CTRL-W (this will turn on "View White Space")
    3. Replace all TAB characters in the file (recognizable by the right arrow character) with spaces
    4. Save the file

    PS. NEVER EVER DO A BUILD AND SYSGEN, no matter what people tell you!

    See also: http://guruce.com/blogpost/how-to-remove-the-demonic-build-and-sysgen-commands-from-platform-builder-for-windows-embed


    Good luck,

    Michel Verhagen, eMVP
    Check out my blog: http://guruce.com/blog

    GuruCE
    Microsoft Embedded Partner
    http://guruce.com
    Consultancy, training and development services.


    Tuesday, April 16, 2013 11:51 PM
    Moderator
  • Hi 

    I solved that error but now I am facing other one error.

    build.log content is

    E:\WINCE600\PUBLIC\COMMON\CESYSGEN>NMAKE /nologo E:\WINCE600\PUBLIC\COMMON\OAK\LIB\ARMV4I\RETAIL\0409\xmllite.res  1>nul 
    Copying gwestubs.*
    Building combined gwes res file for 0419
    SysgenMake -RES2RES %GWES_RESOURCES% -fo E:\WINCE600\OSDesigns\nok\nok\Wince600\nok_ARMV4I\cesysgen\oak\target\ARMV4I\retail\0419\gwes.res
    Res2Res for Windows CE (Release) (Built on Jun 30 2006 16:52:50)
    Copyright (C) Microsoft Corp. 1991-2004.  All rights reserved.
    Res2Res: Ignoring "dummy"
    Res2Res: Using E:\WINCE600\public\common\oak\Bin\i386\R2RDUMMY.DLL for temp exe
    Res2Res: Using resources from E:\WINCE600\OSDesigns\nok\nok\calibrui\obj\ARMV4I\retail\0419\calibrui_clone.res.
    Res2Res: Adding resources from E:\WINCE600\OSDesigns\nok\nok\calibrui\obj\ARMV4I\retail\0419\calibrui_clone.res to C:\DOCUME~1\RANJIT~2.GLO\LOCALS~1\Temp\R2R22F2.tmp.
    ERROR: Res2Res: Could not open E:\WINCE600\OSDesigns\nok\nok\calibrui\obj\ARMV4I\retail\0419\calibrui_clone.res.
    Res2Res: Error adding resources (-1)


    NMAKE : fatal error U1077: 'SysgenMake' : return code '0x2'
    Stop

    please help me to solve this .

    thanks

    Wednesday, April 17, 2013 9:59 AM
  • Did you read the entire blog post at http://guruce.com/blogpost/cloning-calibrui-in-windows-ce-60?

    You're trying to clone CalibrUi, right? If so, the errors you describe are exactly as what is described in the blog post. Read it and follow the instructions. Everything is there to make it work...


    Good luck,

    Michel Verhagen, eMVP
    Check out my blog: http://guruce.com/blog

    GuruCE
    Microsoft Embedded Partner
    http://guruce.com
    Consultancy, training and development services.

    • Marked as answer by Rohith_88 Monday, May 13, 2013 5:21 AM
    Wednesday, April 17, 2013 10:01 AM
    Moderator