none
A particular Task is not running in task schdeuler at logon RRS feed

  • Question

  • Hi,

    I have 3 tasks scheduled in the Task Scheduler. Out of this, one task is not running in Windows Embedded Standard 7 OS.

    the error code seen in LastRunResult is (0x63). I have checked in internet for this error code but couldn't get the information.

    could anyone help me why this task is not executing?

    Regards, Prabu M

    Below is the screenshot of the Taskscheduler,

    Friday, November 20, 2015 1:10 PM

All replies

  • The only reference to task scheduler error codes is here: https://msdn.microsoft.com/en-gb/library/windows/desktop/aa383604(v=vs.85).aspx

    Can you share what the task is and how it is called?


    Sean Liming - Book Author: Starter Guide SIM (WEI), Pro Guide to WE8S & WES 7, Pro Guide to POS for .NET - www.annabooks.com / www.seanliming.com

    Friday, November 20, 2015 5:22 PM
    Moderator
  • Hi Sean,

    thanks for the reply.

    the task is to call the exe at logon of any user. the following is the command given to schedule the task.

    schtasks /create /tn "MyApplication" /sc onlogon /tr "cmd /c 'C:\Program Files\MyApplication\MyApplication.exe'" /run SYSTEM /f

    Saturday, November 21, 2015 8:12 AM
  • It has been a while since I did a scheduled task.

    1. Can you start MyApplication.exe manually after logon? My thought is if it doesn't run there might be something missing?

    2. Is it possible to run the EXE without calling cmd?

    3. What about using the Run registry key rather that task scheduler?


    Sean Liming - Book Author: Starter Guide SIM (WEI), Pro Guide to WE8S & WES 7, Pro Guide to POS for .NET - www.annabooks.com / www.seanliming.com

    Sunday, November 22, 2015 6:57 PM
    Moderator