locked
How to fix "OLE error code 0x8002801d: Library not registered"? RRS feed

  • Question

  • How to fix "OLE error code 0x8002801d: Library not registered"?

    when I click on the Tool\Code Reference menu in VFP 9.0 SP2 I get the above error.

    It was working in the Windows XP environment before the current Windows 10 environment.

    Tuesday, September 20, 2016 10:35 AM

Answers

  • Hi Maurice Gauldin,

    This article contains information that shows you how to fix Ole Error Code 0x8002801d Library Not Registered both (manually) and (automatically). Please refer that if it helps: http://easysoftwareuk.com/ole-error-code-0x8002801d-library-not-registered.htm

    Thank you for participating in the forum activities.

    Best Regards,

    Neda Zhang


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Wednesday, September 21, 2016 3:36 AM

All replies

  • Hi Maurice Gauldin,

    This article contains information that shows you how to fix Ole Error Code 0x8002801d Library Not Registered both (manually) and (automatically). Please refer that if it helps: http://easysoftwareuk.com/ole-error-code-0x8002801d-library-not-registered.htm

    Thank you for participating in the forum activities.

    Best Regards,

    Neda Zhang


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Wednesday, September 21, 2016 3:36 AM
  • Dear Neda;

         The link .....easysoftwareuk..... doesn't work anymore. Could you kindly provide the answer here?

    Best Regards

    Ming

    Thursday, January 30, 2020 4:25 AM
  • Code References is written in VFP and uses some of the ActiveX controls that came with VFP. Pretty sure the issue is that one of the controls it's using isn't registered. If you installed VFP from a CD (or an equivalent folder), that's odd, but you could look for information about installing the old standard ActiveX controls.

    Your better option is to forget Code References and switch to GoFish, which is available (along with a ton of other great VFP tools) at vfpx.org.

    Tamar

    Monday, February 3, 2020 9:34 PM
    Answerer
  • Dear Tamar

           Thank you for your kind reply. I'll try all of you advices.

    Best Regards

    Ming

    Friday, March 6, 2020 3:28 AM