locked
Missing Buttons on the Debug Toolbar RRS feed

  • Question

  • I am running Visual Studio 2005 (I have included the information from the Help | About dialog below so that you can see exactly what version I am running).

    My problem is this:

    I have turned on the "Debug" toolbar, but the only debug step control button that appears is the Step Over button. The Step In and Step Out buttons do not appear. Other developers in my office have all 3 of those buttons on the Debug toolbar, but for some reason I don't.  I'm on a new PC, but I know that in the past I've had all 3 of those buttons, because I use them a lot! It's hard to use the debugger when you can't easily step into code to debug it!

    How can I get those buttons back?

    If this is not the correct forum for this question, please let me know the correct one and I'll repost it.

    Thanks,

    Brad



    Microsoft Visual Studio 2005
    Version 8.0.50727.762  (SP.050727-7600)
    Microsoft .NET Framework
    Version 2.0.50727

    Installed Edition: Enterprise Architect

    Microsoft Visual Basic 2005   77637-163-9000005-41650
    Microsoft Visual Basic 2005

    Microsoft Visual C# 2005   77637-163-9000005-41650
    Microsoft Visual C# 2005

    Microsoft Visual C++ 2005   77637-163-9000005-41650
    Microsoft Visual C++ 2005

    Microsoft Visual J# 2005   77637-163-9000005-41650
    Microsoft Visual J# 2005

    Microsoft Visual Studio Tools for Office   77637-163-9000005-41650
    Microsoft Visual Studio Tools for the Microsoft Office System

    Microsoft Visual Web Developer 2005   77637-163-9000005-41650
    Microsoft Visual Web Developer 2005

    Visual Studio 2005 Team Edition for Architects   77637-163-9000005-41650
    Microsoft Visual Studio 2005 Team Edition for Software Architects

    Crystal Reports    AAC60-G0CSA4B-V7000AY
    Crystal Reports for Visual Studio 2005


    Microsoft Visual Studio 2005 Premier Partner Edition - ENU Service Pack 1 (KB926601)  
    This service pack is for Microsoft Visual Studio 2005 Premier Partner Edition - ENU.
    If you later install a more recent service pack, this service pack will be uninstalled automatically.
    For more information, visit http://support.microsoft.com/kb/926601

    SQL Server Analysis Services  
    Microsoft SQL Server Analysis Services Designer
    Version 9.00.1399.00

    SQL Server Integration Services  
    Microsoft SQL Server Integration Services Designer
    Version 9.00.1399.00

    SQL Server Reporting Services  
    Microsoft SQL Server Reporting Services Designers
    Version 9.00.1399.00
    Friday, February 16, 2007 7:33 PM

Answers

  • We've seen this come in from a few different sources.  Try going to the Import and Export Settings section and applying one of the default configurations (for C#/VB/C++/General).  Alternatively you can use the customize option to drag those commands back onto the toolbar,

    John

    Wednesday, February 21, 2007 11:41 PM
  • This one is not an easy fix to find <g>.  What I did was right click on the Debug toolbar.  Then click on the Rearrange Commands... button.  A new dialog pops up.  Select the toolbar radio button at the top and select debug in the drop down (should already be selected if you right-clicked the debug toolbar).  Then press the Add.. button.  Another dialog pops up. Select DEBUG in the categories listbox. Then just select the command(s) you want to add to the toolbar it will be added.  You can only select one at a time (waa..hoo...!).  Once you get the commands on the toolbar, then you can move them up or down to place them exactly where you want them.  Not exactly intuitive, but it works.
    Tuesday, February 27, 2007 5:45 PM

All replies

  • We've seen this come in from a few different sources.  Try going to the Import and Export Settings section and applying one of the default configurations (for C#/VB/C++/General).  Alternatively you can use the customize option to drag those commands back onto the toolbar,

    John

    Wednesday, February 21, 2007 11:41 PM
  • This one is not an easy fix to find <g>.  What I did was right click on the Debug toolbar.  Then click on the Rearrange Commands... button.  A new dialog pops up.  Select the toolbar radio button at the top and select debug in the drop down (should already be selected if you right-clicked the debug toolbar).  Then press the Add.. button.  Another dialog pops up. Select DEBUG in the categories listbox. Then just select the command(s) you want to add to the toolbar it will be added.  You can only select one at a time (waa..hoo...!).  Once you get the commands on the toolbar, then you can move them up or down to place them exactly where you want them.  Not exactly intuitive, but it works.
    Tuesday, February 27, 2007 5:45 PM
  • Thanks John,

    Worked beautifully.

    Craig
    • Proposed as answer by Samy I Wednesday, October 13, 2010 10:49 PM
    Friday, December 18, 2009 6:54 PM
  • For Visual Studio 2010, the steps are:

    1- right mouse click anywhere on the tools or click View menu, select toolbars,  and select the select customize

    2- A new window labeled “ will appear , click on the commands tab at the top

    3- select the "Toolbar:" radio button and choose "Debug" from the pull down list on the left. The box below will show you the controls which appear on your debug toolbar. Click the add-command button.

    4- A new window will appear labeled 'Add Command". select "Debug" from the categories on the left and scroll down on the right to choose what you want for example "Step out' and click the OK button

    5- Now you are back to the “customize” window, use the move up/down to place your choice where you want

    Happy debugging 

    Wednesday, October 13, 2010 10:50 PM
  • We've seen this come in from a few different sources.  Try going to the Import and Export Settings section and applying one of the default configurations (for C#/VB/C++/General).  Alternatively you can use the customize option to drag those commands back onto the toolbar,

    John


    I had a similar problem with Visual Studio 2010. I reset the configuration like you suggested, and it worked fine. Thanks!

    Monday, October 25, 2010 6:38 PM