none
Locating Resources with UITypeEditors & Workflow RRS feed

  • Question

  •  

    Hi,

    I'm building a form to help support a custom Activity at design time.
    My setup looks like so..


    WF Class Library -> UITypeEditor -> Windows Form ->
                        ------------------ Seperate Class Library ---------------------


    Within the UITypeEditor, I attempt to load an EDM entity to pass along to the form.
    This fails with .


      The specified named connection is either not found in the configuration, not intended to be used with the EntityClient provider, or not valid


    The connection info is fine, the real problem is that the app.config file can't be loaded properly when EDM initializes.
    When launched from a seperate Windows app , everything works so it seems to me that the failure
    to locate the resource pertains to the host type, in this case Visual Studio.

    I tried using WPF in a previous approach with the same core problem. The controls xaml could not be located. I've tried copying
    the app config file everywhere looking for a hit. Also, tweeked Copy Local on the app.config as well. No luck. Urrrggg!!!!!


    Any ideas on how to approach this? Also, why is there no dedicated form for wf??

    Thanks,
      Travis


    Travis
    • Moved by Lambert Qin [秦磊] Thursday, October 16, 2008 6:21 AM it is more likely a common WWF issue. (Moved from SharePoint - Workflow to Off-Topic Posts (Do Not Post Here))
    Tuesday, October 14, 2008 3:26 PM

All replies

  • Hi,

     

    Your issue is more likely a common Windows Workflow issue, so I moved your question to Off-Topic.

     

    I suggest you to re-post in Windows Workflow Foundation forum (http://forums.microsoft.com/MSDN/ShowForum.aspx?ForumID=122&SiteID=1) should be better supporting resource for your issue.

     

    -lambert


    Posting is provided "AS IS" with no warranties, and confers no rights.
    Thursday, October 16, 2008 6:27 AM