none
Need help installing .net framework 3.5 sp1 RRS feed

  • Question

  • Hello everyone,

    I seem to have a problem when I try to install .net framework 3.5 sp1. I only have .net framework 1.1 and 2.0sp1, I don't know if I need anything else for it to work, but here is the error log I get when I try to install it:

    [11/03/11,19:05:02] RGB Rast: [2] Error: Installation failed for component RGB Rast. MSI returned error code 1601

    [11/03/11,19:05:02] RGB Rast: [2] Error: Installation failed for component RGB Rast. MSI returned error code 1601

    [11/03/11,19:05:12] WapUI: [2] DepCheck indicates RGB Rast is not installed.

    [11/05/11,14:01:40] Microsoft .NET Framework 2.0a: [2] Error: Installation failed for component Microsoft .NET Framework 2.0a. MSI returned error code 1603

    [11/08/11,17:26:17] Microsoft .NET Framework 2.0a: [2] Error: Installation failed for component Microsoft .NET Framework 2.0a. MSI returned error code 1603

    [11/03/11,19:05:02] RGB Rast: [2] Error: Installation failed for component RGB Rast. MSI returned error code 1601

    [11/03/11,19:05:12] WapUI: [2] DepCheck indicates RGB Rast is not installed.

    [11/05/11,14:01:40] Microsoft .NET Framework 2.0a: [2] Error: Installation failed for component Microsoft .NET Framework 2.0a. MSI returned error code 1603

    [11/05/11,14:01:55] WapUI: [2] DepCheck indicates Microsoft .NET Framework 2.0a is not installed.

    [11/11/11,19:53:06] Microsoft .NET Framework 2.0a: [2] Error: Installation failed for component Microsoft .NET Framework 2.0a. MSI returned error code 1603

    [11/08/11,17:26:17] Microsoft .NET Framework 2.0a: [2] Error: Installation failed for component Microsoft .NET Framework 2.0a. MSI returned error code 1603

    [11/13/11,11:46:13] Microsoft .NET Framework 2.0a: [2] Error: Installation failed for component Microsoft .NET Framework 2.0a. MSI returned error code 1603

    [11/26/11,12:06:23] Microsoft .NET Framework 2.0a: [2] Error: Installation failed for component Microsoft .NET Framework 2.0a. MSI returned error code 1603

    [11/08/11,17:26:17] Microsoft .NET Framework 2.0a: [2] Error: Installation failed for component Microsoft .NET Framework 2.0a. MSI returned error code 1603

    [11/13/11,11:46:13] Microsoft .NET Framework 2.0a: [2] Error: Installation failed for component Microsoft .NET Framework 2.0a. MSI returned error code 1603

    [12/10/11,17:00:45] Microsoft .NET Framework 2.0a: [2] Error: Installation failed for component Microsoft .NET Framework 2.0a. MSI returned error code 1603

    [12/10/11,21:44:18] Microsoft .NET Framework 2.0a: [2] Failed to fetch setup file in CBaseComponent::PreInstall()

    [12/10/11,21:44:18] setup.exe: [2] ISetupComponent::Pre/Post/Install() failed in ISetupManager::InternalInstallManager() with HRESULT -2147467260.

    [12/10/11,21:44:18] setup.exe: [2] CSetupManager::RunInstallPhase() - Call to Pre/Install/Post for InstallComponents failed

    [12/10/11,21:44:18] setup.exe: [2] CSetupManager::RunInstallPhaseAndCheckResults() - RunInstallPhase() returned a NULL piActionResults

    [12/10/11,21:44:18] setup.exe: [2] CSetupManager::RunInstallFromList() - RunInstallPhaseAndCheckResults failed [2]

    [12/10/11,21:44:19] setup.exe: [2] ISetupManager::RunInstallLists(IP_PREINSTALL failed in ISetupManager::RunInstallFromThread()

    [12/10/11,21:44:19] setup.exe: [2] ISetupManager::RunInstallFromThread() failed in ISetupManager::RunInstall()

    [12/10/11,21:44:19] setup.exe: [2] CSetupManager::Run() - Call to RunInstall() failed

    [12/10/11,21:44:19] WapUI: [2] DepCheck indicates Microsoft .NET Framework 2.0a is not installed.

    [12/10/11,21:44:19] WapUI: [2] DepCheck indicates XPSEPSC Installer was not attempted to be installed.

    [12/10/11,21:44:19] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.0 SP2 x86 was not attempted to be installed.

    [12/10/11,21:44:19] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.5 'package' was not attempted to be installed.

    [12/11/11,08:06:11] Microsoft .NET Framework 2.0a: [2] Error: Installation failed for component Microsoft .NET Framework 2.0a. MSI returned error code 1603

    Can you please help me solve this? Thank you,
    Fria

    Sunday, December 11, 2011 1:22 PM

Answers

All replies

  • What is your Windows version and Service Pack level?

    Have you verified the .NET Frameworks currently installed?

    Please verify installed Frameworks with this tool:

    http://blogs.msdn.com/b/astebner/archive/2008/10/13/8999004.aspx

    Post the first 25 lines and the last 25 lines of the tool output back here.

    If your existing .NET Frameworks verify OK, then I suggest you proceed as follows:

    Download the comprehensive .NET Framework 3.5 SP1 installer here:

    http://download.microsoft.com/download/2/0/e/20e90413-712f-438c-988e-fdaa79a8ac3d/dotnetfx35.exe

    Before running the installer, clear out your %temp% directory and disable your AV software.

    Run the installer from an account with full administrative priveleges.

    If you encounter a failure, provide complete install logs for analysis as follows:

    Please collect your install logs with this:

    http://www.microsoft.com/downloads/details.aspx?FamilyID=E0DA314F-6216-4A18-BC6B-7D29CF83AF20&displaylang=e&displaylang=en

    After you run Collect.exe, you'll find vslogs.cab in your %temp% directory. Please upload vslogs.cab to a public site, like SkyDrive, and post the link here.

     

    • Marked as answer by SoulessFria Sunday, December 11, 2011 5:31 PM
    Sunday, December 11, 2011 2:10 PM
  • Hello again,

    I use a windows XP x86 operating system.

    I verified the 2 frameworks currently installed on my system, v1.1 was verified successfully, but not 2.0 sp1. This is the first and last 25 lines of the error log.

    First 25:

    [12/11/11,12:29:34] Beginning of new SetupVerifier activity logging session

    [12/11/11,12:29:34] Activity log file location: C:\DOCUME~1\COMPAQ~1\LOCALS~1\Temp\setupverifier_main_12-11-11_12.29.34.txt

    [12/11/11,12:29:34] Error log file location: C:\DOCUME~1\COMPAQ~1\LOCALS~1\Temp\setupverifier_errors_12-11-11_12.29.34.txt

    [12/11/11,12:29:34] Build created on January 17, 2011

    [12/11/11,12:29:34] Detected operating system: Windows XP (x86)

    [12/11/11,12:29:34] Install state for .NET Framework 1.0: not installed.

    [12/11/11,12:29:34] Install state for .NET Framework 1.1: installed with service pack 1.

    [12/11/11,12:29:34] Install state for .NET Framework 2.0: installed with service pack 1.

    [12/11/11,12:29:34] Install state for .NET Framework 3.0: not installed.

    [12/11/11,12:29:34] Install state for .NET Framework 3.5: not installed.

    [12/11/11,12:29:34] Install state for .NET Framework 4 Client: not installed.

    [12/11/11,12:29:34] Install state for .NET Framework 4 Full: not installed.

    [12/11/11,12:29:34] Not adding product '.NET Framework 1.0' because it is not currently installed

    [12/11/11,12:29:34] Not adding product '.NET Framework 1.1' because it is not currently installed

    [12/11/11,12:29:34] Not adding product '.NET Framework 2.0' because it is not currently installed

    [12/11/11,12:29:34] Not adding product '.NET Framework 2.0 SP2' because it is not currently installed

    [12/11/11,12:29:34] Not adding product '.NET Framework 3.0' because it is not currently installed

    [12/11/11,12:29:34] Not adding product '.NET Framework 3.0 SP1' because it is not currently installed

    [12/11/11,12:29:34] Not adding product '.NET Framework 3.0 SP2' because it is not currently installed

    [12/11/11,12:29:34] Not adding product '.NET Framework 3.5' because it is not currently installed

    [12/11/11,12:29:34] Not adding product '.NET Framework 3.5 SP1' because it is not currently installed

    [12/11/11,12:29:34] Not adding product '.NET Framework 4 Client' because it is not currently installed

    [12/11/11,12:29:34] Not adding product '.NET Framework 4 Full' because it is not currently installed

    [12/11/11,12:29:38] Starting verification for product .NET Framework 1.1 SP1

    [12/11/11,12:29:38] Section [Files - .NET Framework 1.1] - start parsing entries

    Last 25:

    [12/11/11,12:30:04] Section [Registry - .NET Framework 2.0 (32-bit)] - stop parsing entries

    [12/11/11,12:30:04] Not running action 'Registry - .NET Framework 2.0 (64-bit)' for product '.NET Framework 2.0 SP1' because the OS condition does not match

    [12/11/11,12:30:04] Not running action 'Registry - .NET Framework 2.0 (Wow6432Node)' for product '.NET Framework 2.0 SP1' because the OS condition does not match

    [12/11/11,12:30:05] Section [Registry GE - .NET Framework 2.0 SP1 (Common)] - start parsing entries

    [12/11/11,12:30:05] Key: HKLM\SOFTWARE\Microsoft\NET Framework Setup\NDP\v2.0.50727

    Value: SP

    Expected Data: 1

    Actual Data: 1

    [12/11/11,12:30:05] Section [Registry GE - .NET Framework 2.0 SP1 (Common)] - stop parsing entries

    [12/11/11,12:30:05] Section [Registry GE - .NET Framework 2.0 SP1 (32-bit)] - start parsing entries

    [12/11/11,12:30:05] Section [Registry GE - .NET Framework 2.0 SP1 (32-bit)] - stop parsing entries

    [12/11/11,12:30:05] Not running action 'Registry GE - .NET Framework 2.0 SP1 (64-bit)' for product '.NET Framework 2.0 SP1' because the OS condition does not match

    [12/11/11,12:30:05] Processing custom action 'Custom Action - .NET Framework 2.0 test application'

    [12/11/11,12:30:05] ExecutablePath = 'Netfx20TestApplication.exe'

    [12/11/11,12:30:05] FriendlyName = '.NET Framework 2.0 test application'

    [12/11/11,12:30:05] TimeoutSeconds = '300'

    [12/11/11,12:30:05] WaitOnExit = 'true'

    [12/11/11,12:30:05] Silent = 'true'

    [12/11/11,12:30:05] Launching process 'Netfx20TestApplication.exe' now

    [12/11/11,12:30:05] Process successfully launched. Waiting 300 seconds for it to complete.

    [12/11/11,12:30:10] Process 'Netfx20TestApplication.exe' exited with return code 0

    [12/11/11,12:30:10] Section [Files - .NET Framework netfxperf.dll] - start parsing entries

    [12/11/11,12:30:10] File C:\WINDOWS\system32\netfxperf.dll (version 1.1.4322.573) is installed on the system

    [12/11/11,12:30:10] Section [Files - .NET Framework netfxperf.dll] - stop parsing entries

    [12/11/11,12:30:10] ****ERROR**** Verification failed for product .NET Framework 2.0 SP1

    So, must I redownload .net framework 2 sp1? Or what should I do?

    Sunday, December 11, 2011 5:35 PM
  • The comprehensive update I linked for you includes all interim updates from the base .NET Framework 2.0 through SP1 for 3.5.

    Did you attempt to install the comprehensive update after following the preparatory steps I gave you in my previous response?

    I suspect you did not, as your current framework did not verify.

    Before following the instructions below, I recommend you uninstall .NET Framework 2.0.

     

    Download the comprehensive .NET Framework 3.5 SP1 installer here:

    http://download.microsoft.com/download/2/0/e/20e90413-712f-438c-988e-fdaa79a8ac3d/dotnetfx35.exe

    Before running the installer, clear out your %temp% directory and disable your AV software.

    Run the installer from an account with full administrative priveleges.

    If you encounter a failure, provide complete install logs for analysis as follows:

    Please collect your install logs with this:

    http://www.microsoft.com/downloads/details.aspx?FamilyID=E0DA314F-6216-4A18-BC6B-7D29CF83AF20&displaylang=e&displaylang=en

    After you run Collect.exe, you'll find vslogs.cab in your %temp% directory. Please upload vslogs.cab to a public site, like SkyDrive, and post the link here.

     

    Sunday, December 11, 2011 8:15 PM
  • I did receive an error when I was installing the .net framework 3.5 sp1 (about 50% completed through installation when error occured.)

    The skydrive site for my document is https://skydrive.live.com/redir.aspx?cid=ada251f7d1f8637c&resid=ADA251F7D1F8637C!107&parid=ADA251F7D1F8637C!106

    I didn't know which portion of the files from the vslogs.cab I was supposed to upload, so I uploaded everything.
    • Edited by SoulessFria Monday, December 12, 2011 12:00 AM
    Sunday, December 11, 2011 11:59 PM
  • Your logs indicate that updates to .NET Framework 2.0 failed because 2.0 is corrupt.

    Try to remove .NET Framework 2.0 from your system using Add/Remove Programs. Then, use this tool to remove ANY pieces of .NET Framework 2.0/3.0/3.5 found on your system:

    http://blogs.msdn.com/b/astebner/archive/2008/08/28/8904493.aspx

    Then, retry this sequence:

    Download the comprehensive .NET Framework 3.5 SP1 installer here:

    http://download.microsoft.com/download/2/0/e/20e90413-712f-438c-988e-fdaa79a8ac3d/dotnetfx35.exe

    Before running the installer, clear out your %temp% directory and disable your AV software.

    Run the installer from an account with full administrative priveleges.

    If you encounter a failure, provide complete install logs for analysis as follows:

    Please collect your install logs with this:

    http://www.microsoft.com/downloads/details.aspx?FamilyID=E0DA314F-6216-4A18-BC6B-7D29CF83AF20&displaylang=e&displaylang=en

    After you run Collect.exe, you'll find vslogs.cab in your %temp% directory. Please upload vslogs.cab to a public site, like SkyDrive, and post the link here.

    If you see the same failure again, you are looking at repairing or reinstalling your OS.
    • Edited by pvdg42 Monday, December 12, 2011 1:14 PM
    • Proposed as answer by Alexander Sun Tuesday, December 13, 2011 6:41 AM
    Monday, December 12, 2011 1:03 PM