locked
'Cannot Resolve Windows Metadata' in .csproj file

    Question

  • 'Cannot Resolve Windows Metadata' in .csproj file

    I receive this error on my Windows 8.1 desktop in VS 2012 and VS 2013  for every single existing or new project I attempt to make. I have reinstalled the Windows 8 SDK (I am trying to work with legacy Windows 8 apps as well as creating new Windows 8.1 apps) and I am still not having any luck. I have reinstalled VS 2012 and also had no luck.

    Upon cleaning/rebuilding very occasionally I will also see that 'Metadata file ...ProjectName.exe' cannot be found - it is entirely random that this error will appear with the Metadata error. I am going mad and have been receiving this for days - the only thing I have not tried is a reinstall of Windows 8.1 as I am a uni student and do not have time to do this and backup my files when I have important projects to be getting on with. That is a ridiculous suggestion to expect anyone to reinstall their OS because of a Visual Studio problem.


    I am receiving no errors about third party libraries or .dll files and again this also happens with brand new store app projects created via the menu.

    • Edited by VickyPotts Tuesday, March 25, 2014 1:24 AM
    Tuesday, March 25, 2014 1:21 AM

Answers

  • Have you tried removing one or the other VS2012 or VS2013 before reinstall? I think that there's something corrupt with both versions on your machine.

    Matt Small - Microsoft Escalation Engineer - Forum Moderator
    If my reply answers your question, please mark this post as answered.

    NOTE: If I ask for code, please provide something that I can drop directly into a project and run (including XAML), or an actual application project. I'm trying to help a lot of people, so I don't have time to figure out weird snippets with undefined objects and unknown namespaces.

    Tuesday, March 25, 2014 7:03 PM
    Moderator