none
"Gathering kernel debugger settings" failed to complete successfully RRS feed

  • Question

  • Changed from previous developer VM to newer WinDev1702Eval.VMware.zip. Setting out two new VMs, on Target I ran the WDK Test Target Setup x64-x64_en-us.msi.

    On the host VM, Visual Studio 2015, Driver Test Configuration, which fails;

    .NET fails to install as newer is already in place. Probably ok this one.

    But "WDK Test Target Setup x64-x64_en-us.msi" and onwards all fail, the logs have;

        UserText="[HRESULT: 0x80070557] Failed to create the test host process for out of process test execution. (Unable to elevate the user's token because the user is not an administrator.)" CA="86902" LA="86987" >

        Title="DriverTestTasks::_ConfigureKernelDebugger"
        TUID=""
        Result="Blocked"

    This all worked with the previous Windev1612, so I'm not sure what has changed.

    Friday, March 10, 2017 7:50 AM

All replies

  • I used lusrmgr.msc to change WDKRemoteUser to be Memberof "Administrator" then everything installed as expected, and I can Start Debugging on the remote target VM.


    • Edited by lundman2 Friday, March 10, 2017 8:27 AM
    Friday, March 10, 2017 8:26 AM