locked
Bad module "ManagedPipelineHandler" in its module list RRS feed

  • Question

  • User761674611 posted

    I am in the process of deploying an existing web service developed in .Net 1.1 and WSE 2.0 to IIS 7.0. When I attempt to go to the URL associated with the service I receive the following error:

    HTTP Error 500.21 - Internal Server Error

    Handler "WebServiceHandlerFactory-Integrated" has a bad module "ManagedPipelineHandler" in its module list.

    Does anyone have information on how to resolve this problem?

    Tom

     

    Tuesday, May 20, 2008 7:04 PM

Answers

  • User511787461 posted

    Looks like you have not installed the asp.net feature from within IIS in "Add/Remove windows component" so that all the regstration needed to run asp.net is not present in your configuration.

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Tuesday, May 20, 2008 7:50 PM
  • User-1936435993 posted

    I think your ASP.net installation was not registered correctly. Try the following steps to register it.

    run %windir%\Microsoft.NET\Framework\v4.0.21006\aspnet_regiis.exe -i

    this should help you out.

    Thanks

    Dan

     

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Monday, November 16, 2009 6:57 AM

All replies

  • User511787461 posted

    What does the handler entry for "WebServiceHandlerFactory-Integrated" look like in configuration?

    Tuesday, May 20, 2008 7:15 PM
  • User761674611 posted

    There are to line items as follows:

     ASPNET-ISAPI-1.1-WebServiceHandlerFactory which points to C:\Windows\Microsoft.Net\Framework\v1.1.4322\aspnet_isapi.dll

    and

     WebServiceHandlerFactory-Integrated which points to System.Web.Services.Protocols.WebServiceHandlerFactory, System.Web.Services, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a

    if change the application pool to be Classic vs. Integrated for this service I then receive the following error:

    The page you are requesting cannot be served because of the ISAPI and CGI Restriction list settings on the Web server. When looking at the handler section it indicates this is "enabled" at the server and the web site level.

     What else could be the missing?

     

    Tuesday, May 20, 2008 7:33 PM
  • User511787461 posted

    Looks like you have not installed the asp.net feature from within IIS in "Add/Remove windows component" so that all the regstration needed to run asp.net is not present in your configuration.

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Tuesday, May 20, 2008 7:50 PM
  • User-2004358091 posted

    Hi, on my side, im sure that i installed ASP.NET feature but still have that error:

    Handler "PageHandlerFactory-Integrated" has a bad module "ManagedPipelineHandler" in its module list

    I tried to had this line:

    <section name="system.webServer" type="System.Configuration.IgnoreSectionHandler,
        System, Version=1.0.5000.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" />

        </configSections>

     in ../v1.1.4322/CONFIG/machine.confi file but does not work

    but i dont know problem could be into applicationhost.config maybe? This is what applicationhost.config looks like:

    <location path="" overrideMode="Allow">
            <system.webServer>
                <handlers accessPolicy="Read, Script">
                   
      <add name="PageHandlerFactory-Integrated" path="*.aspx" verb="GET,HEAD,POST,DEBUG" type="System.Web.UI.PageHandlerFactory" preCondition="integratedMode" />
                    <add name="PageHandlerFactory-ISAPI-2.0" path="*.aspx" verb="GET,HEAD,POST,DEBUG" modules="IsapiModule" scriptProcessor="%windir%\Microsoft.NET\Framework\v2.0.50727\aspnet_isapi.dll" preCondition="classicMode,runtimeVersionv2.0,bitness32" responseBufferLimit="0" />
                   
      <add name="ASPClassic" path="*.asp" verb="GET,HEAD,POST" modules="IsapiModule" scriptProcessor="%windir%\system32\inetsrv\asp.dll" resourceType="File" />
                    <add name="SecurityCertificate" path="*.cer" verb="GET,HEAD,POST" modules="IsapiModule" scriptProcessor="%windir%\system32\inetsrv\asp.dll" resourceType="File" />
                    <add name="ISAPI-dll" path="*.dll" verb="*" modules="IsapiModule" resourceType="File" requireAccess="Execute" allowPathInfo="true" />
                    <add name="CGI-exe" path="*.exe" verb="*" modules="CgiModule" resourceType="File" requireAccess="Execute" allowPathInfo="true" />
                    <add name="TraceHandler-Integrated" path="trace.axd" verb="GET,HEAD,POST,DEBUG" type="System.Web.Handlers.TraceHandler" preCondition="integratedMode" />
                    <add name="WebAdminHandler-Integrated" path="WebAdmin.axd" verb="GET,DEBUG" type="System.Web.Handlers.WebAdminHandler" preCondition="integratedMode" />
                    <add name="AssemblyResourceLoader-Integrated" path="WebResource.axd" verb="GET,DEBUG" type="System.Web.Handlers.AssemblyResourceLoader" preCondition="integratedMode" />
                    <add name="SimpleHandlerFactory-Integrated" path="*.ashx" verb="GET,HEAD,POST,DEBUG" type="System.Web.UI.SimpleHandlerFactory" preCondition="integratedMode" />
                    <add name="WebServiceHandlerFactory-Integrated" path="*.asmx" verb="GET,HEAD,POST,DEBUG" type="System.Web.Services.Protocols.WebServiceHandlerFactory, System.Web.Services, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" preCondition="integratedMode" />
                    <add name="HttpRemotingHandlerFactory-rem-Integrated" path="*.rem" verb="GET,HEAD,POST,DEBUG" type="System.Runtime.Remoting.Channels.Http.HttpRemotingHandlerFactory, System.Runtime.Remoting, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" preCondition="integratedMode" />
                    <add name="HttpRemotingHandlerFactory-soap-Integrated" path="*.soap" verb="GET,HEAD,POST,DEBUG" type="System.Runtime.Remoting.Channels.Http.HttpRemotingHandlerFactory, System.Runtime.Remoting, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" preCondition="integratedMode" />
                    <add name="AXD-ISAPI-2.0" path="*.axd" verb="GET,HEAD,POST,DEBUG" modules="IsapiModule" scriptProcessor="%windir%\Microsoft.NET\Framework\v2.0.50727\aspnet_isapi.dll" preCondition="classicMode,runtimeVersionv2.0,bitness32" responseBufferLimit="0" />
                    <add name="SimpleHandlerFactory-ISAPI-2.0" path="*.ashx" verb="GET,HEAD,POST,DEBUG" modules="IsapiModule" scriptProcessor="%windir%\Microsoft.NET\Framework\v2.0.50727\aspnet_isapi.dll" preCondition="classicMode,runtimeVersionv2.0,bitness32" responseBufferLimit="0" />
                    <add name="WebServiceHandlerFactory-ISAPI-2.0" path="*.asmx" verb="GET,HEAD,POST,DEBUG" modules="IsapiModule" scriptProcessor="%windir%\Microsoft.NET\Framework\v2.0.50727\aspnet_isapi.dll" preCondition="classicMode,runtimeVersionv2.0,bitness32" responseBufferLimit="0" />
                    <add name="HttpRemotingHandlerFactory-rem-ISAPI-2.0" path="*.rem" verb="GET,HEAD,POST,DEBUG" modules="IsapiModule" scriptProcessor="%windir%\Microsoft.NET\Framework\v2.0.50727\aspnet_isapi.dll" preCondition="classicMode,runtimeVersionv2.0,bitness32" responseBufferLimit="0" />
                    <add name="HttpRemotingHandlerFactory-soap-ISAPI-2.0" path="*.soap" verb="GET,HEAD,POST,DEBUG" modules="IsapiModule" scriptProcessor="%windir%\Microsoft.NET\Framework\v2.0.50727\aspnet_isapi.dll" preCondition="classicMode,runtimeVersionv2.0,bitness32" responseBufferLimit="0" />
                    <add name="TRACEVerbHandler" path="*" verb="TRACE" modules="ProtocolSupportModule" requireAccess="None" />
                    <add name="OPTIONSVerbHandler" path="*" verb="OPTIONS" modules="ProtocolSupportModule" requireAccess="None" />
                    <add name="StaticFile" path="*" verb="*" modules="StaticFileModule,DefaultDocumentModule,DirectoryListingModule" resourceType="Either" requireAccess="Read" />
                </handlers>
                <modules>
                    <add name="HttpCacheModule" lockItem="true" />
                    <add name="StaticCompressionModule" lockItem="true" />
                    <add name="DefaultDocumentModule" lockItem="true" />
                    <add name="DirectoryListingModule" lockItem="true" />
                    <add name="IsapiFilterModule" lockItem="true" />
                    <add name="ProtocolSupportModule" lockItem="true" />
                    <add name="StaticFileModule" lockItem="true" />
                    <add name="AnonymousAuthenticationModule" lockItem="true" />
                    <add name="RequestFilteringModule" lockItem="true" />
                    <add name="CustomErrorModule" lockItem="true" />
                    <add name="IsapiModule" lockItem="true" />
                    <add name="HttpLoggingModule" lockItem="true" />
                    <add name="ConfigurationValidationModule" lockItem="true" />
                    <add name="OutputCache" type="System.Web.Caching.OutputCacheModule" preCondition="managedHandler" />
                    <add name="Session" type="System.Web.SessionState.SessionStateModule" preCondition="managedHandler" />
                    <add name="WindowsAuthentication" type="System.Web.Security.WindowsAuthenticationModule" preCondition="managedHandler" />
                    <add name="FormsAuthentication" type="System.Web.Security.FormsAuthenticationModule" preCondition="managedHandler" />
                    <add name="DefaultAuthentication" type="System.Web.Security.DefaultAuthenticationModule" preCondition="managedHandler" />
                    <add name="RoleManager" type="System.Web.Security.RoleManagerModule" preCondition="managedHandler" />
                    <add name="UrlAuthorization" type="System.Web.Security.UrlAuthorizationModule" preCondition="managedHandler" />
                    <add name="FileAuthorization" type="System.Web.Security.FileAuthorizationModule" preCondition="managedHandler" />
                    <add name="AnonymousIdentification" type="System.Web.Security.AnonymousIdentificationModule" preCondition="managedHandler" />
                    <add name="Profile" type="System.Web.Profile.ProfileModule" preCondition="managedHandler" />
                    <add name="UrlMappingsModule" type="System.Web.UrlMappingsModule" preCondition="managedHandler" />
                    <add name="CgiModule" lockItem="true" />
                    <add name="FastCgiModule" lockItem="true" />
                </modules>
            </system.webServer>
        </location>

     

     

    Saturday, August 29, 2009 10:54 AM
  • User511787461 posted

    From your description, it sounds like you have configured your app-pool to run asp.net 1.1 in integrated mode which asp.net 1.1 does not support.

    Thursday, October 22, 2009 8:06 PM
  • User-1936435993 posted

    I think your ASP.net installation was not registered correctly. Try the following steps to register it.

    run %windir%\Microsoft.NET\Framework\v4.0.21006\aspnet_regiis.exe -i

    this should help you out.

    Thanks

    Dan

     

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Monday, November 16, 2009 6:57 AM
  • User-1051852235 posted
    Thanks Dan, that worked for me.
    Wednesday, November 18, 2009 10:58 AM
  • User334174592 posted

    Try the following steps to register it.

    run %windir%\Microsoft.NET\Framework\v4.0.21006\aspnet_regiis.exe -i

    this should help you out.

    Yes this works!

    I figured everything was set up correctly because I was able to see ASP.NET 4.0 in the IIS. However only after I ran this fix did it work. Whew!

    Thursday, November 19, 2009 8:32 AM
  • User1735267126 posted

    How come we were talking about ASP .NET v1.1 and all in a sudden we have to register v4.0?

    I got the same problem, but I don't have ASP .NET 4.0. Does that mean I have to install ASP .NET 4.0?

    Thanks in advance.

    Monday, May 3, 2010 1:07 PM
  • User-273641139 posted

    thank you !!! solved my problem !!

    (had to modify v4.0.21006 --> my .net 4 version is all)

     

    Thursday, May 27, 2010 7:52 AM
  • User-1695663033 posted

     THANKS!  fixed my problem also.

    <input id="gwProxy" type="hidden"><!--Session data--><input onclick="jsCall();" id="jsProxy" type="hidden">
    Tuesday, June 1, 2010 5:09 PM
  • User-1551592385 posted

    Whaou, it also works for me, many thanks Dan.

    Strange ASP.Net is not able to install correctly. Even with the last 4.0.30319 version.

    Anyway, thanks again.

    Thursday, June 3, 2010 6:09 AM
  • User-167695488 posted

    run %windir%\Microsoft.NET\Framework\v4.0.21006\aspnet_regiis.exe -i

     

     I changed to "%windir%\Microsoft.NET\Framework\v4.0.30319\aspnet_regiis.exe -i"  to match my .Net version and all is well now.

     

    Thanks

    Tuesday, June 22, 2010 10:52 AM
  • User2082832845 posted
    Thanks it solved my problem too!
    Saturday, July 3, 2010 5:02 PM
  • User-1972414591 posted

    Unfortunately I don't have the file ...

    c:\windows\Microsoft.NET\Framework\v4.0.30319\aspnet_regiis.exe

    Directory yes, but no file, just my luck.

     Any suggestions?

    Tuesday, July 13, 2010 9:55 AM
  • User-174024831 posted

     thanks Dan  it worked for me too.

     

    kazim

    Thursday, August 12, 2010 5:12 AM
  • User-865962851 posted

    thanks it worked ... good article ..

    Sunday, August 29, 2010 4:48 AM
  • User1559213651 posted

    Good practice. It also resolves my problem. thanks.

    Saturday, September 4, 2010 10:32 PM
  • User701372628 posted
    Thanks it solved my problem too!!!!!!!!!!!
    Friday, September 10, 2010 8:19 AM
  • User-268220776 posted

    It worked for me too! awsome!

     

    %windir%\Microsoft.NET\Framework\v4.0.30319\aspnet_regiis.exe -i

    Thursday, September 16, 2010 4:53 PM
  • User-33979194 posted
    Hi, I have had to go through this step twice now. Once with my win 7 dev machine and once with a win 2008 server R2. In 7 I added it via the add windows features (if I am not mistaken) and in 2008 via the add role wizard. Why does it require this asp.net registration phase to be performed manually? Is this normal or am I missing some setting during installation? Cheers, DB
    Sunday, October 3, 2010 8:48 AM
  • User-526403723 posted

    Muchas Gracias por tu gran aporte, con el he podido solucionar mi problema. Thank you very much for his great contribution, with him I could solve my problem

    Monday, October 11, 2010 5:43 PM
  • User-620063490 posted
    Do you have a 64-bit system? Perhaps you may want to try this: %windir%\Microsoft.NET\Framework64\v4.0.30319\aspnet_regiis.exe –i
    Wednesday, November 24, 2010 4:47 AM
  • User-620063490 posted
    Do you have a 64-bit system? Perhaps this may work: %windir%\Microsoft.NET\Framework64\v4.0.30319\aspnet_regiis.exe –i
    Wednesday, November 24, 2010 4:49 AM
  • User-1031945375 posted

    Hey Guys, I'm looking for the aspnet_regiis.exe under v4.0.xxxx but there's none.

    After installing the framework 4,0 it creates additional files including aspnet_regiis.exe.

    I just want to share this because others may experience the same.

    Nevertheless, I have solved my problem too.

    Thanks a lot.

     

    Wednesday, January 19, 2011 2:35 AM
  • User-1672167363 posted

    Hello,

    I know this is tagging on to a very old post.

    The aspnet_reggis.exe did not go missig.

    Correction for the last post the location of the "aspnet_regiis.exe" is in

                    the following location "C:\Windows\Microsoft.NET\Framework\v4.0.30319>".

    To use the tool "C:\Windows\Microsoft.NET\Framework\v4.0.30319>aspnet_regiis.exe -?"  This gets the help display of commands

    To use the tool to install ASPNET then it is

                      C:\Windows\Microsoft.NET\Framework\v4.0.30319>aspnet_regiis -i

    I think the problem may have been not seeing the exe file in the sea of other files.

    To find the exe files use ths at the command prompt >dir asp*.exe    this will display only the aspnet tools.

    Post errors or questions to a new post.

    Thank You,

    Martin :)

    Wednesday, January 19, 2011 4:02 AM
  • User979400789 posted

    Internet is fantastic. It solved my problem as well.

    Friday, February 4, 2011 5:03 AM
  • User1881267579 posted

     Just to say thanks, was having this problem too.

     

    Regards

    Saturday, February 12, 2011 3:35 AM
  • User461773070 posted
    Very awesome! This guys line corrected it for me.
    Saturday, March 26, 2011 6:02 PM
  • User-1146924588 posted
    thank you that work now
    Thursday, May 12, 2011 3:27 PM
  • User-1508533169 posted
    Did a Google search for a similar problem. Your solution solved my problem. Thank you.
    Monday, September 5, 2011 4:30 PM
  • User-1508974736 posted
    Thanks Dan. You solved my multiple problems also. What I don't understand is why it is necessary to use the aspnet_regiis command. There's no mention of this in any of the documentation/blogs etc. Does something needed to be added to the procedures outlined or to the documentation?
    Sunday, October 30, 2011 12:03 PM
  • User-1672167363 posted

    Hi @ gadya,

    Glad that you you ran "aspnet_regiis" and it fixed the problems.

    Since you asked for Documentation look at MSDN Documentation

    and the .net Framework Tools http://msdn.microsoft.com/en-us/library/k6h9cz8h(v=VS.71).aspx 

    and the "aspnet_regiis.exe" information for commands.

    and later in the documentation you can find information for your other questions.

    HTH

    Martin

     

     

    Sunday, October 30, 2011 12:21 PM
  • User-1678939668 posted
    Just in case there is still any doubt ... Thanks Dan! Like others I had to modify the dir to match my .net install but this fixed the problem indeed.
    Tuesday, November 1, 2011 12:30 PM
  • User-1959722066 posted

    This worked for me too. I tried it almost 2 years after this post was written, but I thought I'd post it anyway.

    Of course, the directory is different because of the newer version of .NET and because I have 7 on an x64 machine. Here is what I used:

    %windir%\Microsoft.NET\Framework64\v4.0.30319\aspnet_regiis.exe -i

    Thursday, November 3, 2011 11:59 AM
  • User634866497 posted

    Unfortunately, I am not having much luck with this solution. My IIS stubbornly refuses to install ASP.NET properly. Rather than repeating all the details here, here is where I posted the description of the propblem originally:

    http://serverfault.com/questions/327098/iis7register-failed-with-hresult-800700b7-cannot-create-a-file-when-that-file

    Essentially, running regiis fails with an error: "IIS7Register failed with HRESULT 800700b7: 'Cannot create a file when that file already exists.  '", and the suggested solution to that (http://blogs.msdn.com/b/dougste/archive/2010/09/06/errors-installing-asp-net-4-0.aspx) does not help.

    I am really desperate for ideas (other than "reinstall everything").

    Tuesday, November 8, 2011 4:31 PM
  • User-1672167363 posted

    Hi @ optimax,

    Did you run  the "aspnet_regiis.exe" tool from the correct folder "%windir%\Microsoft.NET\Framework64\" ?

    Martin

     

    Wednesday, November 9, 2011 3:12 AM
  • User634866497 posted

    @Martin,

    Yes, I ran it from the correct folder. In fact, I tried both 32- and 64-bit versions - with the same result.

    Wednesday, November 9, 2011 9:08 AM
  • User-1672167363 posted

    Hi @ optimax,

    Then you need to create a new post the current thread does apply to your problems.

    You may have Dot Net Framework  WIndows installer Service Pack problems.

    In the new post include the Windows System type X86 X64 and Service Pack level installed Dot Net Frameworks.

    Martin

     

    Wednesday, November 9, 2011 10:26 AM
  • User634866497 posted
    Will do. Thanks.
    Wednesday, November 9, 2011 11:03 AM
  • User-1961623048 posted
    I am feeling some major MAN-LOVE for Dan right now. I have spent a month (on and off) trying to get my Intranet from my old 2005 server to the new 2008 R2. It has been the nightmare of screaming profanity for weeks at a time. I read every thing from MSDN Technet and every page that even began to address my problem. Until I read Dan's post, it never even occurred to me that 4.0 could show up on the roles list, and not actually BE registered. I was just about to place a call to Microsoft for support @ $95 bucks a hit, when I ran across this. Needless to say, it worked beautifully! I am so pleased that I had to sign up to this forum and join just so I could leave a big THANK YOU!!!! for Dan. You really saved me a lot of time and grief, and now I can continue my building of the new intranet site.... Way to see the REAL problem underneath all of the distracting symptoms.
    Thursday, November 17, 2011 3:19 PM
  • User-1974751132 posted

    tanks, now iis works!

    Friday, November 18, 2011 11:30 AM