none
Upgrade failed when package signed with new certificate - (Deployment failed with HRESULT: 0x80073CF3, Package failed updates, dependency or conflict validation.)

    Question

  • We had  code signing cert for windows app and upgrades were working fine.

    Recently that certificate expired so we ordered a new certificate.

    We created a new package using the new certificate and trying to update the older version of application.

    But it doesn't succeed and we get following error:

    ========================================

    Add-AppxPackage : Deployment failed with HRESULT: 0x80073CF3, Package failed
    updates, dependency or conflict validation.
    Windows cannot install package 28DF46F4-A2B5-4913-8B5F-81D6B6F47389_2016.531.10
    31.2350_neutral_~_zg41601gpk2g8 because a different package
    28DF46F4-A2B5-4913-8B5F-81D6B6F47389_2.0.0.0_x64__rnv5yqc929nd4 with the same
    name is already installed. Remove package
    28DF46F4-A2B5-4913-8B5F-81D6B6F47389_2.0.0.0_x64__rnv5yqc929nd4 before
    installing.

    NOTE: For additional information, look for [ActivityId]
    02d3b489-b637-0000-f99c-d40237b6d101 in the Event Log or use the command line
    Get-AppxLog -ActivityID 02d3b489-b637-0000-f99c-d40237b6d101
    At line:37 char:1
    + Add-AppxPackage $f
    + ~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : WriteError: (C:\Windows\Temp..._x64.appxbundle:S
       tring) [Add-AppxPackage], IOException
        + FullyQualifiedErrorId : DeploymentError,Microsoft.Windows.Appx.PackageMa
       nager.Commands.AddAppxPackageCommand

    ===========================

    Is there any way to upgrade older versions with the version with new certificate?

    We wish NOT to uninstall the older version.

    Is there any work-around?
    Thursday, June 2, 2016 10:38 AM