none
.NET Framework 2.0 RRS feed

  • Question

  • Is there any deadline set by Microsoft for supporting .NET Framework 2.0 or earlier version?
    Friday, May 31, 2013 6:29 PM

Answers

  • Versions prior to 2.0 are out of support.

    In the case of 2.0, the situation is a bit different because of the extensions to 2.0, .NET 3.0 and 3.5, and the fact that .NET Framework 3.5 is embedded in Windows 7.

    So, .NET Framework 3.5 (which includes 3.0 and 2.0) support lifecycle follows that of Windows 7.

    Friday, May 31, 2013 8:18 PM
  • Not sure what you mean here, but I suspect IE 9 needs .NET 2.0/3.0 and that IE 10 needs .NET 2.0/3.0/3.5.

    IE 9 System Requirements:

    Operating System        
    • Windows Vista 32-bit with Service Pack 2 (SP2) or higher

    • Windows Vista 64-bit with Service Pack 2 (SP2) or higher

    • Windows 7 32-bit or higher

    • Windows 7 64-bit or higher

    • Windows Server 2008 32-bit with Service Pack 2 (SP2) or higher

    • Windows Server 2008 64-bit with Service Pack 2 (SP2) or higher

    • Windows Server 2008 R2 64-bit

    • IE 10 System Requirements:

    • Operating system

      Windows 7 32-bit with Service Pack 1 (SP1)
      or higher
      Windows 7 64-bit with Service Pack 1 (SP1) or
      higher
      Windows
      Server
      2008 R2
      with Service Pack 1 (SP1) 64-bit

    • Windows Vista and server equivalents all come with .NET 2.0 and 3.0 embedded

    • Windows 7 and server equivalents come with .NET 2.0, 3.0 and 3.5 embedded.

    Monday, June 3, 2013 11:37 PM

All replies

  • Versions prior to 2.0 are out of support.

    In the case of 2.0, the situation is a bit different because of the extensions to 2.0, .NET 3.0 and 3.5, and the fact that .NET Framework 3.5 is embedded in Windows 7.

    So, .NET Framework 3.5 (which includes 3.0 and 2.0) support lifecycle follows that of Windows 7.

    Friday, May 31, 2013 8:18 PM
  • Is .NET Framework 2.0 supported by Internet Explorer 9 and 10?
    Monday, June 3, 2013 11:04 PM
  • Not sure what you mean here, but I suspect IE 9 needs .NET 2.0/3.0 and that IE 10 needs .NET 2.0/3.0/3.5.

    IE 9 System Requirements:

    Operating System        
    • Windows Vista 32-bit with Service Pack 2 (SP2) or higher

    • Windows Vista 64-bit with Service Pack 2 (SP2) or higher

    • Windows 7 32-bit or higher

    • Windows 7 64-bit or higher

    • Windows Server 2008 32-bit with Service Pack 2 (SP2) or higher

    • Windows Server 2008 64-bit with Service Pack 2 (SP2) or higher

    • Windows Server 2008 R2 64-bit

    • IE 10 System Requirements:

    • Operating system

      Windows 7 32-bit with Service Pack 1 (SP1)
      or higher
      Windows 7 64-bit with Service Pack 1 (SP1) or
      higher
      Windows
      Server
      2008 R2
      with Service Pack 1 (SP1) 64-bit

    • Windows Vista and server equivalents all come with .NET 2.0 and 3.0 embedded

    • Windows 7 and server equivalents come with .NET 2.0, 3.0 and 3.5 embedded.

    Monday, June 3, 2013 11:37 PM