locked
Unable to edit or create workflows in SharePoint post upgrade from 2007 to 2010 RRS feed

  • Question

  • We created a number of custom worflows in sharepoint 2007.  After a successful in-place upgrade to sharepoint 2010 we are unable to edit or add any workflows.  The error message is "Unable to load workflow actions from the server.  Please contact your server administrator".  We've verified that the wss.actions file is valid XML.  We also put this file on our development SharePoint server and verified that after an iisreset we can still create and edit workflows on the dev server (which was also in-place upgraded from SP 2007 to SP 2010).
    Wednesday, August 18, 2010 8:11 PM

Answers

  • I ran tcpdump and looked at SharePoint Designer and the server was reporting that it could not find a feature.xml file associated with a solution that had been removed.  I opened the solution file and added the missing file and now it works.  The mystery of why the retracted solution was still being referenced remains, but at least we can make workflows again.
    • Proposed as answer by Clayton Cobb Wednesday, August 25, 2010 7:10 PM
    • Marked as answer by Clayton Cobb Wednesday, August 25, 2010 7:10 PM
    Wednesday, August 25, 2010 7:09 PM

All replies

  • So you did the exact same upgrade on two different servers, but one works while the other doesn't?  I was going to ask if you had any custom activities that needed to be re-deployed to the 2010 system, but then that would have affected Dev, too.  I know it sucks to be told this, but it sounds like something was done in Dev that wasn't duplicated exactly in production.
    SharePoint Architect || Microsoft MVP || My Blog
    Planet Technologies || SharePoint Task Force
    Wednesday, August 18, 2010 8:43 PM
  • Same upgrade process, but the Dev server has an empty content database, and none of the custom workflows that the prod server has.  So they are not identical at all.
    Wednesday, August 18, 2010 9:11 PM
  • Ah, well that's a hint at least.  So, back to my question then.  In 2007, were you using the Codeplex custom workflow activities by chance?  Or maybe your own custom ones built in Visual Studio?  If so, those need to be deployed to the 2010 farm.
    SharePoint Architect || Microsoft MVP || My Blog
    Planet Technologies || SharePoint Task Force
    Wednesday, August 18, 2010 9:15 PM
  • Neither of those, just workflows created in SPD and the 10 sample themes for MOSS 2007 that Microsoft released, which have been deactivated but not retracted.

    Wednesday, August 18, 2010 9:37 PM
  • I ran tcpdump and looked at SharePoint Designer and the server was reporting that it could not find a feature.xml file associated with a solution that had been removed.  I opened the solution file and added the missing file and now it works.  The mystery of why the retracted solution was still being referenced remains, but at least we can make workflows again.
    • Proposed as answer by Clayton Cobb Wednesday, August 25, 2010 7:10 PM
    • Marked as answer by Clayton Cobb Wednesday, August 25, 2010 7:10 PM
    Wednesday, August 25, 2010 7:09 PM