none
VS2015 XAML Designer exception

    Question

  • I'm running VS2015 on Windows 10. When I try to view XAML in the designer even in the MainPage.xaml from a blank UWP project. I get the unhandled exception below.

    It had been working after the initial installation of VS. I'm not sure exactly when it broke. 

    Any idea how I can diagnose and repair this?

    System.Runtime.InteropServices.COMException
    The app didn't start. (Exception from HRESULT: 0x8027025B)
       at Microsoft.VisualStudio.DesignTools.HostUtility.AppPackage.AppPackageNativeMethods.IApplicationActivationManager.ActivateApplication(String appUserModelId, String activationContext, ActivateOptions options, Int32& processId)
       at Microsoft.VisualStudio.DesignTools.HostUtility.AppPackage.DesignerWrtUtility.ActivateApplication(String appUserModelId, String activationContext, Object site, Boolean isRunningElevated)
       at Microsoft.VisualStudio.DesignTools.HostUtility.Platform.AppContainerProcessDomainFactory.ActivateApplicationInternal(String appUserModelId, String activationContext, Object site)
       at Microsoft.VisualStudio.DesignTools.HostUtility.Platform.AppContainerProcessDomainFactory.CreateDesignerProcess(String applicationPath, String clientPort, Uri hostUri, IDictionary environmentVariables, Int32& processId, Object& processData)
       at Microsoft.VisualStudio.DesignTools.DesignerContract.Isolation.Primitives.ProcessDomainFactory.ProcessIsolationDomain..ctor(ProcessDomainFactory factory, IIsolationBoundary boundary, AppDomainSetup appDomainInfo, IIsolationTarget isolationTarget, String baseDirectory)
       at Microsoft.VisualStudio.DesignTools.DesignerContract.Isolation.Primitives.ProcessDomainFactory.CreateIsolationDomain(IIsolationBoundary boundary)
       at Microsoft.VisualStudio.DesignTools.HostUtility.Platform.AppContainerProcessDomainFactory.CreateIsolationDomain(IIsolationBoundary boundary)
       at Microsoft.VisualStudio.DesignTools.DesignerContract.Isolation.Primitives.IsolationBoundary.Initialize()
       at Microsoft.VisualStudio.DesignTools.DesignerContract.Isolation.Primitives.IsolationBoundary.CreateInstance[T](Type type)
       at Microsoft.VisualStudio.DesignTools.DesignerContract.Isolation.IsolatedObjectFactory.Initialize()
       at Microsoft.VisualStudio.DesignTools.DesignerHost.Services.VSIsolationService.CreateObjectFactory(IIsolationTarget isolationTarget, IObjectCatalog catalog)
       at Microsoft.VisualStudio.DesignTools.DesignerContract.Isolation.IsolationService.CreateLease(IIsolationTarget isolationTarget)
       at Microsoft.VisualStudio.DesignTools.DesignerContract.Isolation.IsolationService.CreateLease(IIsolationTarget isolationTarget)
       at Microsoft.VisualStudio.DesignTools.DesignerContract.IsolatedDesignerService.CreateLease(IIsolationTarget isolationTarget, CancellationToken cancelToken, DesignerServiceEntry& entry, IServiceProvider serviceOverrides)
       at Microsoft.VisualStudio.DesignTools.DesignerContract.IsolatedDesignerService.IsolatedDesignerView.CreateDesignerViewInfo(CancellationToken cancelToken)
       at Microsoft.VisualStudio.DesignTools.DesignerContract.Isolation.IsolatedTaskScheduler.InvokeWithCulture[T](CultureInfo culture, Func`2 func, CancellationToken cancelToken)
       at Microsoft.VisualStudio.DesignTools.DesignerContract.Isolation.IsolatedTaskScheduler.<>c__DisplayClass10_0`1.<StartTask>b__0()
       at System.Threading.Tasks.Task`1.InnerInvoke()
       at System.Threading.Tasks.Task.Execute()

    Monday, November 30, 2015 7:04 PM

Answers

  • Hi Tim,

    If you install the VS2015 update1, how about the result?

    Run the command line:

    devenv /resetuserdata

    This will clear everything (including maybe some custom settings), and then run your VS as the admin, re-create a simple UWP app, how about the result?

    If still no help, please repair your VS from the control panel, please connect your network during repairing.

    To make sure that it is not the setup file's issue, please check the SHA-1 value of your VS version.

    https://www.visualstudio.com/en-us/downloads/visual-studio-2015-iso-sha1-vs.aspx

    Best Regards,

    Jack


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    • Marked as answer by Tim McCulloch Friday, December 04, 2015 6:52 PM
    Thursday, December 03, 2015 12:23 PM
    Moderator

All replies

  • Hi Tim McCulloch,

    You can see related explanation on this url: https://connect.microsoft.com/VisualStudio/feedback/details/1076217/related-to-msdn-forum-following-up-windows-phone-8-1-xaml-designer-unhandled-exception

    and this: https://social.msdn.microsoft.com/Forums/en-US/276f8170-21f9-4f2d-a96e-9d4e84d10511/an-unhandled-exception-has-occured-xaml-designer

    Best regards!
    (If this was helpful for you, propose it as an answer)

    • Proposed as answer by Almir Vuk Monday, November 30, 2015 9:42 PM
    Monday, November 30, 2015 8:02 PM
  • Thank you for the reply. I tried suggestions from the links you provided but they did not work.

    Wednesday, December 02, 2015 9:06 PM
  • Hi Tim,

    If you install the VS2015 update1, how about the result?

    Run the command line:

    devenv /resetuserdata

    This will clear everything (including maybe some custom settings), and then run your VS as the admin, re-create a simple UWP app, how about the result?

    If still no help, please repair your VS from the control panel, please connect your network during repairing.

    To make sure that it is not the setup file's issue, please check the SHA-1 value of your VS version.

    https://www.visualstudio.com/en-us/downloads/visual-studio-2015-iso-sha1-vs.aspx

    Best Regards,

    Jack


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    • Marked as answer by Tim McCulloch Friday, December 04, 2015 6:52 PM
    Thursday, December 03, 2015 12:23 PM
    Moderator
  • Thanks!

    I didn't realize VS Update 1 was out. I installed it and that did the trick.

    -Tim

    Friday, December 04, 2015 6:54 PM