locked
SignalR Example,Microsoft.AspNet.SignalR.Client.Samples dependence .NETCoreApp 2.1 error RRS feed

  • Question

  • User1497005810 posted

    I download complete source code and use Visual Studio Professional 2017 to open the solution(After cloning the repository, run build.cmd.)

    But I find Microsoft.AspNet.SignalR.Client.Samples's dependence .NETCoreApp 2.1 has errors.
    Could somebody know how to solve this problem?

    Severity Code Description Project File Line Suppression State
    Error The current .NET SDK does not support targeting .NET Core 2.1. Either target .NET Core 1.1 or lower, or use a version of the .NET SDK that supports .NET Core 2.1. Microsoft.AspNet.SignalR.Client.Samples C:\Program Files (x86)\Microsoft Visual Studio\2017\Professional\MSBuild\Sdks\Microsoft.NET.Sdk\build\Microsoft.NET.TargetFrameworkInference.targets 112

    Error The current .NET SDK does not support targeting .NET Standard 2.0. Either target .NET Standard 1.6 or lower, or use a version of the .NET SDK that supports .NET Standard 2.0. Microsoft.AspNet.SignalR.Client C:\Program Files (x86)\Microsoft Visual Studio\2017\Professional\MSBuild\Sdks\Microsoft.NET.Sdk\build\Microsoft.NET.TargetFrameworkInference.targets 126

    Error NETSDK1050 The version of Microsoft.NET.Sdk used by this project is insufficient to support references to libraries targeting .NET Standard 1.5 or higher. Please install version 2.0 or higher of the .NET Core SDK. Microsoft.AspNet.SignalR.Client.JS.Tests C:\Program Files (x86)\Microsoft Visual Studio\2017\Professional\MSBuild\Microsoft\Microsoft.NET.Build.Extensions\Microsoft.NET.Build.Extensions.NETFramework.targets 67

    I want to write three projects: Windows Form, Web Client、SignalR Server. Does somebody suggest me to see which book or website?
    SignalR Server can be a bridge between Windows Form and Web Client by SignalR.

    Saturday, January 18, 2020 2:19 AM

All replies

  • User475983607 posted

    I download complete source code and use Visual Studio Professional 2017 to open the solution(After cloning the repository, run build.cmd.)

    But I find Microsoft.AspNet.SignalR.Client.Samples's dependence .NETCoreApp 2.1 has errors.
    Could somebody know how to solve this problem?

    Severity Code Description Project File Line Suppression State
    Error The current .NET SDK does not support targeting .NET Core 2.1. Either target .NET Core 1.1 or lower, or use a version of the .NET SDK that supports .NET Core 2.1. Microsoft.AspNet.SignalR.Client.Samples C:\Program Files (x86)\Microsoft Visual Studio\2017\Professional\MSBuild\Sdks\Microsoft.NET.Sdk\build\Microsoft.NET.TargetFrameworkInference.targets 112

    Error The current .NET SDK does not support targeting .NET Standard 2.0. Either target .NET Standard 1.6 or lower, or use a version of the .NET SDK that supports .NET Standard 2.0. Microsoft.AspNet.SignalR.Client C:\Program Files (x86)\Microsoft Visual Studio\2017\Professional\MSBuild\Sdks\Microsoft.NET.Sdk\build\Microsoft.NET.TargetFrameworkInference.targets 126

    Error NETSDK1050 The version of Microsoft.NET.Sdk used by this project is insufficient to support references to libraries targeting .NET Standard 1.5 or higher. Please install version 2.0 or higher of the .NET Core SDK. Microsoft.AspNet.SignalR.Client.JS.Tests C:\Program Files (x86)\Microsoft Visual Studio\2017\Professional\MSBuild\Microsoft\Microsoft.NET.Build.Extensions\Microsoft.NET.Build.Extensions.NETFramework.targets 67

    The error indicates you've downloaded an older Core 1.1 project but do not have 1.1 installed on your machine.  

    I want to write three projects: Windows Form, Web Client、SignalR Server. Does somebody suggest me to see which book or website?
    SignalR Server can be a bridge between Windows Form and Web Client by SignalR.

    This information is not hidden.  SignalR has been around a while and there's tons documentation.  All you have to do is click the Docs link above.  Anyway, I recommend installing Visual Studio 2019.  This will get you to ASP.NET Core 3.1 where has has everything you need including Windows Applications.

    https://docs.microsoft.com/en-us/aspnet/core/signalr/introduction?view=aspnetcore-3.1

    Saturday, January 18, 2020 2:07 PM
  • User1497005810 posted

    Thank you, mgebard!

    The error indicates you've downloaded an older Core 1.1 project but do not have 1.1 installed on your machine.  

    You mean I should install Core 1.1?But my error display Core 2.1?

    I had finished the signalr example for .net framework 4.5 by persistence connection in WebForm and Windows Form.

    SignalR 2.4.0 example(.net framework 4.5) use persistence connection in WebForm and Windows Form

    Sunday, January 19, 2020 1:54 PM