none
SDTInternalRunManager RRS feed

  • Question

  • I have a CLR assembly built against .NET 2.0. It runs, but I'd like to be able to debug it. When I hit F5 or F11 I get a message box that says "The SDTInternalRunManager service could not be found". It worked fine before I installed SSDT. Changing the platform to 3.5 makes no difference.

    Googling SDTInternalRunManager brings up a post by Barry Wang on msdn forums: he had the same problem, but his post was moved from "Visual Studio installation" to "Off-Topic Posts" without an answer being offered.

    • Moved by Janet Yeilding Monday, March 5, 2012 9:29 PM (From:SQL Server Data Tools)
    Wednesday, February 29, 2012 9:01 AM

All replies

  • Sorry you're running into this issue.  My best guess is that this is a CLR compatibility-related problem, so I'll move this post to a CLR forum.

    -Janet Yeilding

    Monday, March 5, 2012 9:27 PM
  • Hi Wigit,

    Welcome to the MSDN Forum.

    Did you get the message box like this one: http://social.microsoft.com/Forums/en-US/Offtopic/thread/1b19174e-44c3-4652-a152-97dcc680b4c0 ? 

    You have mentioned that "I have a CLR assembly built against .NET 2.0. It runs", do you mean the assembly can work fine in another project? And when you debug the other projects or applications, there is no such message box, right? 

    I look forward you.

    Best regards,


    Mike Feng
    MSDN Community Support | Feedback to us
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Tuesday, March 6, 2012 1:09 PM
    Moderator
  • Yup, exactly that. It runs under VS running on other machines using the same code base. What is (or was) SDTInternalRunManager?

    Dave.

    Tuesday, March 6, 2012 2:17 PM
  • Same story here when I am trying to debug CLR function on MSSQL 2008. Anybody from Microsoft can help?
    Friday, March 30, 2012 6:13 PM
  • Hi,

    Do you mean you hit this issue just after applying SSDT(SQL Server Data Tools (SSDT))?

    Regards

    Wednesday, April 11, 2012 7:19 AM
  • That's a 'yes' from me - dunno about Dmitriy.

    Dave.

    Wednesday, April 11, 2012 9:36 AM
  • I am also having the issue. SSDT has been applied.
    Thursday, April 12, 2012 4:20 AM
  • Perhaps with three people having the same problem there might be a response from Microsoft?

    Dave.

    Thursday, April 12, 2012 6:13 AM
  • Same issue here after applying SSDT
    Monday, April 16, 2012 1:34 PM
  • Four and counting :-)

    Dave.

    Monday, April 16, 2012 1:43 PM
  • Me too... After installing SSDT. Very annoying now I have to uninstall SSDT (which I find useful), to be able to debug my CLR projects...
    Monday, April 16, 2012 8:36 PM
  • After installing SSDT, each time you open the project/solution you are asked to convert the project to the new type.  This step must occur or you'll NEVER be able to debug the CLR.  I was having the same issue until I converted the project and reconfigured the primary CLR project.  Needed to go under project properties and change settings on almost EVER tab.
    • Proposed as answer by EJ Ralston Wednesday, April 25, 2012 6:29 PM
    Wednesday, April 25, 2012 6:29 PM
  • Agreed. A database project gets deployed to its own instance. To get round the SDTInternalRunManager problem, don't use use Debug->Start Debugging. Instead open your test script file and use right click->Execute with Debugger (=Control-shift-Q).

    Dave.

    Friday, May 25, 2012 9:35 AM
  • (assumes you've installed all patches and run a 'repair' on the sql server version you're using to debug).

    Dave.

    Friday, May 25, 2012 9:36 AM