locked
Could not load file or assembly 'mswacdmi.dll' or one of its dependencies. The specified module could not be found. RRS feed

  • Question

  • Hi,

    I am getting an error like "Could not load file or assembly 'mswacdmi.dll' or one of its dependencies. The specified module could not be found" when creating xdrive using "CloudDrive.InitializeCache(localCache.RootPath, localCache.MaximumSizeInMegabytes)".pls provide some solution.

     

    Thanks

    anuaj

    Monday, April 11, 2011 5:08 AM

Answers

  • Hi,

    I understand that you receive error message "When running with Full IIS on the Windows Azure Emulator on x86 (not x64), the following error is surfaced “Could not load file or assembly ‘mswacdmi.dll’ or one of its dependencies." when calling CloudDrive.InitializeCache method.

    It is a known issue of SDK 1.3 when running with Full IIS on the Windows Azure Emulator on x86 (not x64). According to Windows Azure Drives with Full IIS in SDK 1.3, the workaround is:

    The workaround is to add the path C:\Program Files\Windows Azure SDK\v1.3\bin\runtimes\storage\simulation\x86 to your system path environment variable. After adding this path, reboot your machine.

    The issue has been fixed in the Windows Azure SDK 1.4 release March 2011. So if you are still using SDK 1.2 or 1.3, you should upgrade it to the latest. If you still experience this issue with SDK 1.4, I would suggest directly submitting a support ticket on http://www.microsoft.com/windowsazure/support/.

    Thanks,


    Wengchao Zeng
    Please mark the replies as answers if they help or unmark if not.
    If you have any feedback about my replies, please contact msdnmg@microsoft.com.
    Microsoft One Code Framework
    • Proposed as answer by freaky roach Friday, April 15, 2011 6:21 AM
    • Marked as answer by Wenchao Zeng Monday, April 18, 2011 2:44 AM
    Tuesday, April 12, 2011 9:18 AM