none
A JDE adapter problem: target machine actively refused it 127.0.0.1:15000". RRS feed

  • Question

  • From time to time, my JDE adapter threw out the following warning when sending messages,

    Error transmitting message: No connection could be made because the target machine actively refused it 127.0.0.1:15000".

    Eventually, message will be sent. But, it's annoying. Does anyone know why? and How to resolve it? Thanks!

    Tuesday, April 27, 2010 7:38 PM

Answers

  • Hi Teddy,

    I checked our hotfix database and didn't see a BTS09 version of this fix. I'd suggest you open a support incident to Microsoft to verify if the problem still persists on BTS09. If so, you can then request a new version of the hotfix which applies to BTS09. To obtain the phone numbers for specific technology request please take a look at the web site listed below.

    http://support.microsoft.com/default.aspx?scid=fh;EN-US;PHONENUMBERS

    If you are outside the US please see http://support.microsoft.com for regional support phone numbers.

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Wednesday, May 5, 2010 7:55 AM
    Moderator

All replies

  •  

     Check JDE is up and running during those time when your getting an error, that would be start and check the following KB articles:

     http://support.microsoft.com/kb/956939
     http://support.microsoft.com/kb/923650 

    -SHR

     

    Tuesday, April 27, 2010 8:46 PM
  • SHR,

    I am using BizTalk 2009, so the hotfix doesn't apply. Anyone knows any hotfix for 2009?

    thanks

    Teddy

    Tuesday, April 27, 2010 11:07 PM
  • CAUSE
    ======
    This may occur on any machine updated by Windows Defender. A signature update
    started detecting modified HOSTS files as malicious. It then removes the 127.0.0.1
    localhost entry from the HOSTS file.


    RESOLUTION
    ============
    Add 127.0.0.1 localhost to the hosts file:

    1. Go to C:\Windows\System32\drivers\etc
    2. Open the hosts file in Notepad
    3. Add the following:
    127.0.0.1 localhost

    Save and close the hosts file.


    MSONLY
    ============
    The Rule Engine Update Service may also start if you change
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\BusinessRules\3.0\UpdateServiceHost from
    "localhost" to "127.0.0.1". Before doing this, modify the hosts file.

    REPRO STEPS
    =============
    1. Stop the Rule Engine Update Service.
    2. Go to C:\Windows\System32\drivers\etc.
    3. Open the hosts file in Notepad.
    4. Remove the following line: 127.0.0.1 localhost
    5. Save and close the hosts file.
    6. Start the Rule Engine Update Service.


    MORE INFORMATION
    ===================
    SettingsModifier:Win32/PossibleHostsFileHijack
    http://www.microsoft.com/security/portal/Entry.aspx?name=SettingsModifier%3aWin32%2f
    PossibleHostsFileHijack&threatid=1758608427027806866


    APPLIES TO:
    BizTalk 2004 - All Editions
    BizTalk 2006 - All Editions
    BizTalk 2006R2 - All Editions
    BizTalk 2009 - All Editions


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Friday, April 30, 2010 10:33 AM
    Moderator
  • Wen-Jun,

    The hosts file is already there. I am running BizTalk 2009 on Windows 2003/2008 64 bits. The problem is more like the problem happened on BizTalk 2006R2 mentioned in link provided by SHR.  The cause was,

    This problem occurs because the Runtimeagent.exe process tries to exit but is blocked.

    That hotfix doesn't seem to apply to BizTAlk 2009. Can you get some updates on this?

    thank you very much,

    Teddy

    Friday, April 30, 2010 5:29 PM
  • Hi Teddy,

    I checked our hotfix database and didn't see a BTS09 version of this fix. I'd suggest you open a support incident to Microsoft to verify if the problem still persists on BTS09. If so, you can then request a new version of the hotfix which applies to BTS09. To obtain the phone numbers for specific technology request please take a look at the web site listed below.

    http://support.microsoft.com/default.aspx?scid=fh;EN-US;PHONENUMBERS

    If you are outside the US please see http://support.microsoft.com for regional support phone numbers.

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Wednesday, May 5, 2010 7:55 AM
    Moderator
  • Hi there - has there been any update on this?

    I'm experiencing the same issues using the trial version of BTS 2009 and the JDE E1 adapter at a client.

    I've logged a problem call using the connect website (at https://connect.microsoft.com/BizTalk/feedback/details/575407/jde-enterpriseone-adapter-causes-runtime-error).

    I can't log a support call as we have to pay for that (is that right? you have to pay to report a bug? or am I missing something here?!).

    It's causing issues for us as I can't recommend that the client use BizTalk 2009 until this issue is fixed.

    The advice given by Wen-Jun Zhang above (check the hosts file) is a red herring as on my version of Windows Server 2008, the "127.0.0.1" entry is commented out, with a comment indicating that localhosts settings are managed via DNS, not the Hosts file.

    In any case, the issue only happens if you:

    1) Submit a message via the adapter

    2) Wait for 2 mins (which is w3hen the runtimeagent.exe)

    3) Attempt to submit another message

    Subsequent messages seem to process correctly.

    The error only seems to happen when the runtimeagent.exe process attempts to shut itself down after a period of inactivity.

    TeddyH: did you get a hotfix or resolution to this issue?

     

    Cheers,

    Dourn.

    Friday, July 16, 2010 8:47 AM
  • I was told that a hotfix for this will come out around mid august
    Thursday, July 22, 2010 7:07 PM
  • Cheers Teddy, that's good to know...

    I started a new post, as I'm also getting crashes fom the runtimeagent.exe process, don't know if you've seen this?

    My post is here:

    http://social.msdn.microsoft.com/Forums/en-US/biztalkr2adapters/thread/22d97ba2-802d-4303-9a66-294002d1fafe

     

    Cheers,

    Dourn.

    Friday, July 23, 2010 7:45 AM
  • Hi all - you'll be happy to know that a Hotfix is now available to solve this problem:

    http://support.microsoft.com/kb/2291479/

     

    Cheers,

    Dourn.

    Thursday, September 16, 2010 11:36 AM