WPFFontCache_v0400.exe Is Hogging CPU RRS feed

  • Question

  • Hello Sir,
    i have installed Visual Studio Beta 2 Ultimate on my system, Windows XP 32 Bit, 1 GB RAM, Intel Processor etc.

    the installation of beta 2 goes successfully.

    i can open the IDE Easily.

    but after creating/opening a project, my system becomes very slow, i thought that devenv.exe is taking a lot of memory and CPU, but when i opened Task Manager, i saw this WPFFontCache_v0400.exe taking 100 % CPU and close to 3 MB of memory.
    It is showing my CPU Usage to 100 % all the time, this exe is running.

    now my question is that why this exe is hogging my CPU.

    Kindly please help me in this.

    Looking for favorable replies.

    • Moved by Brittany Behrens Wednesday, November 11, 2009 11:31 PM (From:Visual Studio Editor)
    Wednesday, November 11, 2009 4:28 PM


All replies

  • Hello Sir

    Thanks for your replies, but kindly please let me know what is the role of this exe in the Visual Studio 2010 Beta 2. is there any problem or anything missing from my side.

    is it possible can i ask you another question related to Visual Studio 2010 Beta 2 or i have to create a new post for that.

    Sunday, November 15, 2009 2:55 PM
  • This exe caches font information for all WPF apps. WPF apps will work without it but apps will start faster and load fonts faster with it running.

    Is there anything in particular that triggers the 100% CPU? Like does it happen once you open a specific menu, a specific font, or a specific project? If it just happens every time you start VS we won't be able to reproduce that.

    As for something to try, Hua's got the right idea but is slightly wrong. That's the old font cache service. The new one is "Windows Presentation Foundation Font Cache "

    Try this:
    1) Stop the 4.0 service
    2) Go to <documents and settings>\LocalService\Local Settings\Application Data\ and delete all of the WPFFontCache_v0400* files.

    3) Start the 4.0 service again
    4) Start VS and try to make it happen again

    And see if that fixes it.

    Thursday, November 19, 2009 10:38 PM
  • I am having the same problem.

    I do not have any WPF apps.

    Even more when WPFFontCache_v0400.exe is hogging my PC,
    I cannot neither open properties of APS.NET Development Server
    launched from VS2008 website nor close it.

    Why is it launched if I neither develop WPF app
    not have them at all?
    Guennadi Vanine -- Gennady Vanin -- Геннадий Ванин
    Monday, November 23, 2009 4:05 PM
  • You might be using a WPF app and not know it. The service doesn't start until a WPF app turns it on.

    Does doing above help at all? If you're on Vista or Win7, the font cache files are in %WINDIR%\ServiceProfiles\LocalService\AppData\Local
    Monday, November 23, 2009 6:54 PM
  • In the case of Visual Studio 2010 Beta 2, you are running WPF if you are running the IDE. The TextEditor in VS2010 is written in WPF, thus the font cache manager will be launched with the TextEditor.

    Tuesday, November 24, 2009 1:19 AM
  • I just disabled it in services.msc and deleted in Task Manager.
    Seems liek VS2010 editor works.

    Windows XP Pro SP3 rus
    Guennadi Vanine -- Gennady Vanin -- Геннадий Ванин
    Tuesday, November 24, 2009 6:31 PM
  • Hello gwan,

      Sorry for a delay, I lost my old account.

      and sorry for the little mistake, the Version should be

      Good luck
    Monday, November 30, 2009 3:17 AM
  • Hello Jordan,

      Thank you for replying the thread.

      Good luck.
    Monday, November 30, 2009 3:17 AM
  • Hello Gwan,

        You can try to clear Font Cache 

        1. Start > Control Panel > Administrative Tools > Services
        2. Scroll down to 'Windows Presentation Foundation Font Cache' and then right click and select properties
        3. In the window then select 'disabled' in the startup type combo

       You can also report it to 

       And you can also ask at 

        Visual Studio 2010 & .NET Framework 4 Beta 2 Announcements

    Monday, November 30, 2009 3:20 AM
  • Hello Sir

    Thanks for your comments, i have tried your steps and i am happy to get my speed back using Visual Studio 2010.

    i can't still understand this thing, does this problem occurs on my system or what or no one till now faces this problem?

    what is the use of this exe, when we have to disable this through services.msc.

    i wan't to ask another question, whether i have to start a new post or what. kindly please help me.

    thanks for you help as now Visual Studio 2010 Beta 2 is now running fine.

    Sunday, December 6, 2009 3:02 PM
  • Just had the same problem, and it seems to have been triggered by the Team Explorer in VS2010 Beta 2.  I cleared the font cache as per Jordan Parker's post (<documents and settings>\LocalService\Local Settings\Application Data\) and everything works fine.
    Friday, February 5, 2010 2:49 PM
  • Thanks Jordan,

    It works to me.

    Wednesday, September 29, 2010 4:48 AM
  • thanks. that works for me 
    Monday, June 6, 2011 5:06 AM
  • Tuesday, December 6, 2011 9:00 AM
  • It worked for me....

    Wednesday, July 4, 2012 10:22 AM
  • It worked for me....

    Is there a patch available from microsoft for this service?


    Friday, September 28, 2012 12:20 PM
  • Is there a patch available from Microsoft for this problem. We are getting too many such issues of font not appearing properly etc.


    Friday, September 28, 2012 12:28 PM
  • Is there a patch available from microsoft for this bug?


    Friday, September 28, 2012 12:53 PM
  • I have this problem when i start Kaspersky lab 2014 anti virus. your solution did not worked
    Monday, February 3, 2014 6:53 PM