none
Solved: Hyper-V VMs Failed to restore... RRS feed

  • Question

  • Hey all,

    Server 2012 R2 Datacenter (Bizspark)

    So came into the office today to hear beeping coming from the server room. A Raid card was having a conniption fit over a degraded Raid 10 array which hosts our VMs and a few other things.

    2 drives showed corruption however the array appeared to still be intact (could see the drive in windows, copy/change files etc.) We had just recently moved offices and I had another machine that had some issues with loose drive cables so after checking that the array seemed OK I shut the machine down made sure all the cables were good, rebooted and started to rebuild the array.

    So fast forward a few hours and the array is back to optimal and so far as I can tell there has been no loss of data.

    Go to make a phone call and dead lines (phones are hosted as a VM). Go to Hyper V and see that all of the VMs that were running at shutdown are now in a saved state. When I attempt to start them I see a progress bar pop up for "restoring" but when it hits 100% I get a very unhelpful error:


    The application encountered an error while attempting to change the state of 'XYZ'.

    'XYZ' failed to restore

    (Virtual machine ID .......)


    If I attempt to start a VM that was OFF at the time of this RAID silliness it starts fine. Any suggestions? I DO have bare metal backups but I'm guessing that's going to be a bit of a pain to do...

    thanks...

    EDIT:

    Solved- Deleted saved states and were back up and running...

    • Edited by pmcfadden Sunday, August 7, 2016 8:16 PM
    Sunday, August 7, 2016 8:05 PM