none
Problems with VGB RRS feed

  • Question

  • Hello, I am creating a custom VGB gesture database. The problem is, when I am recording the kinect suddenly disconnects, then it reconnects again. I have read this is a common problem, so I will wait for the solution, but when a use this recorded clips (with sudden stops) on VGB, there is a frame skip on the clips, the frames are not ordered, making impossible to tag the gestures.

    I hope you can help me with a solution to this problem, thank you very much.

    Tuesday, October 28, 2014 12:47 PM

Answers

  • Well, after trying all the possible solutions, finally, testing the Kinect on a clone system (exact same hardware), we find out that the problem must be due to some kind of incompability with some kind of software, as we have cloned the second machine's disk on my system, and now th Kinect works fine.

    Thanks for all the help.

    • Marked as answer by AlfredCB Friday, March 6, 2015 9:04 AM
    Friday, March 6, 2015 9:04 AM

All replies

  • Depending on how the code is operating, there is a watchdog between KinectService and your application and if things are taking to long, it will reset the service. On lower resource machine, this can be caused because of how your code is getting scheduled in and out by the kernel.

    Given your system is skipping frames during record/playback I would assume the performance of the machine is getting taxed. What kind of system are you running on? What is your system performance like when recording and playback? You can use the Task Manager > Performance tab and click the Open Resource Monitor to quickly see what part of the system is running high.

    Can you try another system that has better CPU/GPU and see if that changes the behavior.


    Carmine Sirignano - MSFT


    Tuesday, October 28, 2014 7:06 PM
  • When I reproduce the clips on Kinect Studio, they run smoothly, without any skip frame nor intersperse frames, just as I have recorded them. 
    The problem appears when I use these clips on VGB. I can't tag the clips because of this.

    The system runs fine when recording/playing and when using VGB.Right now I dont have another system with better characteristics. These are the specifications:

    - Processor: Intel Core i7-4770 @ 3.4Ghz
    - Memory: 16GB 
    - GPU: AMD Radeon HD 5450 1GB DDR3

    So, summarizing, I record the clips on Kinect Studio, and when I use the on VGB, frame skips and  intersperse frames appear, making impossible the tagging.

    Wednesday, October 29, 2014 3:47 PM
  • What parameters are you using in the recordings and did you record when the user was already "locked on". Can you provide the clip on a share (OneDrive/Dropbox)?


    Carmine Sirignano - MSFT

    Wednesday, October 29, 2014 5:42 PM
  • I record with the default parameters, checking NUI Streams: Depth, IR, BodyFrame, Opaque Data and Calibration Data, as said on the whitepaper. I don't fully understand the  "locked on" part, I record myself so I have to click the record button and then step backwards until the Kinect recognizes me, then I start to make the gestures I want to record.

    I would gladly share the clips, but I would prefer to share it directly with you instead of posting it publicly here if possible.

    Thursday, October 30, 2014 10:56 AM
  • "step backwards until the Kinect recognizes me" is the lock on. If you had someone already standing and recognized, the recorded clip will not have the body data for that locked on user until several frames have passed.

    The GPU is a bit on the lower end but should work given you are not having other performance issues on the system. Did you change your Resource Monitor to see if the CPU/Drive performance is working fine.

    contact the k4w [at] Microsoft [dot] com team and ask them to set file space for you to upload the clip.


    Carmine Sirignano - MSFT

    Thursday, October 30, 2014 5:25 PM
  • Ok perfect, thank you for the information.

    Yes, I checked all the monitors, and they seem to work fine. Only, when the Kinect shuts down (This happens using all the aplications, not only when recording/monitoring), the processes KinectService and KStudioHost Servide stops working. 

    I have contacted the K4W team, now I'm waiting for the response.
    Friday, October 31, 2014 9:57 AM
  • The only way to correct the service restarting issue is to have a system that meets the minimum/recommended hardware mentioned above. While you can use lower spec'd in most scenarios, the hardware specification is the only one we have confirm worked and passed all testing in our lab.

    We will send you an email shortly for you to upload the clip and will confirm whether there are any issues running it on our lab machines.


    Carmine Sirignano - MSFT

    Friday, October 31, 2014 4:55 PM
  • I have uploaded three clips. Thanks for the help, I hope this problem can be solved
    Monday, November 3, 2014 5:09 PM
  • Hello, I uploaded the clips a week ago. Is there any update on solving the issues? I can't work with this problems

    Thank you very much.

    Tuesday, November 11, 2014 9:47 AM
  • Sorry for the delay. There was a lot happening last week. Can you confirm these clips are recorded after you resolved the KinectService/Senser restart issue? From the quick glance of the clips, you have a big drop out in the middle of them which may not be a valid clip.

    Also, what type of hard drive are you using SDD, 7200 RPM SATA or 5400 RPM SATA? Depending on the motherboard manufacturing the USB3 chipset may be tied into the same PCIx bus as the hard drives.

    You may need to re-record after you have resolve the performance issues. You an try by ensuring the system is using the High Performance power setting in the Power control panel. Also ensure the PCI Express setting for power control is turned off. Do you have another machine that you can test with?

    One other thing, can you try a different GPU?


    Carmine Sirignano - MSFT




    Tuesday, November 11, 2014 7:00 PM
  • Taking a look at the clips you provided, they played back fine up until the point of where the sensor dropped. The recorded body frames were able to played(make sure you are disconnected in KStudio and start playback). When in a connected mode, body data is regenerated by the runtime and will work up until that drop-out as well.

    The good news is you can repair all those clips using the KSConvert tool. navigate to the tools directory(“C:\Program Files\Microsoft SDKs\Kinect\v2.0_1409\Tools\KinectStudio”) and enter "ksconvert <pathToFile> <pathToResultFile>"

    Once you have done that, reload the converted clips in KStudio in a disconnected state to ensure the data is there.


    Carmine Sirignano - MSFT

    Thursday, November 13, 2014 6:49 PM
  • No, those clips were recorded with the restarting issue, as I haven't been capable of solving the problem.

    The Hard Drive is a Seagate ST500DM002-1BD142 500GB: 7200 RPM SATA.

    And this is the Morherboard:  GigaByte B85M-DS3H.

    I have set the performance on High, I have updated all the Drives, the BIOS, everything, and the problem persist.

    I have tried it on a diferent machine with a better GPU (GTX 650), and works fine, but I would like to solve the problem on my machine as it is the only one I can work in. Does the Kinect uses the GPU intensively?? as on the requirements it only specifies a graphic card that supports DirectX 11, and my graphic card supports it.

    Following your recommendation I have used the ksconvert tool to repair the clips, but when I use this clips on VGB, the problem persist, some frames are disordered.

    Thanks for all the help, I hope the problem can be solved.

    Monday, November 17, 2014 11:23 AM
  • Kinect uses bandwidth extensively and uses the GPU for computation of the raw data from the sensor. If data doesn't flow fast enough or at all, the Kinect runtime is designed to restart to ensure the state of the pipeline is in a known working state.

    If you system persists to have issue sustain that high level of through-put there is no quick fix to the issue.

    You might want to try a dedicated USB3 Gen 2.0 capable PCIx expansion card as an option. Be sure your motherboard is capable of Gen 2.0 bandwidths on the PCIx expansion slot you are plugging that card into. As well, you may want to check with the manufacturer to see if the USB3 and the SATA ports are sharing the same bus. If so, that may be the issue, and the only fix in that case is new hardware.


    Carmine Sirignano - MSFT

    Monday, November 17, 2014 6:18 PM
  • Hello, I tried everything you proposed here,I have tried with another (better) GPU, I have checked with the manufacturer the problem with sharing buses,I have even bought a new USB 3.0 card (one of the recommended), but the problem persists, the Kinect freezes every 20 seconds approximately. 

    Is there any other solution to this?

    Thank you very much

    Friday, February 13, 2015 11:13 AM
  • Well, after trying all the possible solutions, finally, testing the Kinect on a clone system (exact same hardware), we find out that the problem must be due to some kind of incompability with some kind of software, as we have cloned the second machine's disk on my system, and now th Kinect works fine.

    Thanks for all the help.

    • Marked as answer by AlfredCB Friday, March 6, 2015 9:04 AM
    Friday, March 6, 2015 9:04 AM