none
[WACK]Cause of Crash during Windows App Certification Kit test? RRS feed

  • Question

  • I got the following error reported when I performed a Windows App Certification Kit Test. How do I go about figuring out what is the cause?

    Error Found: The crashes and hangs test detected the following errors:

    Application XYZ was detected by Windows Error Reporting and experienced a crash or hang.

    I looked at the application reports generated in the Event Viewer, but it doesn't seem to indicate what is the cause. Is there a way to figure out the cause looking at these reports?



    • Edited by Krunal Parekh Thursday, May 19, 2016 2:06 AM title tag
    Wednesday, May 18, 2016 5:31 PM

All replies

  • Hi Jaxim,

    Please see this similar issue that might help.

    http://stackoverflow.com/questions/12437349/my-windows-8-store-app-crashes-in-app-certification-kit-how-can-i-found-out-why

    Could you find out which test in WACK was failing?


    Thanks MSDN Community Support Please remember to Mark as Answer the responses that resolved your issue. It is a common way to recognize those who have helped you, and makes it easier for other visitors to find the resolution later.


    Thursday, May 19, 2016 2:06 AM
  • Thanks for the response!

    In that example, the person saw something in the event log, but I don't see anything similar, I may be looking in the wrong place.

    When I open the event viewer, I see 3 "Event Error Reporting" entries, none of which include much info about the problem. I feel like I need to open another file to get similar info that is described in the example you provided.

    Below is the info I see for one of the Event Error Reporting Entries:

    Log Name:      Application
    Source:        Windows Error Reporting
    Date:          5/18/2016 10:59:42 AM
    Event ID:      1001
    Task Category: None
    Level:         Information
    Keywords:      Classic
    User:          N/A
    Computer:      Win8ProRTMDev
    Description:
    Fault bucket , type 0
    Event Name: WWAJSE
    Response: Not available
    Cab Id: 0

    Problem signature:
    P1: 4ea57891-cb2a-4784-ac8b-0d09ca742214_2.0.10.0_neutral__gw6f4zr971emm
    P2: App
    P3: 3fa6
    P4: 5
    P5: ms-appx://4ea57891-cb2a-4784-ac8b-0d09ca742214/lib/winjs-4.0.1/js/base.js
    P6: 12713_5
    P7: 
    P8: 
    P9: 
    P10: 

    Attached files:
    ErrorInfo.4216.4256.txt
    C:\Program Files\WindowsApps\4ea57891-cb2a-4784-ac8b-0d09ca742214_2.0.10.0_neutral__gw6f4zr971emm\AppXManifest.xml

    These files may be available here:


    Analysis symbol: 
    Rechecking for solution: 0
    Report Id: 26792c01-1d09-11e6-be8b-e8039a8b5f3f
    Report Status: 262144
    Hashed bucket: 
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="Windows Error Reporting" />
        <EventID Qualifiers="0">1001</EventID>
        <Level>4</Level>
        <Task>0</Task>
        <Keywords>0x80000000000000</Keywords>
        <TimeCreated SystemTime="2016-05-18T14:59:42.954088800Z" />
        <EventRecordID>134591</EventRecordID>
        <Channel>Application</Channel>
        <Computer>Win8ProRTMDev</Computer>
        <Security />
      </System>
      <EventData>
        <Data>
        </Data>
        <Data>0</Data>
        <Data>WWAJSE</Data>
        <Data>Not available</Data>
        <Data>0</Data>
        <Data>4ea57891-cb2a-4784-ac8b-0d09ca742214_2.0.10.0_neutral__gw6f4zr971emm</Data>
        <Data>App</Data>
        <Data>3fa6</Data>
        <Data>5</Data>
        <Data>ms-appx://4ea57891-cb2a-4784-ac8b-0d09ca742214/lib/winjs-4.0.1/js/base.js</Data>
        <Data>12713_5</Data>
        <Data>
        </Data>
        <Data>
        </Data>
        <Data>
        </Data>
        <Data>
        </Data>
        <Data>
    ErrorInfo.4216.4256.txt
    C:\Program Files\WindowsApps\4ea57891-cb2a-4784-ac8b-0d09ca742214_2.0.10.0_neutral__gw6f4zr971emm\AppXManifest.xml</Data>
        <Data>
        </Data>
        <Data>
        </Data>
        <Data>0</Data>
        <Data>26792c01-1d09-11e6-be8b-e8039a8b5f3f</Data>
        <Data>262144</Data>
        <Data>
        </Data>
      </EventData>
    </Event>


    Thursday, May 19, 2016 11:50 AM
  • Hi Jaxim,

    Unfortunately little I can do from my side. I would recommend opening a support ticket for this since I can not confirm this from my side right now. Support incident charges will be refunded if they are caused by a Microsoft bug.

    1.) Go to http://aka.ms/storesupport (sign in using your MSDN Subscription if applicable)

    2.) Under "App development" click the “Windows 10 Universal app development” OR "Windows 8.x app development” link based on where they are experiencing the problem.

    3.) On the next page, choose Problem type = Support for Writing apps, Category = <<appropriate category>>

    4.) Then choose the "Start request" link to start a support request.

    With Regards,

    Krunal Parekh


    Thanks MSDN Community Support Please remember to Mark as Answer the responses that resolved your issue. It is a common way to recognize those who have helped you, and makes it easier for other visitors to find the resolution later.

    Tuesday, May 31, 2016 8:34 AM