locked
Custom User Profile Properties do not appear in My Site RRS feed

  • Question

  • I created some custom User Profile properties, which I want to show in MySite. These properties are under their own Section, and the 'Show in the profile properties section of the user's profile page' and the 'Show on the Edit Details Page' checkboxes are checked in the property's edit page. The Policy settings display Everyone.

    I also see the property in Central Administration, there is at least one user with data, and the privacy setting is also set to Everyone. (At least for the user with which I am testing).

    Yet, the property nor the section appear in the My Site.

    Anything that I missed?

    Much obliged!



    • Edited by sivilian Tuesday, July 16, 2013 6:15 PM
    Tuesday, July 16, 2013 6:13 PM

Answers

  • Hi sivilian,

    Have you created some other type custom user profile properties (e.g. HTML)?

    I create a HTML type custom property with setting of showing in user profile page, and the Custom Properties section is displayed in EditPfofile.aspx page.

    Thanks


    Daniel Yang
    TechNet Community Support

    • Marked as answer by star.wars Thursday, August 8, 2013 2:16 PM
    Tuesday, July 23, 2013 7:50 AM

All replies

  • Hi sivilian,

    You can move your custom property from "Custom Properties" section to "Languages and Region" section(or other sections showed in EditProfile.aspx) via "Move up arrow", and then the custom property should be showed in My Site.

    Thanks


    Daniel Yang
    TechNet Community Support

    Friday, July 19, 2013 10:14 AM
  • Thank you Daniel for the answer.

    However, I would like to have the custom properties under their own section. I know this is possible because I had it working at one time. I don't remember doing anything special, but it stopped working after I migrated to another Sharepoint environment.

    many thanks,

    sivilian

    Monday, July 22, 2013 1:07 PM
  • Hi sivilian,

    Have you created some other type custom user profile properties (e.g. HTML)?

    I create a HTML type custom property with setting of showing in user profile page, and the Custom Properties section is displayed in EditPfofile.aspx page.

    Thanks


    Daniel Yang
    TechNet Community Support

    • Marked as answer by star.wars Thursday, August 8, 2013 2:16 PM
    Tuesday, July 23, 2013 7:50 AM
  • Hi Sivilian,

    Please make sure that in Property Edit settings, should be checked with "Allow users to edit values for this property" as shown in the below screen shot. Hope it should helpful!



    dinesh


    Friday, October 18, 2013 2:07 PM
  • Hi

    I have a similar issue with custom user profile properties. I have migrated mysites DB, managed meta data and user profile service apps from SP 2010 to SP 2013.

    After migration, I dont see data in custom user properties in user mysites. Can anyone suggest me a solution for this


    Santosh

    Tuesday, December 9, 2014 1:33 PM