locked
Running ASP.NET 1.1 with Windows 2008 64 bit and IIS 7.0 RRS feed

  • Question

  • User-961325171 posted

    Hi,

    I am trying to get my ASP.NET 1.1 websites running under Windows 2008 64 bit with IIS 7.0. I've followed the instructions from the blog below.

    http://blogs.iis.net/bills/archive/2008/06/02/installing-asp-net-1-1-with-iis7-on-vista-and-windows-2008.aspx

    Pretty followed step by step.

    I am now getting 500 error once I navigate to the site. What I notice from the  IIS Manager is, the Application Pool selection does not have the .NET runtime 1.1 in the drop downlist. Is this ok? Is this the reason why my 1.1 site is not running?

     Has anyone here got this configuration working. ASP.NET 1.1 IIS 7.0 on Windows 2008 64 bit.

     Thanks,

     

    Monday, July 28, 2008 7:30 PM

Answers

  • User-961325171 posted

    Thanks for all the suggestions. With the help of the MS Tech Support, we found the problem that cause the site to hang.

    We took an IIS Dump using Debug DIAG tool and found that IIS stop loading after encountering a third party COM Component. Once this DLL is removed, the site was able to run just fine.

    Regards

     

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Wednesday, July 30, 2008 8:11 PM

All replies

  • User-1653247517 posted

    500 instead of 503 tells that apppool is probably running (can you pls confirm?). Are you getting some description with 500 error response? Can you pls paste that here? Can you pls check eventviewer for error messages?

    Thanks,
    Kj

    Monday, July 28, 2008 11:26 PM
  • User-1757254373 posted

    If I recall, 1.1 should show up in the application pool drop down.

    Tuesday, July 29, 2008 11:46 PM
  • User-1757254373 posted

    just booted up my VM with it and it works for me? You sure you followed the steps correctly? Did you allow it in ISAPI and CGI Restrictions?

    Wednesday, July 30, 2008 12:18 AM
  • User-961325171 posted

    Yes, I've allow ASP.NET 1.1 in the ISAPI and CGI restrictions. I think the reason why .NET 1.1 isn't appearing in the app pool drop down is because I installed the .NET Framework 3.5 first and then the .NET 1.1. Not really sure,

     As of right now, I am still getting a 500 error. No errors in the eventlog, only thing I see in the IIS log is my request to the page and a 500 error with two zeros following.

    500 0 0 46

     

    Wednesday, July 30, 2008 12:53 PM
  • User-1757254373 posted

    Just so you know, I setup a VM last night, I had .net 3.5 installed, then installed 1.1. I will look at some stuff tonight, I am just a lil busy at work :P  Did you do any failed request tracing?

    Wednesday, July 30, 2008 2:33 PM
  • User-1757254373 posted

    Also, did you try running your app in a 32bit worker process? I seen some goofy stuff in my day

    Wednesday, July 30, 2008 2:35 PM
  • User-961325171 posted

    Yes, the enabled32biton64 is set to true. And I can see the W3wp.exe *32 process running...

    Wednesday, July 30, 2008 5:02 PM
  • User-961325171 posted

    Thanks for all the suggestions. With the help of the MS Tech Support, we found the problem that cause the site to hang.

    We took an IIS Dump using Debug DIAG tool and found that IIS stop loading after encountering a third party COM Component. Once this DLL is removed, the site was able to run just fine.

    Regards

     

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Wednesday, July 30, 2008 8:11 PM
  • User-1757254373 posted

    Oh, wow. Well, you figured it out! Have a good one

    Wednesday, July 30, 2008 10:16 PM
  • User-1428505852 posted

     Hello,

     I just received a Windows 2008 Standard x64 server and I have exaclty the same problem!

     But I never installed any third part component appart .NET Framework 1.1!

     Can you tell me please how to solve this problem?

    Thursday, August 7, 2008 4:09 AM
  • User-961325171 posted

    So is your site not coming up or are you getting a 500 error? If you are getting a 500 error check the IIS log for the Sub-Status code. Those codes will give you some clues as to what exactly is the 500 error about.

    Make sure you Allow ASP.NET in the ISAPI & CGI restrictions and your site is configured with the ASP.NET App Pool.

     Last but not least you must also install .NET 1.1 SP1 and an ASP.NET Security hot fix.

    Good luck.

    Thursday, August 7, 2008 12:39 PM
  • User-1757254373 posted

    Yeah, pretty much what he said ^^^. Normally, people forgot to allow asp.net in the isapi & cgi restrictions.

    Thursday, August 7, 2008 4:35 PM
  • User-1428505852 posted

      That's exactly what I did but I don't have any framework v1.1 to choose from the dropdown list when I configure a new app pool!

     Also I do have a .net 1.1 default app pool, but no way to create a new one!

     Is it the normal behavior of a 1.1 framework on a windows 2008 server 64bits?

    Friday, August 8, 2008 3:35 AM
  • User-961325171 posted

    Not sure if it is a bug or not in IIS 7 on Windows 64 Bit OS.  We had the same question as you had ask "Where is the .NET Framework 1.1" when creating App Pools.

    So we had one of our test servers reinstalled with Windows 2008 32 bit, then IIS 7.0 then .NET 1.1 , .NET 1.1 SP1 and ASP.NET 1.1 hot fix. Now this time with the 32 bit OS, the .NET Framework 1.1 framework shows up when creating App Pools in IIS 7.0.

    The only difference is the 64 bit OS and 32 bit OS.

    I think it should be fine to only have one App pool as long as you can assign more than one Worker Process to a single App Pool. You can verify this by creating 2 websites pointing at the ASP.NET 1.1 app pool. And make sure that you change the Max Worker Process allowed in the App Pool Advance setttings to 2 or more.

    Then navigate the 2 sites and observe task manager to make sure you see 2 worker process started. W3wp.32*.exe. The 32 bit worker process.

      

    Friday, August 8, 2008 12:56 PM
  • User-1172524742 posted

    I had the same problem, and was shocked to find that it is actually explained in the help-section, simply by clicking the small question mark in the upper right corner :-)

    Remember to set the enable32BitAppOnWin64="true" setting (I found it easiest to simply copy and edit an existing entry in the config XML-file).

    [snit_from_help] 

    Note 
    If you select .NET Framework version 1.1, the Managed pipeline mode list will be disabled. Additionally, if you are running IIS 7.0 on 64-bit Windows, and you have installed .NET Framework version 1.1, the value will not appear in the .NET Framework Version list when you add or edit an application pool. This is because .NET Framework version 1.1 installs under the Framework directory, but IIS reads values from the Framework64 directory on 64-bit Windows. You must set the managedRuntimeVersion attribute to v1.1 for the application pool in the configuration file directly or by using a tool such as IIS 7.0 command-line tool.

    [/snit_from_help] 

    Tuesday, September 9, 2008 10:04 AM