Entity Framework 6.# and VS 2017 Pro


  • I recently installed VS 2017 Pro, I have a project that has a database created entity model.

    If I select the edmx by either right click and select ADO.Net Framework of double clicking on the edmx. I go into to wait state that does not stop until I kill it with task manager.

    I reinstalled Entity Framework from NuGet.

    I've created a separate copy of the entity model.

    Still the same issue soon as I select the edmx.

    I saw that this was addressed in a previous post, but I'm not sure what exactly fixed it.

    Can anyone help?

    Monday, March 20, 2017 5:06 PM


All replies

  • Hi Alan at Bluegrass Cellular,

    This forum discuss and asks questions about .NET Framework Base Classes, Since your issue is more related to visual studio general. we'll move it to visual studio general forum for suitable support.

    Thanks for your understanding and cooperation.

    Best regards,

    Cole Wu

    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact

    Tuesday, March 21, 2017 1:43 AM
  • Okay for some reason, it works this morning. Go figure.

    Tuesday, March 21, 2017 3:08 PM