none
Canot install .Net framework 3.5 on windows 8.1 RRS feed

  • Question

  • every time try to install .Net Framework 3.5 on windows 8.1 it cant be completed with error 0x800f0831 I tried everything but nothing worked

    and when I go to turn windows features on/off and selected .Net framework 3.5

    it appears with the same error code

    Thursday, February 19, 2015 2:48 PM

Answers

All replies

  • What procedure are you using to install .NET 3.5 on Win 8.1?

    This article describes the correct technique:

    http://msdn.microsoft.com/en-us/library/hh506443(v=vs.110).aspx

    If you have already used the procedures in the linked article,  I suggest you repair your OS by the "SFC /scannow" command.

    Thursday, February 19, 2015 3:27 PM
  • If your computer is on a domain and the windows updates is managed by an internal windows update server, you can try removing your PC from the domain and doing the update at Windows features.

    This method worked for me.

    Kind Regards
    Christoff

    Thursday, February 19, 2015 4:04 PM
  • Hello Nodeee,

    I don't know why pvdg's link cannot be opened so I paste it again:

    https://msdn.microsoft.com/en-us/library/hh506443(v=vs.110).aspx

    If you cannot turn on it please try dism command listed there.

    Best regards,



    Barry
    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Friday, February 20, 2015 1:41 AM
    Moderator
  • Thank you Christoff this is what worked for me.
    Wednesday, April 8, 2015 10:15 AM