locked
The form has been closed. RRS feed

  • Question

  • Hi Guys,

     

    I have completed the creation of a custom workflow and an association form. I deployed the workflow manually by copying the assembly in GAC and copying the feature and workflow xmls in the features directory, in the folder for my workflow, along with the forms in there. It installs correclty but when I go to the list and start associating the workflow I get the infopath form not found pop up. So this happened when I removed the Microsoft.Office.Feature.workflow from feature.xml file since it was giving error in compilation. Then I added the this line in feature.xml directly in the deployment and then when I try and associate I get a white page saying "the form has been closed"

     

    Does anyone know what I am doing wrong?

    • Moved by Mike Walsh FIN Thursday, March 10, 2011 9:24 PM enough mentions of workflow to make this a workflow question in my mind (From:SharePoint - Development and Programming (pre-SharePoint 2010))
    Thursday, March 10, 2011 5:56 PM

Answers

  • Hi,

    You cannot upload an association form manually. It has to be done using STSADM activate feature command. 

    Once the feature is activated, is it showing the message "Operation Completed Successfully"? Also, did you give the right URN of the association form in workflow.xml file?

    Regards

    Ginni - Microsoft Community Contributor

    [My SharePoint Blog]

    • Marked as answer by Leoyi Sun Thursday, March 17, 2011 7:38 AM
    Monday, March 14, 2011 8:57 AM

All replies

  • chances are there are errors in your infopath form.. plz check
    Friday, March 11, 2011 2:47 PM
  • How can I check this?
    Friday, March 11, 2011 10:20 PM
  • Hi,

    Did you copy the Infopath forms in the Feature Folder while deploying the workflow as a feature?

    Regards

    Ginni - Microsoft Community Contributor

    [My SharePoint Blog ]

    Saturday, March 12, 2011 9:46 AM
  • Hi Ginni,

     

    I did. I copied and feature.xml, workflow.xml, formname.xsn and other files of the form into the feature folder then I installed from stsadm then activated it. I tried the whole thing again from scratch, but this time I don't even see my form in the "Manage form template" in Central Admin, so I uploaded it manually, but after uploading manually it still says Workflow enabled - No and "Installing...".

     

    What should I do?

    Monday, March 14, 2011 12:18 AM
  • Hi,

    You cannot upload an association form manually. It has to be done using STSADM activate feature command. 

    Once the feature is activated, is it showing the message "Operation Completed Successfully"? Also, did you give the right URN of the association form in workflow.xml file?

    Regards

    Ginni - Microsoft Community Contributor

    [My SharePoint Blog]

    • Marked as answer by Leoyi Sun Thursday, March 17, 2011 7:38 AM
    Monday, March 14, 2011 8:57 AM
  • Hi Malhar

    Kindly prefer to this link

    http://social.msdn.microsoft.com/Forums/en/sharepointworkflow/thread/980eef0a-80a3-4f6e-94dd-6f2b3902dd5e

     


    Warm Regards Vishal Joshi| Senior SharePoint Administrator| http://sharepoint2007administration.blogspot.com/
    Monday, March 14, 2011 2:35 PM