locked
Server Error in Application "Default Web Site" - asp pages will not run RRS feed

  • Question

  • User-133434231 posted

    Hi - I have tried to set up IIS7 to run .asp pages and I get the above error message. html files are fine. Any ideas would be greatfully received.

    Tuesday, August 5, 2008 7:12 PM

Answers

  • User-1341446551 posted

     Did you run the file from the server ... you might see some detailed error there... secondly... try to remove Show Friendly HTTP error messages in IE->Options->Advanced to see some more to it... Is this ASP App running well on an IIS 6 box??

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Tuesday, August 5, 2008 7:52 PM
  • User-2064283741 posted

     is asp installed correctly

    http://www.vitaminzproductions.com/technology-blog/index.php/2007/05/19/setting-up-asp-classic-on-iis-7-vista/

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Tuesday, August 5, 2008 8:08 PM
  • User844605415 posted

    It looks like you have default IIS7 install. Classic ASP is not installed if you have default IIS7 install. Run appwiz.cpl from the run command(or command prompt) and install ASP. That should also take care of your script map handler mappings and you should be ready to serve classic ASP content.

    Thanks,

    Mukhtar Desai

    IIS Performance Team

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Tuesday, August 5, 2008 8:27 PM
  • User-133434231 posted

    hi - I have set up asp classic as per http://www.vitaminzproductions.com/technology-blog/index.php/2007/05/19/setting-up-asp-classic-on-iis-7-vista/ now, now I am getting

    The website cannot display the page

     HTTP 500

     

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Wednesday, August 6, 2008 6:30 AM

All replies

  • User-1341446551 posted

     Did you run the file from the server ... you might see some detailed error there... secondly... try to remove Show Friendly HTTP error messages in IE->Options->Advanced to see some more to it... Is this ASP App running well on an IIS 6 box??

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Tuesday, August 5, 2008 7:52 PM
  • User-2064283741 posted

     is asp installed correctly

    http://www.vitaminzproductions.com/technology-blog/index.php/2007/05/19/setting-up-asp-classic-on-iis-7-vista/

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Tuesday, August 5, 2008 8:08 PM
  • User844605415 posted

    It looks like you have default IIS7 install. Classic ASP is not installed if you have default IIS7 install. Run appwiz.cpl from the run command(or command prompt) and install ASP. That should also take care of your script map handler mappings and you should be ready to serve classic ASP content.

    Thanks,

    Mukhtar Desai

    IIS Performance Team

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Tuesday, August 5, 2008 8:27 PM
  • User-133434231 posted

    hi - I have set up asp classic as per http://www.vitaminzproductions.com/technology-blog/index.php/2007/05/19/setting-up-asp-classic-on-iis-7-vista/ now, now I am getting

    The website cannot display the page

     HTTP 500

     

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Wednesday, August 6, 2008 6:30 AM
  • User-133434231 posted

    The asp page I am tring to run is very simple - just a test page with an .asp extension as I have just set up the server on my local machine to test as I develop. I have turned off Show Friendly HTTP error messages and it has not fixed the problem. Thanks

    Wednesday, August 6, 2008 10:08 AM
  • User-133434231 posted

    could you talk me through appwiz.cpl ? Thanks

    Wednesday, August 6, 2008 10:09 AM
  • User-1341446551 posted

    If you followed the document above then you already have checked ASP....Like I said remove Friendly HTTP Error Message from the browser ... you should get some more info from that ...
     

     

    Wednesday, August 6, 2008 1:22 PM