locked
Atlas VSIs will only work with VS 2005 Beta 2 RRS feed

  • Question

  • User912950612 posted

    I want to answer what will very likely be a FAQ for the Atlas VSIs.   The current Atlas VSIs on http://atlas.asp.net will not work with PDC bits or with any RTM builds of VS 2005 such as the August CTP – you need to be on a Beta 2 build.  There were breaking changes occurring between Beta 2 and the RTM build which would have made it more difficult to develop/test Atlas and get it all finished by PDC.   By staying on Beta 2, our developers could focus on Atlas features.

    The team is following up soon with a PDC build and we’ll have it out on the site when it’s ready.<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" /><o:p></o:p>

    <o:p></o:p>


    -Rich<o:p></o:p>

    <o:p> </o:p>

    Tuesday, September 13, 2005 11:32 AM

All replies

  • User357194711 posted
    OK I seem to be a bit cognitively challenged this morning: as far as I can tell the files currently served up at that location are just zip files (vsi.zip) - they don't initiate the installation of anything at all, contrary to the installation instructions.
    I'm really keen to get going on this, so how exactly do we get the files integrated with VS 2005 Beta 2 given that there doesn't seem to be an actual installation process? I'd manually put the extracted files where they need to be, but I don't have a clue right now.
    Tuesday, September 13, 2005 2:50 PM
  • User357194711 posted
    Regarding my earlier whine about the installation not working: it turns out all I had to do was remove the ".zip" extension that IE wanted to add for reasons known only to itself.
    Tuesday, September 13, 2005 3:13 PM
  • User1965044966 posted
    I use Visual Studio 2005 July CTP, after delete the compiled error in web.config (appliesTo="Web"), then it runs fine.
    Wednesday, September 14, 2005 2:46 AM
  • User912950612 posted
    There are several breaking changes between Beta 2 and RC0 so while you may be able to get the VSI and your app to build there's also a chance that the Atlas code will break in some place due to one of those changes.  We built and tested on Beta 2 so we know it works (preview quality, at least). 

    The team should have a RTM build version out pretty soon, however.

    -Rich
    Wednesday, September 14, 2005 3:14 AM
  • User-1155260916 posted
    Yes, we are working on getting the RTM versions of the VSI's complete ASAP. Apart from the appliesTo change in web.config, there are some changes within the Microsoft.Web.Atlas.dll that 'may' cuase you breaks depending upon your application. The script files themselves are currently consistent between builds.
    Wednesday, September 14, 2005 3:37 PM