none
Remote Event Receiver not firing from Project Online RRS feed

  • Question

  • Hi,


    I follow the post (http://www.ro.umt.com/blog/2013/08/01/project-server-2013-remote-event-handlers/#comment-695) and successfully setup the WCF on IIS, the WCF works fine with the on premises, but when I tried to fire the event from Project Online, the event is not fire, any idea? ( I can register/un-register the event without any problem)

    More background: the endpoint is SSL and we host the WCF at our own server.
    Thanks!


    Joe

    April 17,2014: After more tests, seems like the Project event is the only event that are not firing from the Project Online, other events are working fine (Resource, LookupTable and CustomeField)



    • Edited by Joe.C Thursday, April 17, 2014 4:27 PM
    Friday, April 11, 2014 7:38 PM

All replies

  • Hi Joe, 

    Please make sure you are using secure transport bindings for your service. Project Online wants to access it over https.

    If you are unable to provide a SSL endpoint, can check out this article where a solution with Service Bus as intermediary is suggested. 

    http://blogs.msdn.com/b/officeapps/archive/2013/01/03/debugging-remote-event-receivers-with-visual-studio.aspx

    Saturday, April 12, 2014 6:19 AM
  • Hi Ionut,

    Thanks for the response. FYI, the endpoint is a SSL already. And I'll forgot to mention that we host the WCF in our own server (server-hosted app).


    Joe

    Monday, April 14, 2014 12:12 PM
  • Something to shared, after more tests. The event that are not fired are the Project events from Project Online, and other events like Resource, LookupTable and CustomFields are fired from Project Online. Now I'm thinking that this may be a bug.

    Any other input is appreciated!



    Joe

    Thursday, April 17, 2014 4:25 PM