none
Fatal error during installation - .Net Framework 4 RRS feed

  • Question

  • I have installed Microsoft .Net Framework 4 before and it worked fine. Then sometime ago, it stopped working. So i uninstalled it and tried to re-install the program. But now i get this error.
    OS Version = 6.1.7601, Platform 2, Service Pack 1
    OS Description = Windows 7 - x64 Home Premium Edition Service Pack 1
    CommandLine = C:\ddabdf6307127c4f211b654a540b\\Setup.exe /x86 /x64
    TimeZone = Eastern Standard Time
    Initial LCID = 1033
     
    Using Simultaneous Download and Install mechanism
    Operation: Installing
    Package Name = Microsoft .NET Framework 4 Setup
    Package Version = 4.0.30319
    User Experience Data Collection Policy: Disabled
    Number of applicable items: 11
    Exe (C:\ddabdf6307127c4f211b654a540b\SetupUtility.exe) succeeded.
    Exe Log File: dd_SetupUtility.txt
    ServiceControl operation succeeded!
    ServiceControl operation succeeded!
    Exe (C:\ddabdf6307127c4f211b654a540b\Windows6.1-KB958488-v6001-x64.msu) failed with 0x240006 - (null).
    Exe (C:\ddabdf6307127c4f211b654a540b\SetupUtility.exe) succeeded.
    Exe Log File: dd_SetupUtility.txt
    MSI (C:\ddabdf6307127c4f211b654a540b\netfx_Core_x64.msi) Installation failed. Msi Log: Microsoft .NET Framework 4 Setup_20111201_151554112-MSI_netfx_Core_x64.msi.txt
    Final Result: Installation failed with error code: (0x80070643), "Fatal error during installation. " (Elapsed time: 0 00:02:23).
    i have tried many Different Framework 4 Installers (Normal and Standalone) and get the same error.

    I have taken everything out my %Temp% and i have no firewall up or anything else, also used the cleanup tool.

    i used the collect.exe to get this log. 

    https://skydrive.live.com/?cid=eebe7c24a4e3b87b#cid=EEBE7C24A4E3B87B&id=EEBE7C24A4E3B87B%21106

    Can someone help me. This has been going on for months and i have failed to find a answer.

    I'm new to posting a problem, so tall me if placed this in the wrong place. Thank You. 


    • Edited by Cooldog144 Thursday, December 1, 2011 10:17 PM
    Thursday, December 1, 2011 8:48 PM

Answers

  • Try this as a quick fix:

    "I went to "C:\Windows\Microsoft.NET" there is a directory called "assembly".

    I looked in the directory and found some subdirectories with lots of old dot net 4 files. I renamed the directory assembly2 and tried to install Dot Net 4 and it worked!!!!

    (You can't delete the assembly directory unless you take ownership of it but you can rename it.)

    It seems that something was in the old "assembly" directory."

    This procedure is from 'irarab', a forums contributor, and has proved very useful.

    If your problem is still not solved, please provide full logs as follows:

    Please collect your install logs with this:

    http://www.microsoft.com/downloads/details.aspx?FamilyID=E0DA314F-6216-4A18-BC6B-7D29CF83AF20&displaylang=e&displaylang=en

    After you run Collect.exe, you'll find vslogs.cab in your %temp% directory. Please upload vslogs.cab to a public site, like SkyDrive, and post the link here.

    • Marked as answer by Cooldog144 Friday, December 2, 2011 12:54 AM
    Friday, December 2, 2011 12:43 AM

All replies