locked
Sharepoint Designer 2007: Form Fields Not Appearing In WorkFlow Wizard RRS feed

  • Question

  • I am attempting to create a simple approval workflow in Sharepoint Designer 2007.  I have a form with a few fields from a list and two buttons: "I Approve" and "I Reject".  I am attempting to create a workflow using the Form Action button Custom Actions workflow wizard that will update the appropriate field of the appropriate record in the list.  The record identifier, ID, is contained on the form.  Along with that I include the Title field so that I can verify that the form is correctly displaying the list items.

    To create the workflow, I click one of the buttons and select Form Actions->Custom Actions to start the wizard.  I tell the wizard I want to update a list item, and I select the original list from the dropdown choices.  I can pick the field I want to update, which is a choice field, and the wizard correctly shows me the choices available for that field.  I pick the value I want.  Now to find the correct item, I select the ID field from the original list (which is displayed on the form) and click the (fx) button to set the value.  One the Define Workflow Lookup, however, the fields on my form don't appear under "Form Fields".  There is  nothing listed there, even though the form contains 2 fields from the list.  If I hard code a specific value for the ID, that record will be correctly updated.

    I have been hunting around for the solution to this for several days. A number of people have posted similar problems but usually involving forms originally created in InfoPath. Several people have suggested making sure that the datatype of the field I want to use is "label", but that hasn't helped. Any suggestions would be greatly appreciated. Thanks!

    Thursday, June 6, 2013 2:59 PM

Answers

  • Hi,

    I understand that you want to use the form action button on a page.  I have a test based on your description, when add the form action button on a custom new form or edit form web part, the form field will appear in the site workflow. When you add the button inside a display form web part, the form fields will show up as empty in the workflow. So if you are using the ‘I approve’ and ‘I reject’ button on a display form of a list, then it is the expected behavior. You can add the button on new form or edit form instead.

    If I have any misunderstanding, please feel free to let me know.

    Thanks,

    Entan Ming

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contacttnmff@microsoft.com.


    Entan Ming
    TechNet Community Support


    Friday, June 7, 2013 6:05 AM
    Moderator