locked
Integrated Windows Authentication: IE asks for user credentials RRS feed

  • Question

  • User1379292251 posted

    Please help me !

    When I navigate with IE10 to my Web-application the application's home page should immediately show up as I am using Integrated Windows Authentication as authentication method. Nevertheless IE10 requiring me to enter my credentials ( user name and password ).

    My configuration:

    Windows 8 Pro with IIS 8 ( localhost ):

    all authentication methods except Integrated Windows Authentication disabled

    Web-application uses the DefaultAppPool that is configured to use integrated managed pipeline mode

    IE10:

    Internet options - Advanced - Enable Integrated Windows Authentication checked

    Security - Local Intranet - Custom - User Authentication - Logon - Automatic logon only in Intranet Zone checked

    Web-application Web.config-file - <System web> - <authentification mode="Windows" /></authentification>

    In my eyes I have set everything correctly; Have I forgotten any setting in another location ( e.g. Local Security Policy ) ?

     

    Under Windows 7 Ultimate - IIS 7.5 - IE9 everything is working correctly ( the called Web-application appears immediately )

    Thanks for hints

    Monday, November 26, 2012 4:47 AM

Answers

  • User1379292251 posted

    Problem solved:

    I registered my Web-site in IE10 - Internet options - Security - Trusted Sites - Sites !

    The correct registration is in

    IE10 - Internet options - Security - Local Intranet - Sites

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Monday, November 26, 2012 7:30 AM

All replies

  • User1495804863 posted

    Hi,

    Add the site to your trusted sites in IE.

    or

    Look in Internet Explorer / Tools / Options / Advanced.

    There is a checkbox "Enable Integrated Windows Authentication" under "Security".

    Is this checked?

    It's checked by default, and can be set by admins using a GPO:

    http://www.windowsecurity.com/articles/configuring-advanced-ie-settings-using-group-policy.html

    Monday, November 26, 2012 4:56 AM
  • User1379292251 posted

    Yes, "Enable Integrated Windows Authentication" under Security in IE10-Internet options is checked.

    Group policies area not available as Windows 8 Pro is not a server system

    Monday, November 26, 2012 5:48 AM
  • User1379292251 posted

    Problem solved:

    I registered my Web-site in IE10 - Internet options - Security - Trusted Sites - Sites !

    The correct registration is in

    IE10 - Internet options - Security - Local Intranet - Sites

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Monday, November 26, 2012 7:30 AM