none
Issues with .Net Framework Installation - I've tried everything I can find. RRS feed

  • Question

  • Up to this point in time, I've not needed the .NET 3.5 Framework apparently. But now I do. I tried to install ArcGIS 10.1 on my computer to no avail. I would get

    I honestly don't remember everything I did the last time I tried to fix this, but I searched everywhere for a solution and tried to uninstall every version of .NET Framework I could find on my computer. I currently have .NET 4 it looks like. I know this is not a software-specific issue because I recently tried to install Jing and came up with another error pertaining to needing 3.5.

    I also recall errors when trying to install 3.5, including go to "Turn Windows Features on or Off" so I did so and .NET was already enabled. I also tried toggling it on and off in combination with reboots.

    Any help would be appreciated. I ran the .NET Framework Setup Verification Utility and it said 4.0 was installed. More specifically (this is a truncated part of the log):

    [09/02/12,19:05:39] Beginning of new SetupVerifier activity logging session
    [09/02/12,19:05:39] Activity log file location: C:\Users\Corey\AppData\Local\Temp\setupverifier_main_09-02-12_19.05.39.txt
    [09/02/12,19:05:39] Error log file location: C:\Users\Corey\AppData\Local\Temp\setupverifier_errors_09-02-12_19.05.39.txt
    [09/02/12,19:05:39] Build created on August 21, 2012
    [09/02/12,19:05:39] Detected operating system: Windows 7 (x64)
    [09/02/12,19:05:39] Install state for .NET Framework 1.0: not installed.
    [09/02/12,19:05:39] Install state for .NET Framework 1.1: not installed.
    [09/02/12,19:05:39] Install state for .NET Framework 2.0: not installed.
    [09/02/12,19:05:39] Install state for .NET Framework 3.0: not installed.
    [09/02/12,19:05:39] Install state for .NET Framework 3.5: not installed.
    [09/02/12,19:05:39] Install state for .NET Framework 4 Client: installed with no service packs.
    [09/02/12,19:05:39] Install state for .NET Framework 4 Full: installed with no service packs.
    [09/02/12,19:05:39] Install state for .NET Framework 4.5: not installed.
    [09/02/12,19:05:39] Windows directory: C:\Windows
    [09/02/12,19:05:39] System directory: C:\Windows\system32
    [09/02/12,19:05:39] Program Files directory: C:\Program Files (x86)
    [09/02/12,19:05:39] Common Files directory: C:\Program Files (x86)\Common Files
    [09/02/12,19:05:39] Not adding product '.NET Framework 1.0' because it is not currently installed
    [09/02/12,19:05:39] Not adding product '.NET Framework 1.1' because it is not currently installed
    [09/02/12,19:05:39] Not adding product '.NET Framework 1.1 SP1' because it is not currently installed
    [09/02/12,19:05:39] Not adding product '.NET Framework 2.0' because it is not currently installed
    [09/02/12,19:05:39] Not adding product '.NET Framework 2.0 SP1' because it is not currently installed
    [09/02/12,19:05:39] Not adding product '.NET Framework 2.0 SP2' because it is not currently installed
    [09/02/12,19:05:39] Not adding product '.NET Framework 3.0' because it is not currently installed
    [09/02/12,19:05:39] Not adding product '.NET Framework 3.0 SP1' because it is not currently installed
    [09/02/12,19:05:39] Not adding product '.NET Framework 3.0 SP2' because it is not currently installed
    [09/02/12,19:05:39] Not adding product '.NET Framework 3.5' because it is not currently installed
    [09/02/12,19:05:39] Not adding product '.NET Framework 3.5 SP1' because it is not currently installed
    [09/02/12,19:05:40] Not adding product '.NET Framework 4.5' because it is not currently installed
    [09/02/12,19:05:41] Starting verification for product .NET Framework 4 Client
    

    So do I need to install all of those previous versions? I would think 4.0 and later versions would be standalone and not build upon previous versions..

    Monday, September 3, 2012 12:45 AM

Answers

All replies