none
error APPX0703: Manifest references file 'MyAppName.dll' which is not part of the payload

    Question

  • Hi,

    imtrying since two days to Publish my new Windows 10 Universal APP to the Store but i cant generate a release Version of it. Im getting always this error. Ive already reinstalled Visual Studio, tried the Community Edition and the Professional one. I do not have any third Party references. I could generate always a release Version of the APP, but since i tried to generate the package for the store this is not possible anymore and i get this error. i dont know what to do now.

    Helge

    Sunday, September 20, 2015 3:00 PM

Answers

All replies

  • Did you recently upgraded to the UWP Tools 1.1? Happens to me since I updated as well.

    Getting rid of my BackgroundTask works as well. And it was building fine before.


    • Edited by JanLoehr Sunday, September 20, 2015 5:59 PM
    Sunday, September 20, 2015 5:53 PM
  • maybe i make a mistake, but i tried it with a new and empty solution with the same results. im using a freshly installed Visual Studio 2015 community Edition and get exactly the same error again.

    1. i create a new universal app with the Name App1
    2. i add a new component for windows universal to the solution with the Name RuntimeComponent1
    3. in App1 i add the reference to RuntimeComponent1
    4. in Class1 from RuntimeComponent1 i add this Code:

    using System;
    using System.Collections.Generic;
    using System.Linq;
    using System.Text;
    using System.Threading.Tasks;
    using Windows.ApplicationModel.Background;
    
    namespace RuntimeComponent1
    {
        public sealed class TileUpdateTask : IBackgroundTask
        {
            public void Run(IBackgroundTaskInstance taskInstance)
            {
                throw new NotImplementedException();
            }
        }
    }
    5. in the ManiFestFile (UI Mode) i declare the RuntimeComponent as Backgroundworker with a SystemEvent and the Entrypoint RuntimeComponent1.TileUpdateTask
    6. i try to create an APPPackage, enter my account credentials, select the reserved APP Name

    Sunday, September 20, 2015 5:57 PM
  • this is the generated manifestfile (i deleted some private Infos)

    <?xml version="1.0" encoding="utf-8"?>
    <Package xmlns="http://schemas.microsoft.com/appx/manifest/foundation/windows10" xmlns:mp="http://schemas.microsoft.com/appx/2014/phone/manifest" xmlns:uap="http://schemas.microsoft.com/appx/manifest/uap/windows10" IgnorableNamespaces="uap mp">
      <Identity Name="xxxxxxxx" Publisher="xxxxxxxx" Version="1.1.0.0" />
      <mp:PhoneIdentity PhoneProductId="xxxxxxxx" PhonePublisherId="00000000-0000-0000-0000-000000000000" />
      <Properties>
        <DisplayName>WiFi Tool</DisplayName>
        <PublisherDisplayName>xxxxxxxx</PublisherDisplayName>
        <Logo>Assets\StoreLogo.png</Logo>
      </Properties>
      <Dependencies>
        <TargetDeviceFamily Name="Windows.Universal" MinVersion="10.0.0.0" MaxVersionTested="10.0.0.0" />
      </Dependencies>
      <Resources>
        <Resource Language="x-generate" />
      </Resources>
      <Applications>
        <Application Id="App" Executable="$targetnametoken$.exe" EntryPoint="App1.App">
          <uap:VisualElements DisplayName="WiFi Tool" Square150x150Logo="Assets\Square150x150Logo.png" Square44x44Logo="Assets\Square44x44Logo.png" Description="App1" BackgroundColor="transparent">
            <uap:DefaultTile Wide310x150Logo="Assets\Wide310x150Logo.png">
            </uap:DefaultTile>
            <uap:SplashScreen Image="Assets\SplashScreen.png" />
          </uap:VisualElements>
          <Extensions>
            <Extension Category="windows.backgroundTasks" EntryPoint="RuntimeComponent1.TileUpdateTask">
              <BackgroundTasks>
                <Task Type="systemEvent" />
              </BackgroundTasks>
            </Extension>
          </Extensions>
        </Application>
      </Applications>
      <Capabilities>
        <Capability Name="internetClient" />
      </Capabilities>
    </Package>



    Sunday, September 20, 2015 6:00 PM
    • Proposed as answer by JanLoehr Sunday, September 20, 2015 6:11 PM
    • Marked as answer by LiveTileWizard Sunday, September 20, 2015 6:30 PM
    • Unmarked as answer by LiveTileWizard Sunday, September 20, 2015 6:32 PM
    • Marked as answer by LiveTileWizard Sunday, September 20, 2015 6:34 PM
    Sunday, September 20, 2015 6:01 PM
  • seems to work now, thank you
    Sunday, September 20, 2015 6:30 PM