none
TCP error code 10060 RRS feed

  • Question

  • Hello,

    I am trying to setup WCF service on VPS  windows server 2016. When I am trying access web service then getting below error. 

    "The connection attempt lasted for a time span of 00:00:21.0249246. TCP error code 10060: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond 51.220.26.168:808."

    I have added net.tcp  on IIS and try to on off firewall and also enable  Windows Communication Foundation Net.TCP Listener Adapter (TCP-In). but getting the same error 

    Please</g> can any one let me know what setting

    I am missing of the server.

    Thanks & Regards

    Kinshuk


    • Edited by Kinshuk Dev Saturday, July 29, 2017 5:51 AM
    Saturday, July 29, 2017 5:47 AM

All replies

  • Maybe, the service is not listening on the port the client I using?
    Saturday, July 29, 2017 10:58 AM
  • Hi Kinshuk,

    Per to the error message, this error is caused by that the connection could not be established.

    To check whether it is related with firewall, I suggest you access the service from Server 2016, will it be accessible?

    Not sure whether there is any wrong in your steps, could you share us your service configuration, client configuration and the steps you host WCF Service in IIS.

    Best Regards,

    Edward


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Monday, July 31, 2017 1:29 AM