none
Activesync issues exchange 2010 RRS feed

  • Question

  • Hi

    Facing problem in activesync (exchange 2010)

    I checked internally it's showing the below error 

    Can someone help me for solve the below

    [PS] C:\Windows\system32>Test-ActiveSyncConnectivity -ClientAccessServer CHNEXCH01 -URL "https://chnexch01.astraglobal.l
    ocal/Microsoft-server-activetsync" -MailboxCredential (get-credential design)

    The -URL and -ClientAccessServer arguments are mutually exclusive.
        + CategoryInfo          : InvalidArgument: (:) [Test-ActiveSyncConnectivity], ApplicationException
        + FullyQualifiedErrorId : 78AFAC63,Microsoft.Exchange.Monitoring.TestMobileSyncConnectivity


    Thanks 

    Wednesday, November 27, 2013 8:53 AM

All replies

  • Hello Prakazh,

    the error says it all, doesn't it? Can't use the two parameters together, so it's either ...

    Test-ActiveSyncConnectivity -ClientAccessServer CHNEXCH01 -MailboxCredential (get-credential design)
    
    # or
    
    Test-ActiveSyncConnectivity -URL "https://chnexch01.astraglobal.local/Microsoft-server-activetsync" -MailboxCredential (get-credential design) 

    Of course, if you're trying to troubleshoot ActiveSync, you are only getting started with analyzing that, so ... good luck :)

    Cheers,
    Fred


    There's no place like 127.0.0.1

    Wednesday, November 27, 2013 10:42 AM
  • Hi,

    Thanks for your replied.

    Checked in exchange server & got the below error 

    [PS] C:\Windows\system32>Test-ActiveSyncConnectivity -ClientAccessServer CHNEXCH01 -MailboxCredential (get-credential de

    sign)

    CasServer  LocalSite     Scenario        Result  Latency(MS) Error

    ---------  ---------     --------        ------  ----------- -----

    chnexch01  Default-Fi... Options         Failure             [System.Net.WebExcept...

    Thanks 


    Saturday, November 30, 2013 7:36 AM
  • Test -activesync error 

    [PS] C:\Windows\system32>Test-ActiveSyncConnectivity -ClientAccessServer CHNEXCH01 -MailboxCredential (get-credential el
    ec) | select error

    Error
    -----
    [System.Net.WebException]: The underlying connection was closed: Could not establish trust relationship for the SSL/...

    Can someone help me 

    thanks 

    Monday, December 2, 2013 6:47 AM
  • Kindly find the full error


    [PS] C:\Windows\system32>Test-ActiveSyncConnectivity -ClientAccessServer CHNEXCH01 -MailboxCredential (get-credential el
    ec) | fl


    RunspaceId                  : 093ef079-d9e9-48f3-9e1a-7818a5635fa7
    LocalSite                   : Default-First-Site-Name
    SecureAccess                : True
    VirtualDirectoryName        :
    Url                         :
    UrlType                     : Unknown
    Port                        : 0
    ConnectionType              : Plaintext
    ClientAccessServerShortName : chnexch01
    LocalSiteShortName          : Default-First-Site-Name
    ClientAccessServer          : chnexch01.astraglobal.local
    Scenario                    : Options
    ScenarioDescription         : Issue an HTTP OPTIONS command to retrieve the Exchange ActiveSync protocol version.
    PerformanceCounterName      : DirectPush Latency
    Result                      : Failure
    Error                       : [System.Net.WebException]: The underlying connection was closed: Could not establish trus
                                  t relationship for the SSL/TLS secure channel. Inner error [System.Security.Authenticatio
                                  n.AuthenticationException]: The remote certificate is invalid according to the validation
                                   procedure.
    UserName                    : elec
    StartTime                   : 12/2/2013 12:21:55 PM
    Latency                     : -00:00:01
    EventType                   : Error
    LatencyInMillisecondsString :
    Identity                    :
    IsValid                     : True

    thanks

    Monday, December 2, 2013 6:57 AM
  • Hi Prazkah,

    this error means that your exchange certificate is the source of the failure:

    [System.Security.Authentication.AuthenticationException]
    The remote certificate is invalid according to the validation procedure.

    So better check on your Exchange whether the Certificates are up-to-date and their registered names match their the one resolved from the machine you use for testing ActiveSync.

    Cheers,
    Fred


    There's no place like 127.0.0.1

    Monday, December 2, 2013 9:12 AM