locked
Problem with WebServiceClient RRS feed

  • Question

  • User364663285 posted

    Hi,
    Any idea to resolve

    Error	13	The type or namespace name 'WebServiceClient' could not be found (are you missing a using directive or an assembly reference?)	
    


    due to this line?

                        using (var client = new WebServiceClient(42, "license_key"))
                        ...
    


    Wednesday, May 2, 2018 8:10 AM

All replies

  • User753101303 posted

    Hi,

    Where is declared this class ? To be able to use a type you need :
    - to have a reference to the assembly in which it is declared
    - then you can use the type by using its full name ie var client=new MyApp.Somewhere.WebServiceClient(42, "license_key");
    - and finally

    using MyApp.Somewhere;

    allows to use the non fully qualified name : var client=new WebServiceClient(42,"license_key");

    Wednesday, May 2, 2018 8:46 AM
  • User364663285 posted

    Hi,

    I don't know which namespace to add to avoid this issue.

    Thursday, May 3, 2018 2:12 AM
  • User36583972 posted

    Hi wmec,

    Error	13	The type or namespace name 'WebServiceClient' could not be found (are you missing a using directive or an assembly reference?)	

    As far as I know, there is no such library(WebServiceClient) in net framwork. So ,please check the following options to solve your issue.

    1: Where does your project encapsulate the WebServiceClient class? You can get in touch with your project developer and get the details of the project.

    After it was found, you can refer the PatriceSc's suggestion and add references to your project.

    2: You may need install the .NET API for MaxMind minFraud Score, Insights, and Factors package. This API uses the async/await feature introduced in .NET 4.5 to provide non-blocking calls to the minFraud web services.

    To do this, type the following into the Visual Studio Package Manager Console:

    install-package MaxMind.MinFraud

    Best Regards,

    Yong Lu

    Thursday, May 3, 2018 5:57 AM
  • User753101303 posted

    Where did you see the WebServiceClient class name ? You are using a 3rd party Library ?

    If you already have a reference you could use the VS "object explorer" window to find this class (and its namespace).

    Thursday, May 3, 2018 7:40 AM
  • User364663285 posted

    Yohann,

    What to adjust, due to this error?

    PM> install-package MaxMind.MinFraud
    Attempting to resolve dependency 'MaxMind.GeoIP2 (≥ 3.0.0)'.
    install-package : 'MaxMind.GeoIP2' already has a dependency defined for 'MaxMind.Db'.
    At line:1 char:1
    + install-package MaxMind.MinFraud
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : NotSpecified: (:) [Install-Package], InvalidOperationException
        + FullyQualifiedErrorId : NuGetCmdletUnhandledException,NuGet.PowerShell.Commands.InstallPackageCommand
     

    Thursday, May 3, 2018 9:54 AM
  • User36583972 posted

    Hi wmec,

    I can install the MaxMind.MinFraud package without any errors.

    right your project -> Click Manage Nuget Packages -> browse the MaxMind.MinFraud package.

    If you are having an issue with the minFraud service, please see their support page.


    Best Regards,

    Yong Lu

    Monday, May 7, 2018 2:01 AM
  • User364663285 posted

    Sorry, how to ensure MaxMind, would be available below?

    https://app.box.com/s/yjwqsvxd60lc8n4m9m2frtxzmj5vc3s0

    Monday, May 7, 2018 7:57 AM
  • User36583972 posted

    Hi wmec,

    May be you can choose the Online option and search the MaxMind.MinFraud package.

    Best Regards,

    Yong Lu

    Tuesday, May 8, 2018 1:32 AM
  • User364663285 posted

    Are you able to see my screenshot below?

    https://1drv.ms/u/s!Ai8CrEskdewXmVZdXEXTo1Emp7ck

    Can I have more details to your current advice?

    Wednesday, May 9, 2018 1:23 PM
  • User36583972 posted

    Hi wmec,

    Are you able to see my screenshot below?

    https://1drv.ms/u/s!Ai8CrEskdewXmVZdXEXTo1Emp7ck

    Can I have more details to your current advice?

    Yes, I see you look up MaxMind.MinFraud in updates option. You need to choose the Online option and search the MaxMind.MinFraud package. Then, After installing it, it can be found in Installed packages or updates.

    I'm using the Visual Studio 2017 development tool.

    Best Regards,

    Yong Lu

    Thursday, May 10, 2018 1:54 AM
  • User364663285 posted

    Sorry to that, I am currently with VS 2013. Can you please advise how I can resolve current issue on such version?

    Thursday, May 10, 2018 4:13 AM
  • User36583972 posted

    HI wmec,

    Do you have try this:

    choose the Online option and search the MaxMind.MinFraud package. Then, After installing it, it can be found in Installed packages or updates.

    Best Regards,

    Yong Lu

    Tuesday, May 15, 2018 4:30 AM
  • User364663285 posted

    Hi,

    Sorry, any advice, to this error

    https://1drv.ms/u/s!Ai8CrEskdewXmVdwiFJymU0b3LuP

    Thursday, May 17, 2018 4:57 AM
  • User36583972 posted


    Hi wmec,

    Sorry, any advice, to this error

    https://1drv.ms/u/s!Ai8CrEskdewXmVdwiFJymU0b3LuP

    It said you have already installed related components. You can try to uninstall it and reinstall it.()

    Note: Please consult with your project developer and ensure that the operation does not affect the function of the project.


    Best Regards,

    Yong Lu

    Friday, May 18, 2018 1:49 AM
  • User364663285 posted

    Sorry, any advice to this error?

    https://1drv.ms/u/s!Ai8CrEskdewXmnVheJkTpFNm2Hxi

    Wednesday, August 22, 2018 7:39 AM
  • User364663285 posted

    Any help to this error?

    PM> install-package MaxMind.MinFraud
    Install-Package : The remote name could not be resolved: 'www.nuget.org'
    At line:1 char:16
    + install-package <<<<  MaxMind.MinFraud
        + CategoryInfo          : NotSpecified: (:) [Install-Package], WebException
        + FullyQualifiedErrorId : NuGetCmdletUnhandledException,NuGet.PowerShell.Commands.InstallPackageCommand
     
    PM> install-package maxmind.minfraud
    Install-Package : Object reference not set to an instance of an object.
    At line:1 char:16
    + install-package <<<<  maxmind.minfraud
        + CategoryInfo          : NotSpecified: (:) [Install-Package], NullReferenceException
        + FullyQualifiedErrorId : NuGetCmdletUnhandledException,NuGet.PowerShell.Commands.InstallPackageCommand
     
    PM> 

    Saturday, August 25, 2018 1:31 PM