locked
DotNet doesn't seem to be installed correctly? RRS feed

  • Question

  • User1336297068 posted

    Hi all,

    I recently moved to xp pro 64bit.  I moved all my projects/websites to the new hd exactly as they were.  I then installed Visual Studio 2008.  Then tried DotNet 2.0.  This failed as visual studio has installed dotnet2.1 sp1 (or something like that) and 2.0 said there was a later version installed.  My sites couldn't seem to process asp so i assumed 2.0 wasn't installed.  I uninstalled Visual Studio/MS SQL/2.1 and eventually it let me install 2.0.  I then installed 3.0 and 3.5.  Then reinstalled visual studio.

    Still my sites dont work.  I created a quick cmd line app with the following: Console.WriteLine(".Net Version {0}", Environment.Version.ToString());

    It generated this error:

    Error    1    The "EntityDeploy" task could not be loaded from the assembly C:\WINDOWS\Microsoft.NET\Framework\v3.5\Microsoft.Data.Entity.Build.Tasks.dll. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040) Confirm that the <UsingTask> declaration is correct, and that the assembly and all its dependencies are available.  

    I looked in the References folder of my cmd line project and they all have Yellow Warning signs next to each of the assmebly.  I tried removing them and adding them again but the same sign appears.

    I checked the .net folders and everything seems to be there.

    Any ideas?

    Tuesday, February 9, 2010 5:05 AM

All replies

  • User1336297068 posted

    had to enable asp.net in Web Service Extensions

    Tuesday, February 9, 2010 9:04 AM