none
Interfaces marked as "dual" are hidden in object browser, my solution RRS feed

  • Question

  • This is kind of complicated to repro but I have isolated it as small as possible.  I noticed it when using TLBIMP, some interfaces were not visible in Object Browser, when set to "My Solution" - but I could see them when I added them to "Custom Component list".  It happens when the interface is marked as "dual".

    Repro:

    1) Create an IDL file and make an Interface inheriting from IDispatch, add the "dual" attribute.

    2) Use MIDL.EXE and TLBIMP.EXE to make a DLL

    3) Reference the DLL from Visual C# project (I am using 15.9.3).

    4) The interface is not visible in Object Browser unless you "view hidden members and types".

    5) Close the project, and add the DLL to "Custom Component list".  The interface *is* visible without showing hidden members and types.

    6) Finally, go back to the IDL file and remove the "dual" attribute.  Now it shows up without being hidden.

    So, why are dual interfaces hidden by default in Object Browser, but only in My Solution view with a project open?  I have a feeling this is not a bug, I just don't have some setting properly set.

    Thanks.

    Sunday, December 2, 2018 3:15 PM

All replies

  • Hi tballard,

    Welcome to the MSDN forum.

    Refer to your description, this issue is about the C# development. Since our forum is to discuss the VS IDE, I will help you move this thread to the appropriate forum for a better support, thank you for your understanding.

    Best regards,

    Sara


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Monday, December 3, 2018 6:27 AM