none
.net 3.5 Required on Windows 7 32bit or Server 2008 64bit RRS feed

  • Question

  • When trying to connect to SQL Server 2008 R2 trial edition Report server, I get an error stating the .net framework 3.5 needs to be installed on this machine. I have SQL running on both Server 2008 (not R2) 64 bit and on my desktop Windows 7 32 bit. Regardless I get the same error message. I have verified that .net 3.5 is installed using the .net verification tool. .net 3.5 is installed on both machines, but when trying to access the report builder on either machine, I still get the instrruction to instal it again. Log file below:

     

    ======================================================================
    [08/01/11,11:00:51] Beginning of new SetupVerifier activity logging session
    [08/01/11,11:00:51] Activity log file location: C:\Users\davgil\AppData\Local\Temp\setupverifier_main_08-01-11_11.00.51.txt
    [08/01/11,11:00:51] Error log file location: C:\Users\davgil\AppData\Local\Temp\setupverifier_errors_08-01-11_11.00.51.txt
    [08/01/11,11:00:51] Build created on January 17, 2011
    [08/01/11,11:00:51] Detected operating system: Windows 7 (x86)
    [08/01/11,11:00:51] Install state for .NET Framework 1.0: not installed.
    [08/01/11,11:00:51] Install state for .NET Framework 1.1: not installed.
    [08/01/11,11:00:51] Install state for .NET Framework 2.0: installed with service pack 2.
    [08/01/11,11:00:51] Install state for .NET Framework 3.0: installed with service pack 2.
    [08/01/11,11:00:51] Install state for .NET Framework 3.5: installed with service pack 1.
    [08/01/11,11:00:51] Install state for .NET Framework 4 Client: installed with no service packs.
    [08/01/11,11:00:51] Install state for .NET Framework 4 Full: installed with no service packs.
    [08/01/11,11:00:51] Not adding product '.NET Framework 1.0' because it is not currently installed
    [08/01/11,11:00:51] Not adding product '.NET Framework 1.1' because it is not currently installed
    [08/01/11,11:00:51] Not adding product '.NET Framework 1.1 SP1' because it is not currently installed
    [08/01/11,11:00:51] Not adding product '.NET Framework 2.0' because it is not currently installed
    [08/01/11,11:00:51] Not adding product '.NET Framework 2.0 SP1' because it is not currently installed
    [08/01/11,11:00:51] Not adding product '.NET Framework 3.0' because it is not currently installed
    [08/01/11,11:00:51] Not adding product '.NET Framework 3.0 SP1' because it is not currently installed

    [08/01/11,11:00:51] Not adding product '.NET Framework 3.5' because it is not currently installed

     

     

    What do I need to get this working? I have installed it 5 times on each machine. I have tried turning off 3.0 so that I can install 3.5, but it's already there.

    Monday, August 1, 2011 4:03 PM

Answers

All replies