The preview screen does not work for report building


  • I am using VS 2010 connecting to a SQL 2012 database.

    When trying to preview a report I built using the Report Server Project Wizard it does not display. The preview tab does not show the report I made at all.

    When I save the report and then  deploy it, it will display on the reporting website just fine.

    Any help or ideas would be greatly appreciated.

    Thanks in advance.

    Error Message Text: 

    TITLE: Microsoft Visual Studio
    An error prevented the view from loading.

    An error occured while attempting to start the report preview worker process. (Microsoft.ReportingServices.Designer)
    CreateProcess failed with Error Code: 5 (Microsoft.ReportingServices.Designer)

    The technical details:

    An error prevented the view from loading. (Microsoft Visual Studio)

    An error occured while attempting to start the report preview worker process. (Microsoft.ReportingServices.Designer)
    Program Location:
    at Microsoft.ReportDesigner.Design.ProcessingHostProcess.StartProcess()
    at Microsoft.ReportDesigner.Design.ProcessingHostProcess.GetProcessingClient(IPreviewProcessingCallback callback)
       at Microsoft.ReportDesigner.Design.WCFProcessingHost..ctor(ProcessingHostProcess hostProcess, ILocalCatalog catalog)
       at Microsoft.ReportDesigner.Design.PreviewFrame.<>c__DisplayClass1.<CreateLocalReport>b__0()
       at Microsoft.Reporting.WinForms.LocalReport..ctor(Func`1 getNewProcessingHostInstance)
       at Microsoft.ReportDesigner.Design.PreviewFrame.CreateLocalReport()
       at Microsoft.Reporting.WinForms.ReportViewer.Reset()
       at Microsoft.ReportDesigner.Design.PreviewFrame.Initialize(ProjectReportDesigner designer)
       at Microsoft.ReportDesigner.Design.ProjectReportDesigner.CreatePreviewFrame(VsStyleToolBar pageViewToolBar)
       at Microsoft.DataWarehouse.Design.EditorWindow.EnsureViewIsLoaded(EditorView view)

    CreateProcess failed with Error Code: 5 (Microsoft.ReportingServices.Designer)
    Program Location:   at  Microsoft.ReportDesigner.Design.DependentProcessMonitor.TraceAndThrowLastError(String functionName)
       at Microsoft.ReportDesigner.Design.DependentProcessMonitor.CreateDependentProcess(String exePath, String commandLineArgs)
       at Microsoft.ReportDesigner.Design.ProcessingHostProcess.StartProcess()
    • Moved by Vicky SongMicrosoft employee Thursday, December 06, 2012 1:58 AM (From:Visual Studio Database Development Tools (Formerly "Database Edition Forum"))
    Wednesday, December 05, 2012 10:08 PM

All replies

  • Hi,

    I am moving your issue to the SSRS forum so that you can get better support there.


    Vicky Song [MSFT]
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Thursday, December 06, 2012 1:57 AM
  • Hi Nemesis_DBA,

    Regarding to the "CreateProcess failed with Error Code: 5" error, it usually occurs due to sufficient permissions. Here, I suggest that you try the following steps:

    1. In the Report Designer, right click the report and click "Run" to see if the report can be previewed properly in the pop-up window.

    2. Log onto the computer with an administratro account and check the issue again.

    3. If the report development environment is the SQL Server Data Tools (SSDT) shipped with SQL Server 2012 and you launch the SSDT via Remote Desktop Procotol (RDP) in Seamless/RAIL mode , SSDT will fail to launch Preview process. This is by design.

    Hope this helps.

    Mike Yin 

    If you have any feedback on our support, please click here

    Mike Yin
    TechNet Community Support

    Thursday, December 06, 2012 2:09 PM
  • I can right click and run the report (this will help a lot). All the reports I am working on are done with my admin account.

    I still cannot preview the report in the Preview tab.

    The reports are being generated with Visual Studio 2010 connecting to a SQL 2012 dB.

    Mark Elsen

    Thursday, December 06, 2012 3:28 PM
  • I'm having the same problem. Running/Debugging the report works, but the preview does not. The suggestions by Mike Yin do not help.
    Tuesday, April 23, 2013 3:56 PM
  • I am also having the exact same issue, except trying to use VS 2012. I can properly preview the report when I run under my normal account or as admin, but I need to run the report as (netuser) since I am connecting to a database from a different domain.

    So it is not the install of VS itself since i can get the preview to work, but not under a different user. makes sense this might be a permissions issue, but really i don't know what.


    Thursday, July 25, 2013 10:41 PM
  • Hi All,

    Mike Yin Fixed mine, except I ran Visual Studio as local Administrator instead of logging in as Admin.

    I am also running a query based on a domain Admin account as opposed to my user account, but as the credentials for this are stored in the Data Source/Data-set so I was able to run the Query regardless with not permission errors, and managed to get the Preview tab to run with no errors.


    The issue arose again for me, and was not fixed by running as admin. (I was also advised by a senior DBA that his has never worked either) - but we found that if you have built and deployed the report to a local instance you can right-click/Run from the report in Solutions Explorer which opens a window where you can view it in all it's glory. It's not ideal, but its better than no preview.

    Hope this helps.

    • Edited by KatieHarley Friday, October 23, 2015 4:25 PM
    Friday, September 25, 2015 2:18 PM