locked
ajaxToolkit:AjaxFileUpload Issues RRS feed

  • Question

  • User-195907812 posted

    Hi,

    I have a file upload control that has been working fine until I made some unrelated (in theory) changes over the last couple of weeks and now the file upload doesn't work.

    https://imgur.com/a/DAGRN

    A
    s a test, I created a new file upload:

    <ajaxToolkit:AjaxFileUpload ID="AjaxFileUpload1" runat="server" />

    But as soon as I apply client events, it doesn't render (see above):

    OnClientUploadStart="UploadStart" OnClientUploadComplete="UploadComplete"

    I've compared the output and the two versions are identical, apart from the initialisation function that is automatically created:

    // PREVIOUS BUILD (WORKING) ...
    
    <script type="text/javascript">
    //<![CDATA[
    Sys.Application.add_init(function() {
        $create(Sys.Extended.UI.AjaxFileUpload.Control, {"allowedFileTypes":"mp3","clearFileListAfterUpload":true,"clientStateField":$get("cphPageContent_ModalAudioUpload_AjaxFileUpload_ClientState"),"contextKey":"cphPageContent_ModalAudioUpload_AjaxFileUpload","maximumNumberOfFiles":1,"postBackUrl":"/my_page?id=12345","serverPollingSupport":true}, {"uploadComplete":UploadComplete,"uploadStart":UploadStart}, null, $get("cphPageContent_ModalAudioUpload_AjaxFileUpload"));
    });
    //]]>
    </script>
    </form>

    // CURRENT BUILD (NOT WORKING) ...
    
    <script type="text/javascript">
    //<![CDATA[
    Sys.Application.add_init(function() {
        $create(Sys.Extended.UI.AjaxFileUpload.Control, {"allowedFileTypes":"mp3","clearFileListAfterUpload":true,"clientStateField":$get("cphPageContent_ModalAudioUpload_AjaxFileUpload_ClientState"),"contextKey":"{DA8BEDC8-B952-4d5d-8CC2-59FE922E2923}","enabled":true,"maximumNumberOfFiles":1,"postBackUrl":"/my_page?id=12345","serverPollingSupport":true,"uploadHandlerPath":"/AjaxFileUploadHandler.axd"}, {"uploadComplete":UploadComplete,"uploadStart":UploadStart}, null, $get("cphPageContent_ModalAudioUpload_AjaxFileUpload"));
    });
    //]]>
    </script>
    </form>


    Anyone know what's happened and how to fix?

    Tuesday, October 3, 2017 2:19 PM

Answers

All replies