none
Random AppCrashes in clr.dll with .NET 4.0 RRS feed

  • General discussion

  • Hi Everyone !

    We are developing a 100% managed .NET Application/C# that consists of several Windows-Services and Client-Applications. Until April 2010 the Target was .Net 3.5 SP1. Meanwhile we converted all Projects to target .NET 4.0. And now we are expierencing APP-Crashes which happens every now and then (1 or twice a Week) if we are running our Tests on Win7 or 2008 R2.

    The Faults are of Sort: 

    Faulting application name: DoX.FX.ServerHostLoader.exe, version: 0.1.16070.73, time stamp: 0x4c403ab2

    Faulting module name: clr.dll, version: 4.0.30319.1, time stamp: 0x4ba21eeb

    Exception code: 0xc0000005

    Fault offset: 0x00000000000026fe

    Faulting process id: 0x5e8

    Faulting application start time: 0x01cb404b8b0740a1

    Faulting application path: C:\DoX.FX.ServerHostLoader.exe

    Faulting module path: C:\Windows\Microsoft.NET\Framework64\v4.0.30319\clr.dll

    Report Id: 2311172d-afbc-11df-9ded-0002b3c23d42

     

    In some cases I get a Mini-Dump which I was able to debug to a certain point, the Methods where the crash happens are different e.g.

    Process Architecture: x64
    Exception Code: 0xC0000005
    Exception Information: The thread tried to read from or write to a virtual address for which it does not have the appropriate access.
    Heap Information: Not Present

    System Information
    ------------------
    OS Version: 6.1.7600
    CLR Version(s): 4.0.30319.1

    > clr.dll!JIT_ChkCastClassSpecial()  + 0x1e bytes 
      [Managed to Native Transition] 
      mscorlib.dll!System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext executionContext, System.Threading.ContextCallback callback, object state, bool ignoreSyncCtx) + 0xa1 bytes 
      mscorlib.dll!System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext executionContext, System.Threading.ContextCallback callback, object state) + 0x3b bytes 
      mscorlib.dll!System.Threading.ThreadHelper.ThreadStart() + 0x4d bytes 
      [Native to Managed Transition] 
      kernel32.dll!BaseThreadInitThunk()  + 0xd bytes 
      ntdll.dll!RtlUserThreadStart()  + 0x21 bytes 

    We now rolled back all our projects to .NET 3.5 Target, and the above AppCrash did not occur anymore (In a 1-Week continous Test). So we went searching for this error but suprisingly there are only few others that reported this error. Since this is an internal CLR-Error of .NET 4.0 we cannot believe that we are the only ones having this problem. But maybe the are more around also still trying to find a reason for it ? Would be glad to ge some Idea about this.

    Sigi

     

     

     

     

    Monday, September 13, 2010 4:10 PM

All replies

  • Sigi,

    Have you troed the latest fix for clr? It is here:

    https://connect.microsoft.com/VisualStudio/Downloads/DownloadDetails.aspx?DownloadID=29638.

    If issue still occurs after that, the next thing would be to collect full dumps and open a paid support case with us. If this happens to be a bug you will will get a complete refund for the support case of course. Please visit this link to see the various paid support options that are available to better meet your needs:  http://support.microsoft.com/default.aspx?id=fh;en-us;offerprophone.


    --Trevor H.
    Send files to Hotmail.com: "MS_TREVORH"
    Check out the Microsoft CTS TFS BLOG: blogs.msdn.com/b/dstfs
    Monday, September 27, 2010 4:20 PM
    Moderator
  • Hi Trevor !

    Thanks for you reply, I almost forgot to have a look into here since I did not get an answer after a couple of days. We are still running Tests and collecting dumps.

    I'm looking into the lsit of available hotfixes every day, but up to now there is no hotfix that seems to target our problem.

    I think we will open a paid support case soon, meanwhile we have lot's of dumps to check.

    Sigi

     

    Monday, October 25, 2010 9:34 AM
  • Hi Sigi,

    Did you end up resolving this issue?  I've been experiencing a similar problem with the exact same version of the Framework and OS.  I've opened a support case with MS but wondered whether your issue had been resolved?

    Thanks,

    Darren

    Thursday, March 17, 2011 8:46 AM
  • Oh, i got the same issue with my Vs 2010 SP1 Utimate

     

    Problem signature:
      Problem Event Name:    APPCRASH
      Application Name:    devenv.exe
      Application Version:    10.0.40219.1
      Application Timestamp:    4d5f2a73
      Fault Module Name:    clr.dll
      Fault Module Version:    4.0.30319.225
      Fault Module Timestamp:    4d53688b
      Exception Code:    c0000005
      Exception Offset:    0000f94c
      OS Version:    6.1.7601.2.1.0.272.7
      Locale ID:    1066
      Additional Information 1:    362f
      Additional Information 2:    362f0d712634c438c878085443e738f7
      Additional Information 3:    7cdc
      Additional Information 4:    7cdc426cf14a5a86bb6c4f51e22a70b

    --------------------------------------------------------------------

    My project is web application on .netfx 3.5

    This issue occurs every time i open designer mode for ascx / aspx

    it's not usual, but if it occurs, i have to restart computer for resolving it.

    Now I better love Vs 2008!

     

    Thursday, April 14, 2011 6:54 AM
  • I am having similar issue with .NET framework 4.0 Windows Form Application which is running on Windows Server 2008 64 bit machine. My application was crashed automatically with the following logs in event viewer. Application is built using VS 2010 with the target framework (.NET Framework 4 Client Profile)

    Any fix for this?

     

    Error 28/06/2011 7:35:21 a.m. Application Error 1000 (100)

    Faulting application Concentrator.exe, version 1.0.0.0, time stamp 0x4e001fa2, faulting module clr.dll, version 4.0.30319.235, time stamp 0x4da3fdf5, exception code 0xc0000005, fault offset 0x001142e6, process id 0x%9, application start time 0x%10.

     

    Error 28/06/2011 7:35:21 a.m. .NET Runtime 1023 None

    Application: Concentrator.exe

    Framework Version: v4.0.30319

    Description: The process was terminated due to an internal error in the .NET Runtime at IP 709F42E6 (708E0000) with exit code 80131506.

     


    Maqsood Ahmad

    Tuesday, June 28, 2011 11:15 PM
  • Hi Sigi, I get the very same error you reported.

    Just after switching to .net 4.0 with sql server R2, we weekly get that error.

    Did you managed to resolve it?

     

    Thank by the way.

     

     

    Gas.

    Monday, July 11, 2011 9:01 AM
  • I have the same issue working with BizTalk 2010. Here is the Environment which I built. Windows Server 2008 R2 Visual Studio 2010 SP1 Ultimate SQL Server 2008R2 Installed the Hot Fix posted in the Forum (not fixed the issue yet) Faulting application name: BTSNTSvc64.exe, version: 3.9.469.0, time stamp: 0x4c548eb4 Faulting module name: clr.dll, version: 4.0.30319.431, time stamp: 0x4d534433 Exception code: 0xc0000005 Fault offset: 0x0000000000001187 Faulting process id: 0x15e0 Faulting application start time: 0x01cc432d7568d730 Faulting application path: D:\Program Files (x86)\Microsoft BizTalk Server 2010\BTSNTSvc64.exe Faulting module path: C:\Windows\Microsoft.NET\Framework64\v4.0.30319\clr.dll Report Id: ba41cd83-af21-11e0-bc5a-005056910065 If any one finds a solution with this issue please help me out. Thanks in advance.
    Friday, July 15, 2011 8:40 PM
  • Hi Sigi_B,

    Whole forum was asking whether you have found the resolution, I also ran into the same issue... Could you please let us know whether you were able to resolve, and how?

     

    thanks


    HydPhani
    Monday, July 25, 2011 3:07 PM
  • Amazing Trevor, Thank you very much for this solution.. though stack overflow folks solved this issue by windows update/ VS2010 servicepack1 installation, but on my machine above connect.microsoft.com download worked like a magic...

    thanks a ton,

     


    HydPhani
    Monday, August 1, 2011 2:41 PM
  • Hi, I'm just trying this brand new update from Microsoft: http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=27014

    I'll let you know if it helps!

    UPDATE: The real thing that solved was to execute the program with startup useLegacyV2RuntimeActivationPolicy="true" option.

     

    Bye



    • Edited by Gasgas Friday, September 16, 2011 1:19 PM
    Friday, September 2, 2011 9:24 AM
  • We run a *lot* of in-house 64 bit WinForms apps under .net 4.0 on Windows Server 2008R2.  Today I saw the error reported on this thread.  It was the first time I've seen this since we started using .Net 4.0 about a year ago.

    Faulting application name: ABC.exe, version: 1.0.0.0, time stamp: 0x4f103b24
    Faulting module name: clr.dll, version: 4.0.30319.239, time stamp: 0x4e1822f4
    Exception code: 0xc0000005
    Fault offset: 0x000000000018c9dc
    Faulting process id: 0x118c
    Faulting application start time: 0x01ccd1fe2e03483f
    Faulting application path: \\srv-16\prod_env$\ABC.exe
    Faulting module path: C:\Windows\Microsoft.NET\Framework64\v4.0.30319\clr.dll
    Report Id: a9fe57b6-3e17-11e1-ad56-20cf3074aa43

    Our app does use an unmanaged component.  This machine has the latest patches per Windows Update.

    Any suggestions?

    Friday, January 13, 2012 7:38 PM
  • Thanks Trevor. The fix worked for me. Hopefully, it does not return like others have observed. I still wonder why did it pop up suddenly even though I did not change any thing in my system. Given that this is already 1.5 years from your post, it gives me an impression that something is still wrong. Fingers crossed though, the build seems to be working fine.

    To, everyone, who are still looking forward for help: I had the same issue as shown below, but after installing the fix https://connect.microsoft.com/VisualStudio/Downloads/DownloadDetails.aspx?DownloadID=29638, the issue seems to be fixed.

    ------------------------------------------------------------------------------------------------

    Generating XSD classes - ..\deploy\RuntimeConfiguration.xsd

    NMAKE : fatal error U1077:
    '...\tools\build\buildtypes\build_xsd.cmd' : return code '0xc0000005'

    Problem signature:
    Problem Event Name:    APPCRASH
    Application Name:    xsd.exe
    Application Version:    4.0.30319.1
    Application Timestamp:    4ba224fb
    Fault Module Name:    clr.dll
    Fault Module Version:    4.0.30319.235
    Fault Module Timestamp:    4da4281c

    Exception Code:      c0000005

    --------------------------------------------------------------------------------------------------

    Tuesday, February 14, 2012 9:26 PM
  • Interestingly I found this blog that describes each version of the clr:

    http://blogs.msdn.com/b/dougste/archive/2011/09/30/version-history-of-the-clr-4-0.aspx

    Version 526 (4.0.30319.526) says 'FIX: "Faulting module name: clr.dll" error message when you run a Microsoft .NET Framework 4-based application' which takes you to http://support.microsoft.com/kb/2640103/ which looks like it addresses the exception code posted at the start of this thread.

    Separate from that, I downloaded the HotFix from the link posted by themasher and after the upgrade, I see that it appears to contain version 4.0.30319.488

    c:\windows\microsoft.net\framework64\v4.0.30319\clr.dll:
            Verified:       Signed
            Signing date:   1:06 PM 7/11/2011
            Publisher:      Microsoft Corporation
            Description:    Microsoft .NET Runtime Common Language Runtime - WorkStation
            Product:        Microsoft« .NET Framework
            Version:        4.0.30319.488
            File version:   4.0.30319.488 (RTMLDR.030319-4800)

    During installation  of the HotFix from themasher's thread, it appears that this patch is only available for .net 4.0 Client Profile and there is a post about that - https://connect.microsoft.com/VisualStudio/feedback/details/720374/faulting-module-name-clr-dll-error-message-when-you-run-a-microsoft-net-framework-4-based-application

    So if you don't use Client Profile, I'm not even sure what this HotFix will  give you.

    Unfortunately I've experienced the crash with "Exception code: 0xc0000005" just once, so I can't really determine if either 4.0.30319.488 or 4.0.30319.526 fixes the problem, but I invite someone else to try .526 and report back to this thread.

    Wednesday, February 15, 2012 2:09 PM
  • Hi,

    I am having a similar issue were you able to fix the issue?

    Regards

    Padma

    Friday, February 24, 2012 5:24 PM
  • Sevzas,

    I'm running 4.0.30319.544 and receive a crash randomly

    Fault Module Name: clr.dll

      Fault Module Version: 4.0.30319.544

      Fault Module Timestamp: 4ee9a8e7

      Exception Code: c0000005

      Exception Offset: 00003e04

      OS Version: 6.1.7601.2.1.0.768.3

    Any updates on a fix?

    Configuration:

    Windows 7 64

    VS2010 Ultimate running .net 4

    Wednesday, May 9, 2012 3:34 PM
  • cevans3098,

    I saw this issue just once, so I don't have any updates for this thread.  If I were experiencing this problem randomly like you, I might try to instrument my machine so that a minidump is created when a crash occurs.  That way you might be able to post a stack to this thread or engage Microsoft tech support in some fashion.  Here are some instructions on doing this: http://blogs.msdn.com/b/dotnet/archive/2009/10/15/automatically-capturing-a-dump-when-a-process-crashes.aspx

    Good luck!

    -Sev

    Wednesday, May 9, 2012 4:15 PM
  • sevzas-

    I followed the instructions in that msdn blog and was able to create a minidump of the clr.dll appcrash.  what should I do with this file? not much information in windbg

    -Craig

    Friday, May 11, 2012 2:02 AM
  • Craig,

    That's great that you can get a minidump.  At this point if I were you, I might try one or both of these two things:

    1. Extract the offending stacktrace and google it or some part of it to see if others have seen the same thing.  It would certainly be great if you could post it.

    2. Create a support case with Microsoft.  See Trevor Hancock's post (2nd on this thread).

    -Sev

    Friday, May 11, 2012 5:28 PM
  • I'm really new to windbg, so I'm not sure what I am doing or what to look for.  Attached is what is returned when I use:

    analyze -v -crash

    *******************************************************************************
    *                                                                             *
    *                        Exception Analysis                                   *
    *                                                                             *
    *******************************************************************************


    FAULTING_IP:
    +64f14140
    00000000`00000000 ??              ???

    EXCEPTION_RECORD:  ffffffffffffffff -- (.exr 0xffffffffffffffff)
    ExceptionAddress: 0000000000000000
       ExceptionCode: 80000007 (Wake debugger)
      ExceptionFlags: 00000000
    NumberParameters: 0

    BUGCHECK_STR:  HANG

    PROCESS_NAME:  Test Stand Interface.exe

    ERROR_CODE: (NTSTATUS) 0xcfffffff - <Unable to get error code text>

    EXCEPTION_CODE: (NTSTATUS) 0xcfffffff - <Unable to get error code text>

    MOD_LIST: <ANALYSIS/>

    NTGLOBALFLAG:  0

    APPLICATION_VERIFIER_FLAGS:  0

    MANAGED_STACK:
    (TransitionMU)
    000000000085DEA0 000007FF002D4B60 netchartdir!ChartDirector.DrawArea.a(Double, Double, Double, Double, Int32, Int32)+0x480
    000000000085DFE0 000007FF00371643 netchartdir!ChartDirector.DrawArea.c(Double, Double, Double, Double, Int32, Int32)+0x93
    000000000085E080 000007FF00370B25 netchartdir!ChartDirector.LineLayer.paint()+0x3a5
    000000000085E1E0 000007FF002D1292 netchartdir!ChartDirector.PlotArea.c(Boolean)+0x102
    000000000085E250 000007FF002CEE94 netchartdir!ChartDirector.XYChart.onPaint()+0x74
    000000000085E280 000007FF002CA2EE netchartdir!ChartDirector.BaseChart.c()+0xce
    000000000085E330 000007FF002CA1E0 netchartdir!ChartDirector.BaseChart.makeImage()+0x10
    000000000085E360 000007FF002C6CDF Graphing!Evans.Chart.drawChart(ChartDirector.WinChartViewer, System.String, System.String)+0x44f
    000000000085E490 000007FF002C67F4 Graphing!Evans.Chart.winChartViewer1_ViewPortChanged(System.Object, ChartDirector.WinViewPortEventArgs)+0x94
    000000000085E4E0 000007FF002C64E1 netchartdir!ChartDirector.WinChartViewer.updateViewPort(Boolean, Boolean)+0x91
    000000000085E520 000007FF002C6425 Graphing!Evans.Chart.TimerChart_Tick(System.Object, System.EventArgs)+0x75
    000000000085E560 000007FEE7CF3B99 System_Windows_Forms_ni!System.Windows.Forms.Timer+TimerNativeWindow.WndProc(System.Windows.Forms.Message ByRef)+0x49
    000000000085E590 000007FEE7D70CFC System_Windows_Forms_ni!System.Windows.Forms.NativeWindow.Callback(IntPtr, Int32, IntPtr, IntPtr)+0x16c
    000000000085E660 000007FEE8601B20 System_Windows_Forms_ni!DomainBoundILStubClass.IL_STUB_ReversePInvoke(Int64, Int32, Int64, Int64)+0x50
    (TransitionUM)
    (TransitionMU)
    000000000085E960 000007FEE7D9DA10 System_Windows_Forms_ni!DomainBoundILStubClass.IL_STUB_PInvoke(MSG ByRef)+0x50
    000000000085EA30 000007FEE7D8B194 System_Windows_Forms_ni!System.Windows.Forms.Application+ComponentManager.System.Windows.Forms.UnsafeNativeMethods.IMsoComponentManager.FPushMessageLoop(IntPtr, Int32, Int32)+0x634
    000000000085EC70 000007FEE7D8A9A3 System_Windows_Forms_ni!System.Windows.Forms.Application+ThreadContext.RunMessageLoopInner(Int32, System.Windows.Forms.ApplicationContext)+0x593
    000000000085EDD0 000007FEE7D8A331 System_Windows_Forms_ni!System.Windows.Forms.Application+ThreadContext.RunMessageLoop(Int32, System.Windows.Forms.ApplicationContext)+0x81
    000000000085EE60 000007FEED6E94CA Microsoft_VisualBasic_ni!Microsoft.VisualBasic.ApplicationServices.WindowsFormsApplicationBase.OnRun()+0xea
    000000000085EEC0 000007FEED6E7D84 Microsoft_VisualBasic_ni!Microsoft.VisualBasic.ApplicationServices.WindowsFormsApplicationBase.DoApplicationModel()+0xe4
    000000000085EF50 000007FEED6E8724 Microsoft_VisualBasic_ni!Microsoft.VisualBasic.ApplicationServices.WindowsFormsApplicationBase.Run(System.String[])+0x84
    000000000085EFF0 000007FF001401FE Test_Stand_Interface!Evans.My.MyApplication.Main(System.String[])+0x5e
    (TransitionUM)

    EXCEPTION_OBJECT: !pe 2ad1228
    Exception object: 0000000002ad1228
    Exception type:   System.ExecutionEngineException
    Message:          <none>
    InnerException:   <none>
    StackTrace (generated):
    <none>
    StackTraceString: <none>
    HResult: 80131506

    MANAGED_OBJECT_NAME:  System.ExecutionEngineException

    MANAGED_STACK_COMMAND:  _EFN_StackTrace

    DERIVED_WAIT_CHAIN: 

    Dl Eid Cid     WaitType
    -- --- ------- --------------------------
       0   7f0.a8c Unknown               

    WAIT_CHAIN_COMMAND:  ~0s;k;;

    BLOCKING_THREAD:  0000000000000a8c

    DEFAULT_BUCKET_ID:  APPLICATION_HANG_WRONG_SYMBOLS

    PRIMARY_PROBLEM_CLASS:  APPLICATION_HANG_WRONG_SYMBOLS

    LAST_CONTROL_TRANSFER:  from 000007feed8e8d0b to 000007feed8eb05c

    ADDITIONAL_DEBUG_TEXT:  Followup set based on attribute [Is_ChosenCrashFollowupThread] from Frame:[0] on thread:[PSEUDO_THREAD]

    STACK_TEXT: 
    00000000`0085dea0 00000000`ffffffff netchartdir!ChartDirector.DrawArea.a+0x480
    00000000`0085dfe0 00000000`ffffffff netchartdir!ChartDirector.DrawArea.c+0x93
    00000000`0085e080 00000000`ffffffff netchartdir!ChartDirector.LineLayer.paint+0x3a5
    00000000`0085e1e0 00000000`ffffffff netchartdir!ChartDirector.PlotArea.c+0x102
    00000000`0085e250 00000000`ffffffff netchartdir!ChartDirector.XYChart.onPaint+0x74
    00000000`0085e280 00000000`ffffffff netchartdir!ChartDirector.BaseChart.c+0xce
    00000000`0085e330 00000000`ffffffff netchartdir!ChartDirector.BaseChart.makeImage+0x10
    00000000`0085e360 00000000`ffffffff graphing!Evans.Chart.drawChart+0x44f
    00000000`0085e490 00000000`ffffffff graphing!Evans.Chart.winChartViewer1_ViewPortChanged+0x94
    00000000`0085e4e0 00000000`ffffffff netchartdir!ChartDirector.WinChartViewer.updateViewPort+0x91
    00000000`0085e520 00000000`ffffffff graphing!Evans.Chart.TimerChart_Tick+0x75
    00000000`0085e560 00000000`ffffffff system_windows_forms_ni!System.Windows.Forms.Timer_TimerNativeWindow.WndProc+0x49
    00000000`0085e590 00000000`ffffffff system_windows_forms_ni!System.Windows.Forms.NativeWindow.Callback+0x16c
    00000000`0085e660 00000000`ffffffff system_windows_forms_ni!DomainBoundILStubClass.IL_STUB_ReversePInvoke+0x50
    00000000`0085e960 00000000`ffffffff system_windows_forms_ni!DomainBoundILStubClass.IL_STUB_PInvoke+0x50
    00000000`0085ea30 00000000`ffffffff system_windows_forms_ni!System.Windows.Forms.Application_ComponentManager.System.Windows.Forms.UnsafeNativeMethods.IMsoComponentManager.FPushMessageLoop+0x634
    00000000`0085ec70 00000000`ffffffff system_windows_forms_ni!System.Windows.Forms.Application_ThreadContext.RunMessageLoopInner+0x593
    00000000`0085edd0 00000000`ffffffff system_windows_forms_ni!System.Windows.Forms.Application_ThreadContext.RunMessageLoop+0x81
    00000000`0085ee60 00000000`ffffffff microsoft_visualbasic_ni!Microsoft.VisualBasic.ApplicationServices.WindowsFormsApplicationBase.OnRun+0xea
    00000000`0085eec0 00000000`ffffffff microsoft_visualbasic_ni!Microsoft.VisualBasic.ApplicationServices.WindowsFormsApplicationBase.DoApplicationModel+0xe4
    00000000`0085ef50 00000000`ffffffff microsoft_visualbasic_ni!Microsoft.VisualBasic.ApplicationServices.WindowsFormsApplicationBase.Run+0x84
    00000000`0085eff0 00000000`ffffffff test_stand_interface!Evans.My.MyApplication.Main+0x5e


    FOLLOWUP_IP:
    clr!WKS::gc_heap::plan_phase+454
    000007fe`ed8eb05c f70100000080    test    dword ptr [rcx],80000000h

    SYMBOL_STACK_INDEX:  0

    SYMBOL_NAME:  clr!WKS::gc_heap::plan_phase+454

    FOLLOWUP_NAME:  MachineOwner

    MODULE_NAME: clr

    IMAGE_NAME:  clr.dll

    DEBUG_FLR_IMAGE_TIMESTAMP:  4ee99e7c

    STACK_COMMAND:  _EFN_StackTrace ; ** Pseudo Context ** ; kb

    BUCKET_ID:  X64_HANG_clr!WKS::gc_heap::plan_phase+454

    FAILURE_BUCKET_ID:  APPLICATION_HANG_WRONG_SYMBOLS_cfffffff_clr.dll!WKS::gc_heap::plan_phase

    Followup: MachineOwner
    ---------

    Any ideas on how to proceed to retrieve more useful information?

    Craig

    Saturday, May 12, 2012 10:54 PM
  • Craig,

    This is good progress.  A couple things to think about:

    1. Is there any *unmanaged* code in your app?  If so, then it's easy to corrupt some piece of memory that the clr uses and we should probably be reviewing the unmanaged code.  I noticed that the stack contains references to ChartDirector.  If any portion of ChartDirector is unmanaged, (I am not familiar with this tool) I would look into this and maybe submit the problem to ChartDirector.

    2. Perhaps the cause is something on your machine - wrong version of DLL somewhere.  Have you been able to reproduce this on another machine?  You should try to rule out this possibility.

    3. Do the results of analyze -v look the same every time the app crashes?   

    4. Maybe review this: http://stackoverflow.com/questions/967044/system-executionengineexception-failure

    5. Maybe analyze -v can tell you more if you load the symbols file?  See http://dralu.com/?p=130

    Good luck!

    -Sev

    Monday, May 14, 2012 1:08 PM
  • Hello,

    It's funny but by any chance does anyone know how to resolve this issue in Windows 2012?

    The suggested hotfix by trevor doesn't install in Windows 2012.. yet the issue is 100% identical.

    with a little twist that IIS 8 litterally recycles it self because of it with the "informational" messages:

    Fault bucket , type 0
    Event Name: APPCRASH
    Response: Not available
    Cab Id: 0

    Problem signature:
    P1: w3wp.exe
    P2: 8.0.9200.16384
    P3: 50108835
    P4: clr.dll
    P5: 4.0.30319.18033
    P6: 50b5a6ba
    P7: c0000005
    P8: 0000000000004674
    P9:
    P10:

    Attached files:

    These files may be available here:
    C:\ProgramData\Microsoft\Windows\WER\ReportQueue\AppCrash_w3wp.exe_f0ea49324f508752622628c1a127a5891c5759_d6f5d298

    Analysis symbol:
    Rechecking for solution: 0
    Report Id: 94b5abd8-819e-11e2-940e-e357cf51456e
    Report Status: 4
    Hashed bucket:

    and another one:

    Application: w3wp.exe
    Framework Version: v4.0.30319
    Description: The process was terminated due to an internal error in the .NET Runtime at IP 000007F9430C0986 (000007F942E90000) with exit code 80131506.

    These come right after the clr.dll error and <all> websites drop for a few seconds (recycling IIS).

    Anyone expiriencing the same issue in Windows 2012? and is there a hotfix for that1 too? as i'm searching but i can't find it >.<

    Regards,

    Marco


    Key4ce - IT professionals: www.key4ce.eu

    Thursday, February 28, 2013 12:57 PM
  • Hi All,

    I also experienced the same error after applying hot fix in KB article 2640103. Here are the event log entries:

    Log Name:      Application
    Source:        Application Error
    Date:          3/5/2013 12:33:20 PM
    Event ID:      1000
    Task Category: (100)
    Level:         Error
    Keywords:      Classic
    User:          N/A
    Computer:      mycpu
    Description:
    Faulting application name: myapp.exe, version: 1.2.1303.101, time stamp: 0x5130a6eb
    Faulting module name: clr.dll, version: 4.0.30319.526, time stamp: 0x4eb3b6b1
    Exception code: 0xc0000005
    Fault offset: 0x0013d0df
    Faulting process id: 0x1350
    Faulting application start time: 0x01ce19e09cd75fd9
    Faulting application path: C:\myapp.exe
    Faulting module path: C:\Windows\Microsoft.NET\Framework\v4.0.30319\clr.dll
    Report Id: ea51a1e8-85d3-11e2-b778-00a0d5ffff85

    My environment is Win 7 embedded 32-bit. Application was built with .NET 4 (not client profile) with VS2010.

    Has anyone found any other resolution to this issue? Thanks in advanced.

    stephen

    Tuesday, March 5, 2013 9:14 PM
  • Hey,

    For my issue on Windows 2012 it was fixed by:

    1) Run windows update --> was 2 framework updates

    2) Remove asp.net 4.0 from IIS (both extended as .net 4.0)

    3) Re-add asp.net 4.0 to IIS (both extended as .net 4.0)

    - In Windows 2012 aspnet_regiis is no longer working so the remove/ add method is pretty much "the only way" in the end all of them added together fixed up the issue and i haven't seen it since i wrote my last "help" request above.

    So hopefully any of this information is handy for you too.

    Regards,

    Marco


    Key4ce - IT professionals: www.key4ce.eu

    Tuesday, March 5, 2013 9:42 PM
  • Thanks for your reply Marco. The app I'm troubleshooting is a WPF app. Since applying the hotfix doesn't seem to address my issue, I'm in the process of getting a crash dump. Hopefully I can determine the cause. I will report back when I have more info.


    Wednesday, March 6, 2013 9:16 PM
  • Hi Sevzas,

    I am having similar issue with .NET framework 4.0 Windows Form Application which is running on Windows Server 2008 64 bit machine. My application was crashed automatically with the following logs in event viewer. Application is built using VS 2010 with the  framework (.NET Framework 4 Client Profile and (.NET Framework 4 Extended)

    When the app crash, in the windows event viewer, I could see following log:


    Faulting application name: myApp.exe, version: 2.3.3.4, time stamp: 0x51d9e363

    Faulting module name: clr.dll, version: 4.0.30319.1, time stamp: 0x4ba1d9ef

    Exception code: 0xc0000409

    Fault offset: 0x002b5b8c

    Faulting process id: 0x3630

    Faulting application start time: 0x01ceaa9e6204404b

    Faulting application path: C:\Program Files (x86)\...\myApp.exe

    Faulting module path: C:\Windows\Microsoft.NET\Framework\v4.0.30319\clr.dll

    Report Id: c8d0dbbe-1757-11e3-b318-a0b3cce86d6e
    the difference with others in this thread is that: my exception code is 0xc0000409, not  0xc0000005.

    Do you think the issue is the version of clr.dll which I used?

    Could you tell me if I should use hotfix mentioned by themaster?

    Thank you.

    Guo Feng


    • Edited by Guo Feng Saturday, September 7, 2013 7:53 AM
    Saturday, September 7, 2013 7:52 AM
  • I have had the same APPCRASH error, and found that the problem was actually that the customer had a cell phone connected to the computer. This caused my program to select it for the network interface since it was the fastest one. Once they removed the usb device, the program ran fine every time. Not necessarily your issue, but you never know.
    Friday, January 24, 2014 4:51 PM
  • All,

    I've just recently started getting this same issue every-time I try and run my web site. I tried to go through the links and perform any of the hot fixes, but they were unable to be applied on my machine, I assume I already have them. My site worked yesterday morning and appeared to have stopped working after I installed some Oracle drivers (which I have since un-installed).

    Is this something that I would need to create a dump of my application and create a support ticket with Microsoft to resolve? My only thought that I haven't done yet is to uninstall/reinstall the .net framework.

    Any thoughts?

    Thanks,

    Steve

    Wednesday, October 8, 2014 6:54 PM
  • I'm having the same issue recently.  
    Thursday, October 9, 2014 8:23 PM
  • 14-Dec-2014 (4 years later)

    same issue


    Sunday, December 14, 2014 2:12 PM
  • 27-Jan-2015

    same issue

    Faulting application name: w3wp.exe, version: 7.5.7601.17514, time stamp: 0x4ce7afa2
    Faulting module name: clr.dll, version: 4.0.30319.18408, time stamp: 0x52310752
    Exception code: 0xc0000005
    Fault offset: 0x000000000009ada9
    Faulting process id: 0x1c8
    Faulting application start time: 0x01d03a049c10586f
    Faulting application path: c:\windows\system32\inetsrv\w3wp.exe
    Faulting module path: C:\Windows\Microsoft.NET\Framework64\v4.0.30319\clr.dll
    Report Id: dda7097b-a5f7-11e4-be8a-3e2703000899

    Tuesday, January 27, 2015 8:02 AM
  • Friday, April 10, 2015 10:11 AM
  • We are using .net version 4.6.2 (latest) and we randomly get this same Application error.
    Wednesday, May 3, 2017 6:58 PM
  • Hi

    I have the same issue

    The link (https://connect.microsoft.com/VisualStudio/Downloads/DownloadDetails.aspx?DownloadID=29638) is broken, do someone know another link about this fix?

    Monday, July 17, 2017 5:36 PM
  • Similar Issue in 2017: Visual Studio 2017 crashes after the Splash Screen coming up for 3 Seconds ;(

    Name der fehlerhaften Anwendung: devenv.exe, Version: 15.0.27004.2005, Zeitstempel: 0x59e69397
    Name des fehlerhaften Moduls: clr.dll, Version: 0.0.0.0, Zeitstempel: 0x59b8358b
    Ausnahmecode: 0xc0000005
    Fehleroffset: 0x00567866
    ID des fehlerhaften Prozesses: 0x750
    Startzeit der fehlerhaften Anwendung: 0x01d34e2d52447a9e
    Pfad der fehlerhaften Anwendung: C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\Common7\IDE\devenv.exe
    Pfad des fehlerhaften Moduls: C:\Windows\Microsoft.NET\Framework\v4.0.30319\clr.dll
    Berichtskennung: d0e79a51-395e-4035-9ab6-fb3d9e97915d
    Vollständiger Name des fehlerhaften Pakets:
    Anwendungs-ID, die relativ zum fehlerhaften Paket ist:

    by clicking on the Start-Menu in Windows 10, the following Error raises - could it be the same .NET failure?

    Name der fehlerhaften Anwendung: ShellExperienceHost.exe, Version: 10.0.16299.15, Zeitstempel: 0x59cda974
    Name des fehlerhaften Moduls: Windows.UI.Xaml.dll, Version: 10.0.16299.15, Zeitstempel: 0xf6706fe0
    Ausnahmecode: 0xc000027b
    Fehleroffset: 0x00000000003fa23d
    ID des fehlerhaften Prozesses: 0xecc
    Startzeit der fehlerhaften Anwendung: 0x01d34e2d3d5ceb74
    Pfad der fehlerhaften Anwendung: C:\Windows\SystemApps\ShellExperienceHost_cw5n1h2txyewy\ShellExperienceHost.exe
    Pfad des fehlerhaften Moduls: C:\Windows\System32\Windows.UI.Xaml.dll
    Berichtskennung: 32cc4e11-e2b3-4523-a1c3-09a4fba4ddd8
    Vollständiger Name des fehlerhaften Pakets: Microsoft.Windows.ShellExperienceHost_10.0.16299.15_neutral_neutral_cw5n1h2txyewy
    Anwendungs-ID, die relativ zum fehlerhaften Paket ist: App

    i have already checked:

    1. scf
    2. NDP40-KB2533523-x86.exe
    3. NetFxRepairTool.exe
    4. Repairing VS2017 Community Edition

    After Installing vs2017 it works fine - the Troubles began after updating references through nuget or installing UwpDesktop

    thnx

    Thursday, October 26, 2017 7:51 AM