none
Setting up List Item level permissions in SharePoint 2013

    Question

  • Hi,

    I have a List in SharePoint 2013.

    What I want-

    >> Only the item creators can view and edit their own items
    >> 2 Managers can view and edit items crated by a group of item creators
    >> another 2 Managers can view and edit items created by another group of item creators, and so on...

    What I did-

    >> I have setup the list that only the creators can view and edit their own items
    >> Assigned Contribute right to all the managers on the list
    >> Assigned Full Control right to the specific group of managers on the specific items through Nintex workflow on Item submission.

    I saw the permissions are being assigned by Nintex workflow correctly but the managers can not access the items. It generates error like-  "Item does not exist. It may have been removed or renamed by another users"

    Thanks in advance for any idea to resolve it.

    Sunday, February 12, 2017 5:04 AM

Answers

  • The problem is that you've set the list to only allow users to edit thier own items.  This setting takes precedence over any specific security permissions you've set.  YOu need to turn that off and manage permissions on each individual item in the list.

    Paul Stork SharePoint Server MVP
    Principal Architect: Blue Chip Consulting Group
    Blog: http://dontpapanic.com/blog
    Twitter: Follow @pstork
    Please remember to mark your question as "answered" if this solves your problem.

    • Proposed as answer by croute1 Monday, February 13, 2017 6:38 PM
    • Marked as answer by pointtoshare Tuesday, February 14, 2017 11:57 AM
    Monday, February 13, 2017 3:19 PM

All replies

  • I'm assuming you have the list settings configured so that only creators can view and edit their own items.  If that is the case then that will take precedence over any permissions you have set.  So in this case the managers with Contribute won't be able to see anything except the items they create.  This is by design.  To do waht you want you'll have to assign the View and Edit for the creators as a permission also and leave the list set to so that anyone, with permissions, can view and edit.

    Paul Stork SharePoint Server MVP
    Principal Architect: Blue Chip Consulting Group
    Blog: http://dontpapanic.com/blog
    Twitter: Follow @pstork
    Please remember to mark your question as "answered" if this solves your problem.

    Sunday, February 12, 2017 12:50 PM
  • Hi Paul,

    Thanks for your reply.

    I have set Contribute right to the Managers on the LIST but each Manager has "Full Control" permission to the ITEM they need to edit, this is the cases. 

    Would you please clarify a bit about the solution you suggest? 

    Sunday, February 12, 2017 3:08 PM
  • The problem is that you've set the list to only allow users to edit thier own items.  This setting takes precedence over any specific security permissions you've set.  YOu need to turn that off and manage permissions on each individual item in the list.

    Paul Stork SharePoint Server MVP
    Principal Architect: Blue Chip Consulting Group
    Blog: http://dontpapanic.com/blog
    Twitter: Follow @pstork
    Please remember to mark your question as "answered" if this solves your problem.

    • Proposed as answer by croute1 Monday, February 13, 2017 6:38 PM
    • Marked as answer by pointtoshare Tuesday, February 14, 2017 11:57 AM
    Monday, February 13, 2017 3:19 PM