locked
How to troubleshoot Windows Store device app for ARM tablet?

    Question

  • I am trying to replace a in-house camera device app with a new one. We are changing the app's source language from JS to C#, so we couldn't just make modifications over the old app and redeploy it.

    Right now, Windows seems to ignore the capabilities I placed on the device app and/or the device metadata file I installed, but it doesn't seem to be logging anything regarding a configuration error. I am not sure where to look to troubleshoot, so I am listing the steps I took.

    My understanding is that I have to do the following things to register an app as a device app:

    1. Declare a camera device app capability in the app's manifest
    2. Create a device metadata file, and place that in the tablet's metadata store
    3. Uninstall the camera driver
    4. Deploy the device app
    5. Reinstall the camera driver (it's an internal camera), then refresh devices
    6. Reboot the system

    Also, I am currently deploying the app from a remote machine. Does this not work, meaning that I must install the Windows Store app locally, from an app package?

    Is there something I am missing? If all these steps look valid, please let me know, and I will try to provide different details.

    Thanks!



    • Edited by __dong_ Wednesday, June 26, 2013 5:33 PM
    Tuesday, June 25, 2013 6:25 PM

Answers

  • Never mind, it was a tablet-specific issue. All the stated steps resulted in success when I tested on a different tablet.
    • Marked as answer by __dong_ Friday, June 28, 2013 12:04 AM
    Friday, June 28, 2013 12:04 AM