locked
Failed to register this test agent with the test controller RRS feed

  • Question

  • Hi,

    I've got that error when I tried setting the Test agent.

    My Testcontroller machine is in a workgroup and TestAgent is in a domain. I created a local administrator account with same user name, password on both two machines, and config Testcontroller  and TestAgent on that user, but test agent couldn't register to controller.

    I also added that user to TeamTestAgentService, TeamTestControllerUsers and TeamTestControllerAdmin group on Testcontroller machine.

    Please help me fix it!

    Thank you.

    Friday, December 12, 2014 1:31 PM

Answers

  • Hi roydude,

    Thank you so much for your solutions, but I have resolved this problem.

    These are steps I have done:

    1. Create a local administrator account loadtest/123456 on Controller machine, add to TeamTestAgentService group.

    2. Create a local administrator account loadtest/123456 (same name, pass with account on Controller machine) on Agent machine

    3. Log-in Controller Machine by this account:

    - Configure controller use this account

    - Add <add key="BindTo" value="controller machine IP"/> to QTController.exe.config

    - Restart testcontroller service

    4. Log-in Agent machine by this acount:

    - Add <add key="BindTo" value="agent machine IP"/> to QTAgentService.exe.config

    - Configure agent use this account. In Testcontroller name textbox, type "Controller machine IP: port (default 6901)"

    - Apply settings.

    ---

    I think my problem is in step 4 (bold text). I created a local account (loadtest), but logged in agent machine by domain account to configure agent. I must to log-in by "loadtest" account, same on controller machine.

    Hope help someone gets the same issues.

    Thank!

    • Marked as answer by Martin Vu Sunday, December 14, 2014 1:27 PM
    Sunday, December 14, 2014 1:27 PM

All replies

  • Hi,

    I've hit this issue before, along with many many other issue and the answer seems to vary. Hopefully one of these will do the trick (taken from my troubleshooting doc - I use Virtual Machines by the way, but it shouldn't be any different for a real machine):

           Remove the QTControllerConfig.xml file (do a search for it's location in program files).
           Make sure the Visual Studio Test Controller windows service is running (if you changed your password or login details, you may need to edit the properties of this service before starting it).
           Use MTM Test Lab to re-enter the passwords (make sure you’re using the details described above – sometimes the login names ‘reset’ back) and verify the settings before saving them.
           If you’re still having trouble, try using the Test Controller Configuration tool on the host machine and follow the instructions earlier in this document.
           If you’re still having trouble, I’ve found that starting the Agent on the VM manually sometimes works (the host gets incorrectly set to have the domain on the end – in the Agent config, make sure it’s just pcname:6901).
    If the environment gets stuck at 'not ready' in mtm...

    It seems that each time you create an environment, the controller<->agent relationship is given a GUID in the controller config file, so if you change the Agent config you will need to remove and recreate the test Manager Lab environment.

    I’ve found no ‘sure fire way’ to fix this, but here’s some of the steps I’ve taken which ultimately resolved the issue (either directly or indirectly – very hard to tell at which point it was ‘fixed’):

           In this order:
           Reset to a VM snapshot that worked (if you have one).
          Reconfigure the Agent on the VM.
           Remove and rebuild the environment for that VM in Lab Center.
           Reconfigure the Controller, then reconfigure the Agents (kill the agent first).
           Remove the environment and re-create it from scratch (I found I needed to do this if I created a cloned VM from one which was already part of an environment – it seems to get totally messed up until you re-created it).
           Back up and remove the current C:\Program Files (x86)\Microsoft Visual Studio 12.0\Common7\IDE\QTControllerConfig.xml, then reconfigure the test controller, then reconfigure the test agents.
    If the controller has issues connecting to TFS ...

    Try closing Test Manager, then reconfiguring the controller (one time, that was the only change I made and it worked).

    Lab environment seems ok but nothing starts ...


    If everything looks ok (agent is online, environment says ‘Running tests’ and there’s a test ‘In Progress’ for your environment), but the test never actually starts, Look in Lab -> Controllers. If you find there are 2 agents listed for your VM, delete the one that doesn’t have anything in the ‘Environment’ column.


    Friday, December 12, 2014 4:34 PM
  • Hi roydude,

    Thank you so much for your solutions, but I have resolved this problem.

    These are steps I have done:

    1. Create a local administrator account loadtest/123456 on Controller machine, add to TeamTestAgentService group.

    2. Create a local administrator account loadtest/123456 (same name, pass with account on Controller machine) on Agent machine

    3. Log-in Controller Machine by this account:

    - Configure controller use this account

    - Add <add key="BindTo" value="controller machine IP"/> to QTController.exe.config

    - Restart testcontroller service

    4. Log-in Agent machine by this acount:

    - Add <add key="BindTo" value="agent machine IP"/> to QTAgentService.exe.config

    - Configure agent use this account. In Testcontroller name textbox, type "Controller machine IP: port (default 6901)"

    - Apply settings.

    ---

    I think my problem is in step 4 (bold text). I created a local account (loadtest), but logged in agent machine by domain account to configure agent. I must to log-in by "loadtest" account, same on controller machine.

    Hope help someone gets the same issues.

    Thank!

    • Marked as answer by Martin Vu Sunday, December 14, 2014 1:27 PM
    Sunday, December 14, 2014 1:27 PM
  • Hi Martin,

    I am glad that you have solved the problem and thanks for your share us the solution here, so it would be helpful for other members who get the same issue.

    If you have any issues about MTM, welcome you post in this forum.

    Best Regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Monday, December 15, 2014 1:45 AM