locked
#Deleted Record error in a linked table (SharePoint list) RRS feed

  • Question

  • Hello,

    When opening a remote link table, UserInfo (from SharePoint list), it opens and shows the records for few seconds. After the few seconds, all records and field show "#Deleted".  Then I closed the table and reopen it, it is doing the same things.  Few seconds after, it displays "#deleted" in all the fields.  Then I deleted the linked table and relinked the table, but It is doing the exact same things. 

    I tried with other person computer, but their linked UserInfo table works fine.  By the way, I'm the sharepoint system administrator for our site collection.  Therefore, I have all the access right.

    Can anyone help?

    Thanks

    Friday, March 15, 2013 3:21 PM

Answers

  • Once upon a time (yes, like in a fairy tale) I had the same issue. I still don't know the reason for it because it has disappeared as magically as has appeared.

    Maybe some things to check:

    - network connection;

    - changing "Caching Web Service and SharePoint tables" options in File - Options - Current database;

    - compact and repair.


    Andrey V Artemyev | Saint-Petersburg, Russia
    Russian blog artemyev.biztoolbox.ru


    Friday, March 15, 2013 3:41 PM

All replies

  • Once upon a time (yes, like in a fairy tale) I had the same issue. I still don't know the reason for it because it has disappeared as magically as has appeared.

    Maybe some things to check:

    - network connection;

    - changing "Caching Web Service and SharePoint tables" options in File - Options - Current database;

    - compact and repair.


    Andrey V Artemyev | Saint-Petersburg, Russia
    Russian blog artemyev.biztoolbox.ru


    Friday, March 15, 2013 3:41 PM
  • Andrey,

    Thank you so much for your quick reply.  Currently, someone else has the laptop that I had problem with and he is not coming back until Tuesday.

    I will test your recommendations and will let you know.

    Thank you again for your help.

    Friday, March 15, 2013 4:05 PM
  • For those that continue to find this as the top search result may find it help to read my problem/solution...

    When you click Open with Access in SharePoint, the db opens in access but the table(s) do/does not. When I open the table, I had 14000+ entries, and if I start scrolling before all those entries load, all of it turns to #deleted.

    My simple work around was to wait for the count of items (lower left... Record 1 of x) to be displayed before starting to scroll.

    I'm sure something is hosed in that db, but I don't want to get near it... stupid access.

    Friday, January 6, 2017 10:20 PM
  • I realize this post is old, but if anyone runs into this problem just go to "More Options" table menu and ReLink list, in the new site box just type the same site then select your list, this re establishes the link.

    I tried all of the above solutions and none worked. Creating a new database worked so I realized it was not SharePoint. This was the first time this has happened in Access and it happened at a really bad time so I hope this helps someone.

    Tuesday, April 17, 2018 5:22 PM
  • Five years after your solution, it worked for me.  Thank you.  I unclicked that checkbox and magically - my tables are all back to normal.
    Tuesday, July 10, 2018 8:06 PM
  • Old  post or not, this is the only place I've found the solution suggested by rixmcx59 and it's just worked for me.  Thanks for your reply - much appreciated by me.

    Wednesday, August 1, 2018 9:46 AM
  • I had this problem with Office 365 SharePoint and Access 2016. The problem is that Access is loading a cached set of list items, and they are no longer in the online list.  Go to File --> Options. Select Current Database. Beneath "Use the cache format that is..." checkbox, check the two child checkboxes for Clear Cache on Close and also Never Cache.  Caching has its uses, but I've always found it problematic with large SharePpoint lists.  I am using Access to delete the records past 100,000 since I want to delete the list, and Microsoft in its infinite wisdom does not allow a list with more than 100,000 items to be deleted.  The Table-->More Options-->Relink Lists idea described in this thread did not help me, but not caching has.  Good luck to all those dealing with this problem.


    _Alex

    Update: I imply caching is not helpful with SharePoint lists, but I have found that turning it on for the database before using Access to append to the SharePoint list is useful. Without caching, when I upload 100,000+ items to a list via Access appending from an Excel worksheet, I usually get an out of resources error around 70,000 items uploaded and have to prune my file of those uploaded and restart the append. However, with caching turned on, I was able to upload my complete data set of about 205,000 items. In a previous upload, the same was true for another list upload of 147,000 items. So, caching does have its benefits of appending to a list from Excel, but not when trying to open the list to show all its current items.

    I hope my experiences help others who struggle with Access and large SharePoint lists.

    _Alex

    • Proposed as answer by A. Moseley Monday, October 8, 2018 1:35 AM
    • Edited by A. Moseley Thursday, October 11, 2018 3:10 PM
    Monday, October 8, 2018 1:35 AM
  • Had the issue too after a while with Office 2016

    The cache setting mentioned above made the trick
    Thursday, October 11, 2018 3:01 PM
  • Alex....YOU ARE A CAREER SAVER!  I have been searching for 3 days on how to fix this and your post is the only one I found like it.  I have 3 senior VPs that are waiting for me to finish my app that will save them 100+ hours a month but when I saw this #Delete stuff, I died and thought I am done.  Your solution to check the two child check boxes and for "Clear Cache on Close and also "Never Cache" worked.  For days, I have been trying everything I could find and nothing else worked.  

    THANK YOU!!!

    Will

    Saturday, January 5, 2019 5:43 AM
  • Thank you!!!

    Just fixed this issue with the cache setting changes specified by Alex. I am using SharePoint O365 and Access 2016. It was making me crazy that I couldn't link to the SP list!

    Thanks again!

    Friday, February 15, 2019 4:03 AM
  • Hi Alex,

    your suggestion worked for me as well, even though the Sharepoint list I tried to read is rather small with only 6500 entries.

    Thanks a lot!

    Monday, April 15, 2019 8:41 AM
  • This worked for me - Thanks!
    Thursday, May 16, 2019 4:45 PM
  • I also just wanted to thank you .. you saved me so much time for something I was struggling with at work.
    Thursday, June 20, 2019 11:05 PM
  • i experienced the same issue with access 2016 and sharepoint using a linked table. your solution checking the 2 checkboxes worked for me. thank you for your input.
    Friday, November 15, 2019 1:14 AM
  • I've had the same problem in MS Access 2016.

    The relink solution didn't appear to work (I'd checked it by opening the tables whereupon the "#deleted#" filed vals were all still present).

    However, I then opened a form that (first try) gave an error "restricted error -5012", but when I retried the table data appeared on the form, and then subsequently when I opened the table itself.  This has worked on other tables too so I have saved and backed up.


    Wednesday, November 20, 2019 3:08 PM