locked
sql server configuration manager RRS feed

  • Question

  • When I use sql server configuration manager to try and change my sql service accounts I get the following error "The specified network password is not correct [0x80070056].  The account is a domain account.  I have verified the password as correct.  The account is not disabled or locked out.  I have given this account the windows user rights that sql gives.  Can anyone help?
    Friday, June 4, 2010 8:45 PM

Answers

  • Hello Miralance,

    Yes, I am using the same book. Right now, AdventureWorks2008R2.exe is available from the codeplex website. With that you don't have to use the restore command. Download the setup file and configure the FILESTREAM option prior to installation. Check my post on how to enable FILESTREAM if its not enable during installation. Once the FILESTREAM is enabled, then you can start the installation and point the files to the path of your data files. After the installation is completed, refersh the SSMS. you should be able to see the Adventureworks databases, when you expand the database folder.

    Hope, this may help.


    SKG: Please Marked as Answered, if it resolves your issue.
    • Proposed as answer by Miralance Tuesday, June 8, 2010 10:08 AM
    • Marked as answer by Alex Feng (SQL) Tuesday, August 17, 2010 8:00 AM
    Tuesday, June 8, 2010 9:37 AM

All replies

  • How are you entering the domain user?  Are you using <domain>\<username>, or are you using <username>@<domain>?  If the latter, try using the former and see if that works.
    "galacticabsg75" wrote in message news:e084f75c-5c4c-4f95-92e9-ec163e4a2a03...
    When I use sql server configuration manager to try and change my sql service accounts I get the following error "The specified network password is not correct [0x80070056].  The account is a domain account.  I have verified the password as correct.  The account is not disabled or locked out.  I have given this account the windows user rights that sql gives.  Can anyone help?
    Saturday, June 5, 2010 1:49 AM
  • I tried domain\username and username.  I did not try username@domain.  I'll give that a try.

    Thanks

     

    Saturday, June 5, 2010 7:23 PM
  • Hi,

    You may fails to change the SQL Server service account via input the domain user name directly input the Account Name: text box in the SQL Server (<Instance Name>) Properties dialog box. Please try:

    1.        In the SQL Server (<Instance Name>) Properties dialog box, click Browse button

    2.        In the Select User or Group dialog box, change the Locations to your domain node, and input the domain name in the Enter the object name to select text box and click Check Name to make sure you input the correct domain name, and then click ok

    3.        Now back to the SQL Server (<Instance Name>) Properties dialog box, input the password of this domain account, click Apply or OK to apply changes.

    4.        Restart SQL Server services to take effect.

    If you need more help, please let me know.

    Regards,
    Chunsong


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Monday, June 7, 2010 7:40 AM
  • ChunSong Feng,

    I've got a related problem with galacticabsg. I wanted to change the password of the service account in my SQL Server. However, what appear is also the same with galacticabsg..

    "The specified network password is not correct [0x80070056]. " I already tried what you wrote in which to go to the select user or group dialog box... but still I can't change the password..

     

    A very much thank you for an answer.

    Regards,

    Blue Sapphire

    Monday, June 7, 2010 9:13 AM
  • Hi Miralance,

    Once you selected the domain account in the Select User or Group dialog box and click OK, then you should back to  SQL Server (<Instance Name>) Properties dialog box and you could manually input password there.

    Could you please post a screen shot or link here?

    Regards,
    Chunsong


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Monday, June 7, 2010 9:57 AM
  • Hi Chunsong,

    I did that chunsong, but still the same, however when I use the old password, it works.. I just doesn't change the password..

    It just post the WMI Provider Error with a message:

    "The specified network password is not correct [0x80070056]. "

     

    Thanks Chunsong.

     

    Regards,

    Miralance

    Monday, June 7, 2010 10:35 AM
  • Hi,

    I think you need to check the service accounts properties in Computer Management / AD User and Computers depending on whether you are using a local user account or a domain account. You can have a look at the following thread, which talks about the same issue.

    http://social.msdn.microsoft.com/Forums/en-US/sqlgetstarted/thread/70f30d9e-fd83-4e93-b599-e69617ae2291

    Hope this may help.


    SKG: Please Marked as Answered, if it resolves your issue.
    Monday, June 7, 2010 11:41 AM
  • Additional Considerations for Changing SQL Server 2008 Service Accounts

    • SQL Server 2008 running on Windows Server 2003 and Windows XP

      Changing the service account that is used by SQL Server or the SQL Server Agent requires SQL Server Configuration Manager to perform the following steps:

      1. Stop SQL Server if it is running. - in the command prompt type: net stop MSSQLSERVER (for default instance of server) or net stop MSSQL$instancename

      2. Restart SQL Server in single-user mode. in the command prompt type sqlservr.exe -m  or sqlservr.exe -m -s instancename

      3. Connect to SQL Server. using management studio

      4. Provision the new service account for the service (add the new service login) as a member of the sysadmin fixed server role.

      5. Disable the old service account login inside SQL Server.

      6. Disconnect from SQL Server.

      7. Stop SQL Server. - in the command prompt type: net stop MSSQLSERVER (for default instance of server) or net stop MSSQL$instancename

      8. Restart SQL Server in normal user mode. in the command prompt type sqlservr.exe   or sqlservr.exe  -s instancename

    • hope this could help.. don't forget to check as an answer for the benefit of the others.. thanks..

    Regards,

    Miralance

    Monday, June 7, 2010 11:50 AM
  • we don't have to stop the sql instance while changing the service account passwords. With SQL Server 2008, the new credential settings for SQL Server services will take effect without restarting the instance. Make sure, you change the password using SQL Server Configuration Manager.
    SKG: Please Marked as Answered, if it resolves your issue.
    Monday, June 7, 2010 12:10 PM
  • we don't have to stop the sql instance while changing the service account passwords. With SQL Server 2008, the new credential settings for SQL Server services will take effect without restarting the instance. Make sure, you change the password using SQL Server Configuration Manager.
    SKG: Please Marked as Answered, if it resolves your issue.


    This is something strange to me !

    In all versions of SQL server the service account change effects only after a SQL RESTART.
    when you change the service account and click the APPLY or OK button - it will you prompt you that this will take effect only after a restart.


    Thanks, Leks
    Monday, June 7, 2010 11:27 PM
  • Hello Leks,

    This is a new feature of SQL Server 2008. Now we can change the Sevice account passwords without restarting the SQL Server instance, although we need to use SQL Server Configuration Manager for the same. I have tested the same thing in our test environment last evening. I read about it in MS Press book SQL Server 2008 Implementation and Maintenance (Page- 20).

    After changing the password of the service accounts using SSMS, you will no longer asked to restart the SQL Server instance.

    You can give a try... really cool feature...


    SKG: Please Marked as Answered, if it resolves your issue.
    Tuesday, June 8, 2010 4:10 AM
  • You are correct , i have confused with changing the password and changing the service account .
    Thanks, Leks
    Tuesday, June 8, 2010 4:33 AM
  • Hi Sudeepta,

    Are you using the MS SQL Server 2008 Implementation and maintenance written by Mike Hotek?

    Coz if u are, i have a question on it about the downloading adventureworks2008.. coz in the book, the adventureworks2008 to be downloaded is the .msi, however in the site, it is already Adventurewor2008R2.exe.. And when i downloaded that file, i couldn't find the adventureworks2008.bak and AdventureWorksDW2008.bak which are written in the book.

    Hope you can help me with this..

    Thanks a lot bro.

     

    Regards,

     

    Miralance

    Tuesday, June 8, 2010 9:13 AM
  • Hello Miralance,

    Yes, I am using the same book. Right now, AdventureWorks2008R2.exe is available from the codeplex website. With that you don't have to use the restore command. Download the setup file and configure the FILESTREAM option prior to installation. Check my post on how to enable FILESTREAM if its not enable during installation. Once the FILESTREAM is enabled, then you can start the installation and point the files to the path of your data files. After the installation is completed, refersh the SSMS. you should be able to see the Adventureworks databases, when you expand the database folder.

    Hope, this may help.


    SKG: Please Marked as Answered, if it resolves your issue.
    • Proposed as answer by Miralance Tuesday, June 8, 2010 10:08 AM
    • Marked as answer by Alex Feng (SQL) Tuesday, August 17, 2010 8:00 AM
    Tuesday, June 8, 2010 9:37 AM
  • Hello Sudeepta,

    Thanks a lot for the information bro.. it really helps me very much.. I can see now the adventureworks2008 in the database..

     

    I have posted another question.. if you don't mind please answer that for me..  The title is: Database mail of SQL 2008 not working.

     

    I'm sorry if I post so many questions.. I'm just starting to learn SQL 2008 and I don't have any background yet about SQL...

     

    Thanks a lot bro..

     

    Regards,

     

    Miralance

    Tuesday, June 8, 2010 10:08 AM
  • I will check if I can answer.... Even I am learning by answering your question... Learning never ends....

    Happy Learning.....


    SKG: Please Marked as Answered, if it resolves your issue.
    Tuesday, June 8, 2010 10:29 AM
  • I have replied to your question. Not a very specific though.

    Happy Learning...


    SKG: Please Marked as Answered, if it resolves your issue.
    Tuesday, June 8, 2010 10:44 AM